Instalacja Windows 10 zamiast Linuxa - Nie bootuje DVD


(Layffe) #1

Witam!

Musiałem wymienić dysk w laptopie na stary, używany 160GB HDD.
Dysk za pomocą innego PC wyczyściłem całkowicie narzędziem GParted - także partycję Recovery i UEFI (co ważne) ponieważ zamierzałem tam postawić Linuxa, co się nawet udało. Niestety, osoba która używa laptopa jest przyzwyczajona do Windowsa, tak więc dlatego za pomocą narzędzia Media Creation Tool pobrałem .iso Windowsa 10 i utworzyłem bootowalne DVD za pomocą narzędzia Windows. Płyta sprawdzona na działającym lapku - bootuje, więc nie ma problemu, a jednak…
Na PC który naprawiamy, w trybie Legacy bootuje na Linuxa (DVD jest w ogóle rozpoznawalne w Linuxie jako puste) a na UEFI… no właśnie, jedyna dostępna opcja boot to Network IPv4 i IPv6. Proszę o pomoc, bo nie jestem sobie w stanie z tym poradzić.

Klucz do 10 mam zapisany - wydobyłem przy jakiejś okazji programem do wyciągania klucza systemu, choć nigdy nie wpisywałem, bo był zapisany w UEFI, teraz wnioskuje że będę musiał wpisywać (klucz jeszcze do 8.1 sprzed upgrade).

Pozdrawiam i dziękuje za pomoc!


(Aziczek) #2

Za mało na temat sprzętu, z którego bootujesz W10. Podmień napęd DVD - to z reguły jedna śrubka, czasami pod “klapką” od spodu obudowy. 4 - 5 śrubek max.
Kombinacja F12, F11 przy starcie laptopa nie działa? Tzw. Boot Menu.
P.S.

To w końcu laptop czy PC bo można się pogubić?


(Kurp55) #3

W biosie wyłącz secure boot.


(Layffe) #4

@Aziczek
To laptop. Wybacz, z przyzwyczajenia nazywam laptopy PC’tami. Napędu DVD nie trzeba wymieniać, ponieważ wykrywany jest w BIOS’ie. F11, F12 nie sprawdzałem, natomiast do BIOSu da się wejść, zaraz rzucę okiem.

@Kurp55
Jest wyłączona ta opcja.


(JNJN) #5

Boot menu i wybierz start z napędu DVD.

Lub w biosie ustaw bootowanie jako pierwsze z napędu DVD i zapisz bios Save.

Dysk w biosie widoczny?


(Layffe) #6

@JNJN
Właśnie w tym problem, kiedy wybieram w BIOS tryb Legacy i daję DVD na na pierwsze miejsce boot listy przed Ubuntu, to laptop ignoruje DVD i od razu bootuje Linuxa.

Natomiast w UEFI nie mam nawet opcji przy boot liście innych niż Network (IPv4 i IPv6) - nie ma ani HDD, ani DVD. Po prostu nic.


(JNJN) #7

A to spece od Linuksa muszą się wypowiedzieć.

Rozumiem, że chcesz mieć Linuksa i W10?

A jak tylko sam W10, wyzeruj dysk dowolna metoda i instaluj W10.


(pocolog) #8

Linux czy zerowanie dysku nie ma tu nic do rzeczy, sprawa dotyczy ustawień BIOS/UEFI, które nie dopuszcza bootowania z płyty DVD. Prawdopodobnie po wyczyszczeniu dysku zamiast Linuksa pojawi się komunikat o braku systemu operacyjnego, bo dalej będzie ignorowało DVD.
Może gdyby kolega podał, jaka to płyta główna/jaki bios to byłby łatwiej doradzić ustawienia, ewentualnie zdjęcia z ustawień BIOS.


(Aziczek) #9

Secure Boot masz na disabled? Podaj w końcu markę i model laptopa, na dzień dobry ktoś Ci da rozwiązanie. Za #pocolog


(JNJN) #10

Ależ napisał, że działa w trybie Legacy, tylko widać zainstalowany na dysku linuks, nie pozwala uruchomić instalatora z W10?

I zdarzało się tak, że jak nowe komputery miały zainstalowany Linuks, to nieraz trzeba było najpierw wyczyścić dysk i dopiero ruszył instalator systemu.


(pocolog) #11

Ty tak na poważnie? Wiesz, że UEFI/BIOS odpala się wcześniej niż system z dysku?


(JNJN) #12

Normalnie , nie… wiedziałem - bardzo dziękuję za przypomnienie.

Reasumując:
Jak dysk będziesz miał wyzerowany i instalator nie ruszy to:

  • płyta DVD z systemem
  • napęd uszkodzony
  • ustawienia w biosie, tryb Legacy, ma być widoczny w biosie i bootmenu, napęd DVD i dysk.

(pocolog) #13

Służę radą uprzejmie i polecam się na przyszłość :stuck_out_tongue_winking_eye:

ps.
Moim zdaniem problem ewidentnie leży po stronie użytkownika. Poczekajmy, aż “wypróbuje” quick boot menu, które może rozwiązać jego problem :wink:


(Domker) #14

Po pierwsze nie wiemy nic o UEFI/BIOS jaki tam siedzi, ani nie znamy także modelu laptopa.
Możliwości jest co najmniej kilka.
Pierwsza najbardziej prawdopodobna to traktowanie urządzeń bootujących w trybie UEFI priorytetowo. (“UEFI First” prawdopodobnie w ustawieniach CSM)
Czyli najpierw start wszystkiego, co bootuje w trybie UEFI, a potem nośniki z BIOS Legacy.

Po drugie nie wiemy, czy płytka jest prawidłowo przygotowana lub czy nie jest uszkodzona.
Trzeba by było to zweryfikować na innym komputerze z włączonym trybie BIOS Legacy.

Po trzecie niech autor wątku najlepiej przygotuje sobie pendrive Rufusem z najnowszym obrazem Windows 10 pod tryb UEFI i spróbuje z wyłączonym BIOS Legacy.

Linux nie ma tu znaczenia. W trybie UEFI jak był instalowany to dodaje plik do partycji ESP: grubx64.efi ewentualnie shimx64.efi dla trybu Secure Boot. A w trybie Legacy BIOS wpis w MBR wskazujący na GRUBa.


(Layffe) #15

Panowie, spokojnie. :wink:
Więc po kolei:

  • Model laptopa: Lenovo G710
  • Wersja BIOS: Dostarczona przed producenta, nieaktualizowana.

Zaznaczyłem wyżej, że Linuxa chcę się pozbyć całkowicie.

Co do quick boot menu (F12):
Mam tam 3 opcje: 1. Sata HDD 2. Sata ODD 3. Network Boot
Zarówno HDD jak i ODD po wybraniu przechodzą od razu do GRUB’a gdzie mogę uruchomić system, memtest itp.
Podczas tych restartów i metody prób i błędów pojawiła się jeden jedyny raz opcja numer 4, EFI DVD/CD Boot, która zaskoczyła i uruchomiła instalator Windowsa, po czym zaliczyła ‘‘freeze’’ przy przygotowywaniu instalatora i po restarcie już tej opcji w quick boot menu nie było.

Myślę, może całkowity reset biosu poprzez wyciągniecie baterii na 20 minut by pomógł?

//Edit: Nie bardzo mam teraz opcję wykonać bootowalny pendrive.


(pocolog) #16

Jesteś pewny, że napęd DVD jest sprawny, a płyta którą przygotowałeś nie jest uszkodzona?


(Layffe) #17

Napęd 100% sprawny ponieważ inne płyty czyta bez problemu.
Płyta także 100% sprawna, nagrana narzędziem Windows i działająca w innym laptopie (także Lenovo).

Update: Opcja EFI DVD/CD Boot pojawia się gdy w BIOS ustawimy Legacy -> Legacy First.

Przyznam, że powoli kończą mi się pomysły…


(JNJN) #18

Zerowanie dysku z linuksem.

Sprawdź, czy kontroler sata w biosie jest w trybie AHCI.

Może faktycznie reset biosu.


(Layffe) #19

Udało mi się uruchomić instalator Windowsa, ten jednak stoi na ‘‘uruchamianie programu instalacyjnego’’. Jeśli przez jeszcze 1h będzie tak stać, wykonam reset biosu.


(Domker) #20

Nie baw się z płytą tylko wgraj Rufusem obraz ISO Windows 10 na pendrive metodą dla UEFI i w wyłącz na lapku BIOS Legacy.
Powinno zaskoczyć bez problemu żadnego.
https://rufus.akeo.ie/