Instalator Windows XP nie widzi dysku SATA

Witam, mam problem z instalacją Windowsa XP już mówię o co chodzi.
Znajomy zgrał mi na płyte Windowsa XP, wszystko odpaliło się normalnie do czasu gdy był początek instalacji, wszystkie sterowniki się wgrały na początku i tak dalej ale później instalator wyrzucił mi błąd że nie wykrył żadnego dysku twardego, co mnie zdziwiło bo dysk był widoczny normalnie.
Mam jeszcze dwa inne dyski też na SATA ale to o nich pozniej powiem :grin:

Instalator XP nie obsługuje SATA. Trzeba albo podczas instalacji dodać odpowiednie sterowniki, albo zintegrować je z płytą instalacyjną.

Trzeba to się przeprosić z floppem :joy:

3lajki

Ej ale serio ma ktos jakis pomysl?

Przecież już wyżej dostałeś odpowiedź:

1lajk

Bo mam jeszcze Windowsa 7 na pendriva i na płycie ale tego i tego i chce ruszyć

czego nie rozumiesz w przedstawionej odpowiedzi?

Próbowałeś w BIOSie przełączyć obsługę dysku w tryb IDE?

Powiedz może jeszcze czy dysk jest HDD, czy SSD i jaki procek masz. W przypadku ssd i np. czegoś z ostatnich 7 lat, to masz gwarantowane braki zgodności, wiem przerabiałem :wink:

SP2 i SP3 już obsługuje.

1lajk

Obsługuje, ale sterowniki i tak trzeba zintegrować, bo inaczej dysk w czasie instalacji nie będzie możliwy do wykrycia.

1lajk

Czyli jak ja instalowałem XP na wielu komputerach?

W trybie IDE?

Dyski były SATA.

Win Xp bez dodatkowych sterowników obsługuje dyski SATA jeśli w biosie jest ustawiony tryb IDE MODE (nazwa może być inna w zależności od biosu).
Jeśli ustawisz SATA w tryb AHCI lub RAID to będziesz potrzebował dodatkowych sterowników na dyskietce lub będziesz je musiał zintegrować z instalatorem systemu.

Chyba macie rację, bo to raczej były tanie płyty główne, pewnie żadna z nich nie miała czegoś takiego jak AHCI.

Wielokrotnie instalowałem XP (nie pamiętam tylko jaki SP) na wielu różnych komputerach z dyskiem SATA, nigdy nie robił problemów. Oczywiście w trybie IDE.
Czyli jest proste rozwiązanie - przestawić w BIOS tryb z AHCI na IDE.

Oczywiście że działa, nawet W2000 działa bez problemu z dyskiem SATA (wszystko jedno czy HDD, czy SSD) ustawionym w tryb IDE.

Trzeba tylko pamiętać, że korzystając z IDE dysk nieco traci na wydajności. Na przykład nie działa NCQ. Nawet na blogu ktoś kiedyś robił testy, jak wyglądają prędkości na dysku działającym w trybie IDE i w trybie AHCI.

Dzięki za odpowiedzi ale udało mi się odpalić mają starą płytę główną i poszło wszystko normalnie :smiley: