Intel i3 : 2 rdzenie, 4 wątki - widoczne jedynie 2 wątki. Powód?


(_tommy_) #1

Witam.


(bart86) #2

a skąd wniosek że masz 2 wątkowe rdzenie w procesorze? system przecież tego nie pokazuje


(witek-pl) #3

@bart86 wniosek stąd że ten i3 ma dwa rdzenie i HT więc powinny być cztery wykresy. Sprawdź jeszcze programikiem CPU-Z co on pokazuje. 


(Łukash) #4

Może w BIOS jest wyłączony Hyper-Threading.


(_tommy_) #5

@bart86 

 

Każdy i3 jeśli ma HT to wykres z menedżerze pokazuje 4 wątki, proste. 

 

@Łukash

 

Myślisz, że w BIOSie to jest wyłączone?

 

 

A, zapomniałbym.

System - Windows 7 64 bit

Laptop - Sony Vaio, model VPCEH1M1E


(Łukash) #6

@_tommy_ najprawdopodobniej tak.


(_tommy_) #7

Bios jest tak biedny, że praktycznie nie ma czego włączyć lub wyłączyć. 

Przynajmniej z poziomu użytkownika nie dostrzegam opcji którą mógłbym ewentualnie włączyć :expressionless:

 

Jest to procesor drugiej generacji. Informacja jest jasna na stronie Intela - 2 rdzenie, 4 wątki, wsparcie technologii Hyperthreading…

 

Serio, zgłupiałem…

ibxnnn.jpg

Sam niedowierzam temu co widzę :expressionless:


(Osimaru) #8

W menedżerze urządzeń też widzi tylko dwa rdzenie? Sprawdź czy masz najnowszą wersję BIOSu.


(_tommy_) #9

Wg VAIO Update nie mam żadnych aktualizacji, nawet do BIOSu.

 

W menedżerze wygląda to tak, wg mnie jest ok, ale dlaczego menedżer zadań pokazuje inaczej?

96cfp3.jpg


(Osimaru) #10

Wejdź w Opcje Zasilania i ustaw plan zasilania Wysoka wydajność.

Jeśli to nic nie da, wejdź do BIOS-u i przywróć domyślne ustawienia - napisz jak efekty.

 

Sprawdź w CPU-Z ile rdzeni/wątków wykrywa. Jeśli wykrywa 2 rdzenie 2 wątki to coś z samym HT, Jeśli jeden rdzeń i dwa wątki to coś jest z jednym rdzeniem (niekoniecznie od strony sprzętowej)

 

Wyczytałem gdzieś również, że czasem Windows 7 x64 płata takie figle, na co lekarstwem jest reinstalacja systemu.

 

@edit:

 

Spróbuj jeszcze msconfig - rozruch - opcje zaawansowane - zdejmij ptaszka w okienku “liczba procesorów”


(Dimatheus) #11

Hej,

A dla ciekawości sprawdź, ile rdzeni logicznych wykrywa na przykład Process Exporer.

Pozdrawiam,

Dimatheus


(_tommy_) #12

Dobra, zrobiłem na skróty :wink:

 

Pierwsze co to polecił @Osimaru , wyłączyłem poprzez msconfig “liczbę procesorów”, zrobiłem reset i okazuje się, że teraz menedżer zadań widzi to tak:

http://i40.tinypic.com/2rcslg2.jpg

Wygląda to obiecująco :wink:

 

Tylko teraz pada pytanie, czy aby odhaczenie opcji pokazywania “liczby procesorów” nie będzie miało w jakimś wpływu na stabilność całego systemu? Czy w ogóle będzie to jakoś interpretowane przez sam system? 

 

@Dimatheus

Sprawdziłem, ale nie wiem czy o to Tobie chodziło :wink:

http://i39.tinypic.com/243fapv.jpg


(Dimatheus) #13

Hej,

Nie, nie powinno mieć żadnego negatywnego wpływu na stabilność systemu. Zresztą wydaje mi się, że problem był tylko w wyświetlaniu danych, a i tak system korzystał zarówno z dwóch rdzeni fizycznych, jak i HT.

Pozdrawiam,

Dimatheus


(_tommy_) #14

@Dimatheus

Nie wiem, do końca nie byłbym tego taki pewien. Może z 2 rdzeni sobie korzystał ale czy HT było wykorzystywane? Nie wiem, a pewności nie mam :wink:

 

Dziwiła mnie ta sytuacja, ponieważ w innych laptopach widziałem normalnie 4 wątki, klasycznie, jak pokazałem w obrazku kilka postów wyżej. W tym Sony niepokoiło mnie to, że tak wyświetlany jest stan procesora. 

 

Co by nie było, dziękuję za pomoc :wink:

Po raz kolejny forum dobrychprogramów okazuje się pomocne :wink:

 

Pozdrawiam :wink:


(Dimatheus) #15

Hej,

Dlatego prosiłem o sprawdzenie w Process Explorerze, ale przed dokonaniem jakiś zmian. Teraz już bez znaczenia. :wink:

Pozdrawiam,

Dimatheus


(Osimaru) #16

Z tego co czytałem to czasami Windows 7 właśnie płata takie figle, raz pomaga któreś z wymienionych rozwiązań, innym razem trzeba reinstalować, a w skrajnych przypadkach okazuje się że to jednak fizyczne uszkodzenie procesora, ale akurat temu Windows winien nie jest :slight_smile: