IntelliJ problem z wyświetlaniem czcionki lub językiem


(kop524) #1

Witam otóż używam IntelliJ Idea do projektów na uczelni ale od wczoraj mam problem z wyświetlaniem jakichkolwiek liter(https://scr.hu/DD0krj) tak jak na linku i nie mogę nic z tym zrobić :frowning:
System W10 Home x64

Proszę o pomoc.


(blumberplumber) #2

Albo zła strona kodowa ustawiona, albo uszkodzony plik języka. Zacznij od reinstalacji JDK - przy okazji zaktualizujesz sobie do najnowszej wersji :slight_smile:. Jeśli to nie pomoże, to czeka cię reinstalacja całego IntelliJ - przynajmniej ja tak bym zrobił. Oczywiście skopiuj sobie swoje projekty, żebyś nie stracił swoich plików.


(kop524) #3

JDK świeżo instalowane, a IntelliJ kilka minut temu reinstalowane dodatkowo z usuwaniem przez iobit uninstaller i reinstalowane na earlu access i nadal to samo :frowning: A może to być przez to, że zmieniłem czcionk ę systemu na Consolas? Jeśli tak to dziwne bo zawsze ją miałem ustawioną z powodu wygody i nie było z niczym problemu. Dopiero po reinstalce W10 mi to się zaczęło dziać 8-(


(krystian3w) #4

A może to być przez to, że zmieniłem czcionkę systemu na Consolas?

Jak w konsoli (cmd) to raczej nie.


(blumberplumber) #5

Zmień na razie font na inny i zobaczysz, czy rozwiąże to twój problem. Czcionki też mogą takie figle robić - zwłaszcza, jak pobierasz je z nieznanych źródeł. Polecam poszukać podobnego kroju na np. Google Fonts.


(krystian3w) #6

Consolas to czcionka wbudowana w system:

obraz


(kop524) #7

Dokładnie a poza tym najlepsze jest to, że IDEA ma też możliwość ustawienia czcionki Consolas w opcjach XD

Zmieniałem przez rejestr.
Skrypt regedit jakiego użyłem:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
“Segoe UI (TrueType)”=""
“Segoe UI (TrueType)”=""
“Segoe UI Black (TrueType)”=""
“Segoe UI Black Italic (TrueType)”=""
“Segoe UI Bold (TrueType)”=""
“Segoe UI Bold Italic (TrueType)”=""
“Segoe UI Historic (TrueType)”=""
“Segoe UI Italic (TrueType)”=""
“Segoe UI Light (TrueType)”=""
“Segoe UI Light Italic (TrueType)”=""
“Segoe UI Semibold (TrueType)”=""
“Segoe UI Semibold Italic (TrueType)”=""
“Segoe UI Semilight (TrueType)”=""
“Segoe UI Semilight Italic (TrueType)”=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
“Segoe UI”=“Consolas”


(krystian3w) #8

To przy tych pierwszych można spróbować cofnąć opróżnianie a tą drugą usunąć (raczej domyślnie go nie ma w rejestrze):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"Segoe UI (TrueType)"="segoeui.ttf"
"Segoe UI Black (TrueType)"="seguibl.ttf"
"Segoe UI Black Italic (TrueType)"="seguibli.ttf"
"Segoe UI Bold (TrueType)"="segoeuib.ttf"
"Segoe UI Bold Italic (TrueType)"="segoeuiz.ttf"
"Segoe UI Emoji (TrueType)"="seguiemj.ttf"
"Segoe UI Historic (TrueType)"="seguihis.ttf"
"Segoe UI Italic (TrueType)"="segoeuii.ttf"
"Segoe UI Light (TrueType)"="segoeuil.ttf"
"Segoe UI Light Italic (TrueType)"="seguili.ttf"
"Segoe UI Semibold (TrueType)"="seguisb.ttf"
"Segoe UI Semibold Italic (TrueType)"="seguisbi.ttf"
"Segoe UI Semilight (TrueType)"="segoeuisl.ttf"
"Segoe UI Semilight Italic (TrueType)"="seguisli.ttf"
"Segoe UI Symbol (TrueType)"="seguisym.ttf"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"Segoe UI"=-

(kop524) #9

Za jakiś czas uruchomię ponownie kompa to zobczę :slight_smile: Do usłyszenia.

EDIT: Po restearcie jest normalnie O_O