Iplus (modem GC79) w Ubuntu 7.04


(Toxek1) #1

Właśnie wczoraj zainstalowałem se Linux Ubuntu 7.04, ale nie umiem skonfigurować tam swojego modemu z Iplusa GC79. Byłem już na forum Ubuntu. I jak ja to zrobiłem:

Plik Iplus w /etc/ppp/peers/iplus:

noauth

connect "/usr/sbin/chat -v -f /etc/ppp/iplus-connect"

disconnect "/usr/sbin/chat -v -f /etc/ppp/iplus-disconnect"

debug

/dev/ttyS0

115200

defaultroute

crtscts

lock

local

nodetach

usepeerdns

lcp-echo-failure 4

lcp-echo-interval 65535

Plik iplus-connect w /etc/ppp/iplus-connect:

TIMEOUT 600

ABORT 'BUSY'

ABORT 'NO ANSWER'

ABORT 'ERROR'

SAY 'Starting GPRS connect script\n'

"" 'AT+CFUN=1,1'

"" 'AT+CPIN=2047'

OK 'ATE1\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d'

SAY 'Setting APN\n'

OK 'AT+CGDCONT=1,"IP","www.plusgsm.pl"'

ABORT 'NO CARRIER'

SAY 'Dialing...\n'

OK 'ATD*99***1#'

Plik iplus-disconnect w /etc/ppp/iplus-disconnect:

"" "\K"

"" "+++ATH0"

SAY "GPRS Disconnected."

Wchodze na terminal i wpisuje: sudo PPPD CALL IPLUS, podaje hasło do roota i wyskakuje mi, command not found.

Może mi ktoś pomóc i wytłumaczyć, gdzie jest mój błąd.

Proszę o pomoc.


(nintyfan) #2

W GNU/Linux rozróżniane są wielkie i małe litery. Dlatego piszesz:

sudo pppd call iplus

gdyby jeszcze coś ci nie działało, sprawdź czy jądro widzi ci modem pod /dev/ttyS0, a nie przypadkiem,np. /dev/ttyS4:

dmesg | grep ttyS

chyba pomogłem.