Jak poprawnie zaktualizować .NET Frameworka w Windows 7?


(H@wkeye) #1

Mam pytanie. Czy jeśli w Windows 7 64-bit posiadam zainstalowane wersje platform .NET Framework 4 Client Profile i Extended, nie mam natomiast zainstalowanej wersji .NET Framework 4.5 , to czy mogę pobrać dostępną w witrynie opcjonalną podkreślam aktualizację tej wersji 4.5 czyli 4.5. 1 , czy też muszę wcześniej pobrać samą tę wersję 4.5 z MS Download Center ?

To jest pierwsze pytanie.

 

A drugie. Czy wersja 4.5 całkowicie zastąpi wersje 4 .NET Frameworka ? :squarewink:


(errata72) #2
  1. Można inaczej . Obie wersje były dostępne poprzez WU jako automatyczne aktualizacje.

  2. Każda wersja żyje własnym życiem.Jedne programy potrzebują środowiska NET.3.5 a inne 4.5.1.Warto mieć wszystkie.

Aby mieć 4.5.1 trzeba mieć 4.5


(system) #3

Nie zamęczaj się problemem lecz otwórz Windows Update > Wyszukaj aktualizacje i zastosuj to, co będzie zaproponowane.


(H@wkeye) #4

Jasne rozumiem, ale pytanie było inne - czy nim pobiorę z WU tę opcjonalną nie automatyczną poprawkę wersji 4.5.1 muszę wpierw zainstalować wersję bazową czyli .NET Framework 4.5 bo obecnie jej nie posiadam ?

 

Co do drugiej części pytania to rozumiem, że są to odmienne wersje i jedna ta wyższa nie zastąpi niższej ?


(system) #5

Tym też nie musisz się przejmować! Pobierz to, co poleca witryna Windows Update (nawet jeśli opcjonalnie). Jeśli system pobierze i zainstaluje, to jest OK.


(H@wkeye) #6

Ok., pobrałem tę aktualizację 4.5.1 i tak jak wspomniałem bo czytałem to na stronie MS jednak ta wersja 4.5.1 teraz może nie tyle zastąpiła co uaktualniła te wersje 4 http://www.dobreprogramy.pl/.NET-Framework,Program,Windows,35626.html.

W tej chwili w Panelu sterowania mam tylko tę wersję .NET Framework 4.5.1, tamtych wcześniejszych nie ma.

Ale jednocześnie na tej samej stronie pisze iż wersja ta jest wysoce zgodna i zaktualizowana względem 4, także zapewne jest dobrze. :ok: