Jak ręcznie zainstalować dodatek do Firefox w Ubuntu 16.04?


(sajmon17099) #1

Witam. Chciałbym zainstalować nowego Flash Playera, domyślny jest w przestarzałej wersji a właśnie wyszedł nowy. Tylko że jest on w pliku .so. I wszędzie w internecie pisze żebym wrzucił ten plugin do folderu z pluginami, tylko że w ogóle nie wiem gdzie on jest. Na pewno nie jest w ~/mozilla i gdzieś w /usr/lib/firefox/browser/plugins, a nawet jak tam jest to niestety, skopiowanie tam pliku .so nic nie daje.

I wiem że Flash jest przestarzały i niebezpieczny, ale jest mi potrzebny, bo niestety ale wiele stron dalej go używa (m.in. southpark.cc.com). Do tej pory do takich celów używałem Chrome, ale ciągłe zmienianie okienek z Firefox na Chrome i z powrotem jest męczące.

I nie, nie proponujcie mi żebym się przesiadł z Firefoxa na Chrome'a, po prostu wolę Firefoxa.

 

EDIT: Coś mi się zdaje że powinienem napisać ten temat w dziale "Problemy z oprogramowaniem", ale w tym przypadku korzystam z wersji Firefox na Linuxa, i katalogi są kompletnie indziej niż w Windows.


(p19koz) #2

zapewne używasz wersji 64 bitowej. Ścieżka dostępu w tym przypadku wygląda tak:

 

/usr/lib64/firefox/browser/plugins/


(sajmon17099) #3

Problem jest w tym że już to kiedyś sprawdzałem i nie ma u mnie katalogu lib64.

I tak, mam 64 bitowe Ubuntu.


(saturno) #4

https://forum.dobreprogramy.pl/jak-zainstalowac-adobe-flash-player-na-debianie-470624t.html

 


(sajmon17099) #5

Uwielbiam tę pomoc na forum, lubię gdy ktoś wcale nie czyta tematu.

To jest stare. Ostatnio wyszedł nowy flash i muszę go zainstalować z pliku .so. Przeczytaj jakie katalogi u mnie nic nie dają, a potem odpowiedz.


(saturno) #6

A to już nie moja wina, że wcale nie przeczytałeś tematu do którego dostałeś link!

Jest tam dokładnie napisane do jakiego katalogu masz skopiować plik z flash-playerem.


(nintyfan) #7

Nie katalog ~/mozilla, lecz ~/.mozilla(zwróć uwagę na kropkę). Zastanawiam się czy nie musisz także usunąć pliku pluginreg.dat.


(saturno) #8

Dokładniej to chodzi o: ~/.mozilla/plugins

Tyle że powyższy katalog nie jest oficjalnie zalecany przez mozillę, a ten co podawałem doń wcześniej link to i owszem: https://support.mozilla.org/pl/kb/Instalacja wtyczki Adobe Flash Player#w_rloczna-instalacja-wtyczki-flash


(sajmon17099) #9

Wróciłem i tak, @nintyfan pomyliłem się, zapomniałem o kropce (ale napisać tę kropkę bo poprzednio przeglądałem ten ukryty katalog).

I nie ma katalogu ~/.mozilla/plugins.

Trzeba samemu zrobić katalog /plugins, a jak się do niego coś wrzuci to to nie działa. I przeglądałem ten temat który mi pokazałeś, @saturno. I zapomniałem powiedzieć, w usr/lib mam samo /firefox i nie mam /mozilla, więc to co było w tym temacie nie zadziała.

I na tej stronie nie ma nic pożytecznego: https://support.mozilla.org/pl/kb/Instalacja wtyczki Adobe Flash Player#w_rloczna-instalacja-wtyczki-flash

wiem że mam skopiować plugin, tylko nie wiem do jakiego katalogu, nie wiem czemu np. /usr/lib/firefox/browser/plugins nie działa.


(nintyfan) #10

Spróbowałeś zmienić nazwę/skasować pluginreg.dat?

Firefox 32 bitowy czy 64 bitowy?


(sajmon17099) #11

Mam Firefoxa 64 bitowego.

I gdzie jest ten pluginreg.dat? No i gdzie w końcu umieścić plik z pluginem? W /usr/lib/firefox/browser/plugins?


(saturno) #12

 

Więc utwórz ten katalog: mozilla (na 100% zadziała).

Jak nie zadziała to pokaż wynik:

dpkg -l|grep flash

Ps.: Pobrałeś odpowiedni plik flash player?

Bo flash player dla Chrome nie uruchomi się w Firefoksie.


(sajmon17099) #13

Mam poprawną wersję (sprawdziłem przed chwilą).

Zrobiłem nowy katalog, /usr/lib/mozilla/plugins, skopiowałem tam ten plugin i niestety ale to nic nie dało.

gdy wpiszę w terminalu komendę dpkg -l|grep flash to nic się nie dzieje, terminal nic mi nie pokazuje. Co robić?


(saturno) #14

Podaj mi skąd pobierałeś ten flash player bo szukałem i nie mogę znaleźć na dobrych programach strony z artykułem na ten temat.


(sajmon17099) #15

Jeśli pobieram to mam teraz tak że już nigdy nie z DobreProgramy tylko ze strony twórców. Na DobreProgramy to albo programy mogą być nieaktualne, albo też są jakieś menedżery lub po prostu programu nie ma.

 

Pobrałem Flasha stąd: http://labs.adobe.com/downloads/flashplayer.html


(saturno) #16

Sprawdziłem te konkretna wersje flash player na Live-CD Ubuntu 64-bit i działa.

Jedyne co mi przychodzi do głowy to ze ściągnąłeś przez pomyłkę 32-bitowy flash player.

Jeśli nie to już wymiękam.

 

Ps.1. Jest jeszcze inne rozwiązanie. Pakiet w Debianie nazywa się: browser-plugin-freshplayer-pepperflash (W Ubuntu nie wiem).

Po jego zainstalowaniu Firefox korzysta z najnowszego flasha z Chrome.

 

Ps.2. Odnośnie:

Przestarzały tak ale niebezpieczny to on nie jest bo cały czas Adobe daje mu poprawki bezpieczeństwa.