Jak wyłączyć podświetlenie klawiatury arch linux


(Nazan) #1

mam laptopa z podświetlaną klawiaturą i niestety jak jest ciemno non stop się świeci,wie ktoś jak to wyłączyć,dzięki za pomoc.


(dragonn) #2

Podaj wynik:

ls /sys/class/leds/

(Nazan) #3
nazan@arch ~$ ls /sys/class/leds/

ath9k-phy0 mmc0::

(dragonn) #4

Oj, może być ciężko. mmc0:: to dioda czytnika kart pamięci a ath9k-phy0 to od wifi. Jak widać więcej nie widać. Jaki to konkretnie laptop? Może w BIOS da się wyłączyć na stałe?

EDIT

Pokaż jeszcze co wywali:

find /sys -name brightness

(Nazan) #5

laptop sony vaio F22

nazan@arch ~$ find /sys -name brightness

find: `/sys/fs/fuse/connections/33': Brak dostępu

/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0/brightness

/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video1/brightness

/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/leds/ath9k-phy0/brightness

/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/mmc0::/brightness

find: `/sys/kernel/debug': Brak dostępu

(dragonn) #6

Oo coś widzę.Są dwa acpi_video, jedno z nich to na pewno podświetlenie ekranu, drugie może być podświetlenie klawiatury. Spróbuj tak - najpierw zaloguj się w konsoli jako root (za pomocą su) i następnie wpisz:

echo 0 > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video1/brightness

Jeśli zamiast klawiatury zgaśnie ekran - zresetuje PC i spróbuj:

echo 0 > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0/brightness

(Nazan) #7

niestety nie działa pierwszy kod rozjaśnia ekran a drugi przyciemnia


(dragonn) #8

Oo dziwne, wpisałeś na pewno dobrze? Dwie kontrolki do regulacji jasności ekranu :expressionless: . Znalazłem coś takiego jeszcze http://forums.linuxmint.com/viewtopic.php?f=49&t=88350 spróbuj może. Możesz też od razu wrzucić wynik polecenia:

find /sys -name *backlight*

Jeśli to wyżej nie pomoże.


(Nazan) #9

polecenie wyłączyło podświetlenie dzięki za pomoc

echo 1 > /sys/devices/platform/sony-laptop/kbd_backlight_timeout

(dragonn) #10

To polecenie raczej włączyło automatyczne wyłączanie podświetlenia jeśli jest klawiatura nie używana (a przynajmniej tak powinno działać :smiley: ).

echo 0 > /sys/devices/platform/sony-laptop/kbd_backlight

0 wyłączaj jakaś funkcję, 1 włącza.


(Nazan) #11

masz rację jest tak jak piszesz,po restarcie muszę wpisać ponownie w terminalu bo nie działa


(dragonn) #12

A to już inna sprawa, jeśli chcesz żeby po restarcie trzymało - to powiedz mi które polecenie ma być dokładnie (tak żeby ci efekt odpowiadał), to napiszę ci na szybko plik .service dla systemd który będzie ustawiał to przy starcie systemu.


(Nazan) #13

to już niewielki problem tak czy inaczej, dzięki za pomoc


(dragonn) #14

Nie no, to akurat nie jest żaden problem. Zapisz sobie taki plik:

[Unit]

Description=Keyboard backlight

After=multi-user.target


[Service]

Type=oneshot

ExecStart=/usr/bin/bash -c "polecenie_wyłączające klawiaturę"


[Install]

WantedBy=multi-user.target

Zapisz jako np. /usr/lib/systemd/system/keyboard.service. Następnie tylko systemctl enable keyboard.service