Jak zainstalować Adobe Flash Player na Debianie?


(jakubgross) #1

Jak wyżej. :slight_smile:

Z góry dziękuje za pomoc i pozdrawiam :slight_smile:


(Frankfurterium) #2

Kiedy wpiszesz do Google’a magiczne zaklęcie pierwszego (najłatwiejszego) poziomu “Flash Player Debian”, zostanie ci zesłana wizja zawierająca około 3 560 000 potencjalnych odpowiedzi. Pierwsza z nich na pewno będzie prowadziła do starożytnego manuskryptu utworzonego przez samych czarodziei zajmujących się Debianem. Ten co prawda zapisany jest tekstem w języku dalekiego ludu aż zza morza, ale nawet młody adept sztuk magicznych nie powinien przegapić zaklęcia

 

apt-get install flashplugin-nonfree

 

Aby je skutecznie wypowiedzieć, w repozytoriach należy posiadać księgę contrib, ale to już opowieść na inny dzień.

 

 

 

tl;dr - użyj Google’a.


#3

http://bit.ly/1glWqJC

Nie wróżę Ci długiej przygody z Linuksem, skoro nawet najprostszych rzeczy nie potrafisz w Google znaleźć.


(Chillout) #4

Proszę, tutaj możesz o tym przeczytać: http://forum.dobreprogramy.pl/kilka-pyta%C5%84-odno%C5%9Bnie-konfiguracji-debiana-t459684/

Pozdrawiam:)


(Nerdpershing) #5

Najpierw:

nano /etc/apt/sources.list

Pod koniec każdego wpisu dodajesz (po spacji) contrib non-free

Zapisujesz i wpisujesz:

aptitude update

aptitude install flashplugin-nonfree

Wszystko robisz jako root (żeby się zalogować na roota wpisujesz “su”)


(jakubgross) #6

Czy to ma tak wyglądać po dodaniu contrib non-free?:

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 lxde-CD Binary-1 20131215-03:39]/ wheezy main contrib non-free

deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official i386 lxde-CD Binary-1 20131215-03:39]/ wheezy main contrib non-free


deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ wheezy-updates main
# deb-src http://ftp.debian.org/debian/ wheezy-updates main

#7

Nie, nie ma.

Wpisz w Google frazę debian repozytoria i poczytaj.


(jakubgross) #8

OK. Zainstalowałem poleceniem aptitude install flashplugin-nonfree. Dlczego np. nie wyświetla się odtwarzacz na YouTube?


(Marcineez) #9

Zapewne musisz dodać symlinka do pluginu.


(Raf20076) #10
  1. Przed ściągnięciem wybierz wersje na Linuxa 32, FlashPlayer 11.2 for othe linux(tar.gz) http://get.adobe.com/flashplayer/otherversions/

  2. Rozpakuj plik w wybranym przez siebie katalogu do którego masz dostęp, nastepnie uruchom terminal i w nim przejdź do tego katalogu

  3. Nastepnie skopiuj FlashPlayera (libflashplayer.so) wpisując komendę

cp libflashplayer.so /usr/lib/mozilla/plugins/

 

I to wszystko!


(jakubgross) #11

(Raf20076) #12

 

SPRAWDZ CZY PO WPISANIU KOMENDY

 

cp libflashplayer.so / usr/lib/mozilla/plugins/

 

MASZ libflashplayer.so W KATALOGU plugins

 

na youtube jesli nie masz obrazu bedzie cos tam pisalo o HTML5 klijknij use default player (pisze bez polskich liter nie mam czasu tego teraz przestawic)


(jakubgross) #13

Mam libflashplayer.so.


(Raf20076) #14

Sprawdz na youtube czy masz obraz, a jesli nie masz to co tam pisze

 

na youtube jesli nie masz obrazu bedzie cos tam pisalo o HTML5 klijknij use default player (pisze bez polskich liter nie mam czasu tego teraz przestawic)


(jakubgross) #15

Nic tam nie pisze.


(Nerdpershing) #16

http://youtube.com/html5

Tutaj zmieniasz między html5 i flashem.


(marcin82) #17

Nie wykonuj tego, co proponuje użytkownik Marcineez.

 

Post został zgłoszony … daruj sobie takie porady.


(jakubgross) #18

Na youtube zamieniłem flash na html5 i działa. Ale co jak bym chciał np. sobie pograć w flashowe gierki?


(marcin82) #19

Zainstalować starszą wersję flasha … 

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html


(jakubgross) #20

Jaką konkretnie wersję mam pobrać?

Mam 256 MB Ram. Może dlatego  nie chce działać?