Jak zainstalować CyanogenMod 12.1 na Xperii SP z odblokowanym bootloaderem


(ferdek360) #1

Witam,


(MacGregor) #2

Użyj recovery


(ferdek360) #3

jak zrootować przez recovery i jak wgrać w ten sposób karnel?


(MacGregor) #4

http://download.cyanogenmod.org/?device=huashan

https://wiki.cyanogenmod.org/w/Install_CM_for_huashan


(ferdek360) #5

czyli najpierw wyjąć z paczki z CM12.1 plik boot.img, flashbootować go i dopiero potem wejść w recovery i zainstalować cm? bez karnela itp?

ciągle pokazuje że nie mam roota…


(MacGregor) #6

Zanim to zrobisz musisz odblokować bootloader. Do czego istrukcje już podałem. Na 80% jest to też powód podanych przez ciebie błędów.


(ferdek360) #7

tylko że ja mam odblokowany bootloader


(MacGregor) #8

czyli pobieraz zip z pierwszego linku i instalujesz go przez recvery. Oczywiście jeśli masz zainstalowane custom recovery bo to orginalne może sypac błędami. Nie zapomnij też o wyczyszczenie danych użytkownika i pamięci podręcznej aplikacji przed zainstalowaniem danego zip’a. Wszystko co trzeba zrobisz z poziomu recovery.


(ferdek360) #9

zrobiłem jak napisałeś i gdy na końcu daję reboot system to jest tylko czarny ekran…


(MacGregor) #10

hmm… wychodzi na to że musisz ręcznie zainstalować boot.img przez adb


(ferdek360) #11

a powiesz mi jak to zrobić?


(MacGregor) #12

Druga metoda z tego linku. Mam nadzieje że to pomoże ponieważ nie chce mi się samemu wszystkiego tłumaczyć :wink:


(ferdek360) #13

niestety problem goni problem, link w linku który podałeś (ten do pobrania paczki fastboot) nie działa więc pobrałem coś na własną rękę, nigdzie nie mogę znaleźć tego folderu fastboot a jakby tego było mało to podobno na win xp cała procedura wygląda inaczej niż poradniku…


(MacGregor) #14

A przez flashtool nie chce się zainstalować? Nigdy nie korzystałem z adb więc bardzo ciężko będzie mi pomóc z jego instalacją


(ferdek360) #15

przez flashtool wywala błąd że nie mam roota, przez QuikIMG tak samo a mam normalnie ikonkę supersu i wszystkie akpi na fonie normalnie roota wykrywają, jak wchodzę w service info to jest bootloader unloked :yes, nie wiem co jest grane

 


(MacGregor) #16

Zainstaluj android SDK/ADB według tego poradnika następnie zainstaluj boot.img zgodnie z tym poradnikiem. Nic lepszego już chyba nie znajdę…


(ferdek360) #17

dzięki wielkie, działa :smiley: okazało się że miałem jednak zablokowany bootloader :smiley:


(MacGregor) #18

Mówiłem że jednak coś jest nie tak z tym bootloaderem. W każdym razie cieszę się że wszystko działa i że moja pomoc się przydała :wink: