Jak zainstalować programy z plików tar.gz


(Piesek64) #1

Cześć. Potrzebuje pomocy z instalowaniem programów z plików tar.gz. Mam Minta. Kiedy próbuje użyć "make install" w terminalu wyskakuje błąd "make: *** No rule to make target `install'. Stop.". Mam 2 programy, które chce zainstalować.


(Frankfurterium) #2

tar.gz to archiwum, taki inny rar czy zip. Musisz doprecyzować, co leży w środku, bo samo opakowanie mówi o dokładnie niczym.


(Dhor) #3

Najpierw sprawdź, czy programy które masz w tar.gz nie są już spaczkowane (http://packages.ubuntu.com) w oficjalnych repozytoriach albo na launchpadzie (http://launchpad.net) - wystarczy na tych stronach w wyszukiwarkę wpisać nazwę programu.

W paczce .tar.gz powinien być jakiś plik readme - bo może to są spakowane binarki programów i wystarczy je tylko odpalić - trzeba tylko się przyjrzeć, co tam w środku jest.


(Piesek64) #4

Link do paczek ubuntu nie jest przydatny, bo mam Mint Nadia 14. Launchpad też nie pomógł. Chce zainstalować program LiVES do edycji filmów. Znajduje tylko pliki tar.gz, a próbowałem sposób instalacji z pliku README i komenda

sudo make install

wywala błąd ("make: *** No rule to make target `install'. Stop.").


(roobal) #5

Tylko, że Mint bazuje na Ubuntu i niczym się od niego nie różni.

Na stronie domowej programu piszą co innego.

Nie wiem czy w Mincie jest Centrum Oprogramowania, jeśli nie, możesz skorzystać z GetDeb, ewentualnie pobrać paczki ręcznie. W pliku readme napisano, że wymagane jest jądro 2.6, może na nowszych program nie działa. Spróbuj najpierw instalacji z paczek.


(marcin82) #6

roobal

Jest nieśmiertelny Synaptic ;]

Piesek64

Oczywiście program LIves jest dostępny w repozytoriach. Uruchom albo Synaptic i tam wyszukaj albo w terminalu:

sudo apt-get update && sudo apt-get -y install lives

(Piesek64) #7

To chyba muszę innego szukać bo mam jądro 3.8.1. Dodatkowo działam na Openboxie i mam kłopot z informacjami o podanie hasła. Często wyskakują błędy z Unity (zainstaowałem i jakoś nie chodzi z openboxem).

zaraz zobaczę czy uda się.


(linux_to_syf_^^) #8

Abstrahując od sensowności instalacji tego inaczej niż z repozytorium. Make wyraźnie wskazał, że nie ma reguł dotyczących budowania obiektu install :wink:. W praktyce najprawdopodobniej pominałeś odpalenie skryptu configure(który powinien stworzyć Makefile z regułami dla "install") i kompilację.


(Piesek64) #9

Użyłem tej komendy. Wynik komendy configure http://tnij.at/4405 .

Edit: Teraz idzie, ale terminal się restartuje.


(linux_to_syf_^^) #10

Udało Ci się nie zawrzeć nic we wnioskach :wink:. Configure przeszło, kompilacja i instalacja również?


(Piesek64) #11

Przy instalacji terminal się resetuje. Ale chyba by nie poszło , bo mam kernel wersji 3.8.1. Spróbuje włączyć.