Jak zainstalować środowisko LXDE na Arch Linux


(jakubgross) #1

Cześć,

 

dziś jakoś poradziłem sobie z zainstalowaniem czystego Archa. Teram mam problem, ponieważ zainstalowałem LXDE:

pacman -S lxde

pacman -Sy gamin

pacman -S dbus hal

Zainstalowałem także Xorg oraz  xorg-xinit.

 

Niestety po wpisaniu komendy  ~/.xinitrc pojawia się błąd, że nie ma takiej komendy

Czy nie zainstalowałem czegoś?

 

Z góry dzięki za pomoc i pozdrawiam,

jakubgross


(roobal) #2

System ma rację, bo nie ma takiego polecenia. Dlaczego nie doinstalujesz sobie graficznego menedżera logowania? Wówczas nie będziesz musiał grzebać w plikach.


#3

Przecież to nie jest komenda, tylko miejsce położenia pliku. Użyj jakiegoś edytora do jego edycji.


(jakubgross) #4

Mój Arch chyba zaczął się sypać. Przy uruchomieniu systemu wyskakują takie błędy:

http://iv.pl/viewer.php?file=66691001692505060521.jpg

Trochę to dziwne, ponieważ wcześniej było dobrze.

Czy te błędy da się jakoś naprawić?


(roobal) #5

Zastosowałeś się do wskazówek zawartych w komunikatach? Zauważyłeś stwierdzenie firmware bug?


(jakubgross) #6

Mam zaktualizować bios? Nigdy tego nie zrobię.


(roobal) #7

Aktualizacja BIOS to ostateczność. Chodziło mi bardziej o sprawdzenie podanych tam ustawień BIOSu.


(jakubgross) #8

Raz był komunikat o włączeniu LXDE, ale i tak się nie włączało. Jak za pomocą innej dystrybucji mogę usunąć lxde. Myślę, że to przez to problem.


(dragonn) #9

Jeśli zainstalowałeś tylko lxde szybciej będzie po prostu na nowo zainstalować Arch na czysto a BTW skąd wytrzasnąłeś te polecenia? Hal już dawno się nie używa… https://wiki.archlinux.org/index.php/LXDE tutaj wszystko pisze.


(Arturzajackicek) #10

Zaloguj się jako użytkowniki i wpisz:

nano ~/.xinitrc

Następnie wpisz do pliku:

exec startlxde

Klikasz “Ctrl + O”, a następnie “Ctrl + X”, potem jak chcesz uruchomić interfejs wpisujesz:

startx

I tyle :), powodzenia :smiley:

Pamiętaj rób to wszystko ze swojego konta użytkownika, a nie z roota.

 

A pro po tych “błędów” to po prostu w biosie nie masz uruchomionych rozszerzeń procesora amd (dobrze mówię?) i tyle, ja bym nie uruchamiał z tego powodu, ponieważ, jak sam uruchomiłem to miałem problem z dźwiękiem xd.


(jakubgross) #11

I tak już będę instalował Archa ponownie. Tak mam procesor AMD. :smiley:


(Arturzajackicek) #12

Nie opłaca się. Szkoda czasu, ale rób jak uważasz :slight_smile: . Masz wszystko już zainstalowane najwyżej możesz usunąć hala (bo jest on wbudowany w systemd) tyle! Powinno śmigać. :slight_smile:


(marcin82) #13

A wystarczyło doinstalować LXDM:

pacman -S lxdm

i włączyć usługę:

su -c 'systemctl enable lxdm'

 

Po restarcie masz środowisko graficzne … LXDM nie korzysta z pliku ~/.xinitrc.