Jak zainstalować sterowniki ze strony nvidia.com


(ByczY) #1

Tak jak w temacie nie wiem jak zainstalować sterowniki które oferuje nvidia.com. Robie to w taki sposób:

sudo sh Nvidia-xxx-xxx.run

włącza się instalator naciskam accept i wyskakuje mi powiadomienie że nie mam czegoś w systemie i instalacji nie może iść dalej.

PLZ HELP


(Vader481) #2

Musisz mieć zainstalowane linux-headers do twojego jądra. Aby sprawdzić wersję kernela wpisz w konsoli uname -a.


(ByczY) #3

A czy wersja kernela nie zależy od tego na która loguje się przy starcie kompa w grubie ? bo ja mam tam trzy wersje:

-


(El Presidento) #4

ByczY oczywiście ze zależy. Dlatego po każdej aktualizacji jądra trzeba instalować, na nowo zamknięte sterowniki.


(ByczY) #5

Mam tą wersję:

kernel 2.6.20-16-386

Więc jak powinno wyglądać polecenie do tego linux-headers?


(Init3) #6

Przeczytaj tutorial na debian.linux.pl autorstwa kaki. Ale uwaga - do twojego jądra (tego najnowszego co masz) musisz zainstalować spatchowane wersje instalatorów bo te ze strony nvidia nie działają. Poszukaj na forum debiana, powinien być link do tej strony w temacie o sterach nvidia. Jak sam znajde to tu wkleje. Na debianie oficjalne stery z nvidia.com nie działają do jąder 2.6.20 i 2.6.21, musisz te spatchowane zainstalowac i bedzie wszystko ok. Wiem bo sam to robilem niedawno.


(matiit) #7

knapik

Mi działały na 2.6.21 tyle że musiałem dodać ścieżki do patchy.


(Init3) #8

O tutaj są te dobre wersje (działające) http://grizach.servebeer.com/nvpatch/#1

A ten tutorial musisz znać http://debian.linux.pl/viewtopic.php?t= ... sc&start=0


(ByczY) #9

Które mam wybrać ?

Sterowniki najnowsze (nie legacy):

:arrow: Wersja dla i386

:arrow: Wersja dla IA64

:arrow: Wersja dla x64 (AMD64/EM64T)


Sterowniki najnowsze legacy

:arrow: Wersja dla IA32

:arrow: Wersja dla AMD64/EM64T

Mam kartę GeForce 7300GT i procesor 32 bitowy.


(Init3) #10

Jezu przeciez ci napisalem ze stery z nvidia.com ci nie zadziałają, musisz instalować ze stronki ktora podałem !!

ale na przyszłosc zebyś wiedział procek i386, stery - "nie legacy"


(ByczY) #11

Wpisuje to polecenie

apt-get update && apt-get install linux-headers-`uname -r` gcc gcc-4.1 gcc-4.1-base gcc-3.4-base libgcc1 g++ g++-4.1 build-essential

i mi wyskakuje takie cudo na końcu:

Pobrano 197B w 5s (34B/s)      

Czytanie list pakietów... Gotowe

E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13 Permission denied)

E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

I co mam zrobić ?


(Init3) #12

Musisz te polecenia wpisywać jako root

su i podajesz hasło do roota


(ByczY) #13

wpisałem je poprzez dodanie na początku "sudo"

Złączono Posta : 10.06.2007 (Nie) 20:06

Oto co otrzymuje jak się chce na roota zalogować:

byczynho@CHATKA:~$ su

Password: 

su: Authentication failure

Wybacz.

(matiit) #14

A podajesz poprawne hasło administratora? (nie użytkownika)


(ByczY) #15

Podaje te hasło które dawałem przy instalacji systemu.

A tak apropo jest jakaś różnica pomiędzy zainstalowaniem sterowników w ten sposób:

apt-get install nvidia-kernel-common nvidia-kernel-source module-assistant nvidia-glx linux-restricted-modules-`uname -r`

niż tym z poradnika kaki

Bo na chwile obecna mam właśnie tak zainstalowane, ale wolałbym jednak te z instalatora tylko nie wiem czy to coś zmieni ?


(matiit) #16

być może te z repo nie są najnowsze.


(ByczY) #17

Które mam wybrać:

http://grizach.servebeer.com/nvpatch/NVIDIA-Linux-x86-100.14.03-pkg1-patched.run - tuned for 2.6.20

czy ...

http://grizach.servebeer.com/nvpatch/NVIDIA-Linux-x86-1.0-9631-pkg1-patched.run - tuned for 2.6.20

(Init3) #18

Ja brałem te pierwsze i było ok, szczerze to nie wiem czym się różnią.


(ByczY) #19

Kurde jak chce zainstalować je to mi wybija takie coś:

Detected running kernel version : 2.6.20-16-generic

Detected modpost path : /usr/src/linux-kbuild-2.6.20/scripts/mod

Detected System.map path : /boot/System.map-2.6.20-16-generic

Detected paravirt_ops entry point : 0xc03a7340

---------------------------

/usr/src/linux-kbuild-2.6.20/scripts/mod does not exist or is not directory

Taką mam wersje jądra czy tam kernela:

byczynho@CHATKA:~$ uname -a

Linux CHATKA 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Dlaczego nie chcą się zainstalować ?


(Init3) #20

A poradziłeś juz sobie z wcześniejszym problemem związanym z hasłem i instalacją

??