Jak zainstalować system Ubuntu 10.04.1 na laptopie Toshiba?


(Saver) #1

Jak zainstalować system Ubuntu 10,04.1 na laptopie Toshiba Satellite C650D-11G?

Pobrałem już wszystkie wersje jak na 32bit i 64bit żadna nie działa, bootuje laptop odpala się ekran Ubuntu, i pokazuje mi jakieś linie, czekałem już nawet godzinę i wciąż nie chce się uruchomić,

nagrałem film jak to wygląda.


(system) #2

Sprawdzałeś sumy kontrolne pobranego obrazu.


(Coman Pl) #3

Poszperałem w Google. Faktycznie jest taki problem(wystarczy wpisać w wyszukiwarkę "Ubuntu kernel_thread_helper"). Jednakże nie znalazłem tam jednoznacznej odpowiedzi. Komuś pomogło dodanie do linii instalacji "mem=512M" i "noprobe". Gdzie indziej pomogła instalacja przez Wubi. Innym jeszcze "acpi=off".

Co ciekawe problem występuje głównie na Toshibach.

Tak jeszcze z ciekawości, naciskasz spację jak pojawi się na dole prośba o to (od 27sek filmiku)?


(Saver) #4

klikam wszystkie klawisze, także spacje i nic nie pisze, Instalowałem też przez Wubi ale efekt jest ten sam.

Może mi ktoś pomóc, bardzo mi zależy na systemie Ubuntu, miałem na swoim pierwszym laptopie też z Toshiby Satelite, model zapomniałem i Ubuntu bezproblemowo się zainstalował, tylko miałem wypadek i laptop mi się zniszczył teraz kupiłem nowy własnie ten i nie mogę zainstalować Ubuntu :frowning:

Bardzo proszę o pomoc.

-- Dodane 30.08.2010 (Pn) 22:37 --

W tym momencie spojrzałem na ekran od kamery, nic nie naciskałem :slight_smile:


(Evil Coca Cola) #5

Spróbuj może starszego Ubuntu i potem w nim update. Nieraz takie coś pomaga ale niczego nie gwarantuje.


(system) #6

Możesz też spróbować Debiana w wersji Lenny.

http://cdimage.debian.org/debian-cd/5.0 ... etinst.iso


(roobal) #7

Jak uruchomisz Ubuntu z płyty to wciśnij klawisz ESC jak pojawia się to fioletowe tło, tam będzie wybór język itp. rzeczy. Kliknij F6 (piszę z pamięci, jak wybierzesz z menu język polski to powinno być dodatkowe opcje ) i z menu wybierz acpi=off i jeśli będzie to przy okazji noapic , wciśnij enter aby przeprowadzić rozruch i zobacz czy coś się ruszy.

Pozdrawiam!


(Saver) #8

Dokładnie to zrobiłem po przeczytaniu tego http://asaptra.com/?p=80 tylko jeszcze w biosie zmieniłem AHCI na Compatibility, uruchomiło się wszystko działa, teraz chce zainstalować z wubi

-- Dodane 31.08.2010 (Wt) 0:20 --

Uruchomił się system Ubuntu, przez bootowanie z livecd i teraz mam pytanie jak go zainstaluje i też będę musiał ciągle ustawiać acpi=off , bo to nawet po instalacji nie da sie ustawic, a jak nie zmienie to sie nie uruchomi.


(Coman Pl) #9

Jeśli zainstalowany system nie będzie chciał się bootować wtedy opcję acpi=off dodajesz do gruba na stałe.


(Saver) #10

aha w grub jest ta opcja, to dobrze, dziękuje wam bardzo serdecznie za pomoc. Miłej nocy :slight_smile:

-- Dodane 31.08.2010 (Wt) 10:04 --

Zainstalowałem Ubuntu poprzez wcisniecie F6 i ustawienie acpi=off ale jak odpalam to w grub nie ma takiej opcji, jak mogę dodać acpi=off do gruba?


(Coman Pl) #11

https://help.ubuntu.com/community/BootOptions i https://help.ubuntu.com/community/Grub2

Po "ro quiet splash" dodajesz "noapic"


(Saver) #12

Działa uruchamianie, tylko jak to zapisać bo muszę za każdym uruchomieniem wpisać acpi=off po linii ro quiet splash i ctrl+x


(Coman Pl) #13

Jak już odpalisz ręcznie, to potem edytuj grub.cfg

sudo gedit /boot/grub/grub.cfg

(Saver) #14

Zapisane dzięki:)

A teraz mam pytanie, tak z ciekawości, czy to coś daje jak uruchamiam system przez acpi=off? Jakie są skutki uboczne uruchamiania systemu przez acpi=off?


(system) #15

(roobal) #16

Nie edytuje się grub.cfg z prostego powodu - po pierwszej lepszej aktualizacji jądra bądź Gruba wpisy się usuną (między innymi dlatego odebrano prawa do zapisu właścicielowi), dlatego należy edytować plik /etc/default/grub i w linii GRUB_CMDLINE_LINUX dodajesz ten wpis, powinno to wyglądać tak:

GRUB_CMDLINE_LINUX="acpi=off"

Potem aktualizujesz konfigurację Gruba poleceniem sudo update-grub i wpisy zostaną dodane automatycznie do grub.cfg i tak będzie przy każdej następnej aktualizacji jądra, Gruba i jego konfiguracji.

Pozdrawiam!


(Saver) #17

Bardzo Ci dziękuje za tą cenną poradę:slight_smile:


Próbowałem edytować ale nie działa :frowning: Działa tylko jak edytuje gruba


(roobal) #18

Edytowałeś z prawami administracyjnymi?

Pozdrawiam!