Jak zainstalować Unity 3D na Ubuntu 12.04?


(Kadek1) #1

Jestem użytkownikiem Ubuntu 12.04. Chciałem włączyć MyUnity i Tam mi wyskakuje że moje Ubuntu 12.04 pracuje w trybie 2d. Wywnioskowałem że jeśli chcę korzystać ze wszystkich funkcji muszę włączyć tryb 3D. Ale nie mam zielonego pojęcia jak to zrobić.

Help


(Qba Lukaszczyk) #2

Podaj wynik polecenia:

lspci | grep VGA

Możesz też spróbować w oknie logowania wybrać Ubuntu jako sesję (do wybrania powinno być Ubuntu i Ubuntu 2D).


(Kadek1) #3
01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)

Oto on


(Qba Lukaszczyk) #4

konrad28 , jeśli nie posiadasz sterowników własnościowych:

sudo apt-get install nvidia-173

(Kadek1) #5

Dobra zainstalowałem co teraz.


(LeserGD) #6

Teraz przy logowaniu wybierz Unity zamiast Unity 2d


(Kadek1) #7

Nadal wyskakuje że jest w trybie 2d


(Qba Lukaszczyk) #8

Uruchomiłeś ponownie komputer?


(marcin82) #9

Podaj wynik:

glxinfo | grep rendering

(Kadek1) #10

Uruchomiłem ponownie i cięgle to samo

A wynik polecenie to

direct rendering: Yes

(LeserGD) #11

Wybrałeś podczas logowania Unity, czy tylko wpisałeś hasło i nie zmieniałeś?


(Kadek1) #12

Zresetowałem kompa wybrałem Ubuntu (nie 2D) i się zalogowałem

Dodane 30.04.2013 (Wt) 16:37

I dalej to samo


(Rosiak115) #13

Podaj wyniki polecenia:

/usr/lib/nux/unity_support_test -p

(Kadek1) #14

Ten wynik to nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 55

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 56

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 59

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 58

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30

OpenGL vendor string: nouveau

OpenGL renderer string: Gallium 0.4 on NV34

OpenGL version string: 1.5 Mesa 8.0.2

Not software rendered: yes

Not blacklisted: no

GLX fbconfig: yes

GLX texture from pixmap: yes

GL npot or rect textures: yes

GL vertex program: yes

GL fragment program: yes

GL vertex buffer object: yes

GL framebuffer object: yes

GL version is 1.4+: yes

Unity 3D supported: no


(Qba Lukaszczyk) #15

Czyli nie zainstalowałeś sterowników własnościowych… Ech…

sudo apt-get install nvidia-173

Jaki jest wynik polecenia?


(Kadek1) #16

Teraz jest taki

OpenGL vendor string: nouveau

OpenGL renderer string: Gallium 0.4 on NV34

OpenGL version string: 1.4 (1.5 Mesa 8.0.2)


Not software rendered: yes

Not blacklisted: no

GLX fbconfig: yes

GLX texture from pixmap: yes

GL npot or rect textures: yes

GL vertex program: yes

GL fragment program: yes

GL vertex buffer object: no

GL framebuffer object: yes

GL version is 1.4+: yes


Unity 3D supported: no

(Qba Lukaszczyk) #17

Jaki jest wynik polecenia, które podałem w swoim ostatnim poście?


(Kadek1) #18

jeśli chodzi ci o lspci | grep VGA

to

01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)

(marcin82) #19

Miałeś podać wynik tego polecenia, czyli cały jego przebieg:

sudo apt-get install nvidia-173

Cokolwiek by się nie pokazało, podaj jeszcze raz, ale z literką ‘k’:

lspci -k | grep -A2 VGA

(Kadek1) #20

01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1)

Kernel driver in use: nvidia

Kernel modules: nvidia_173, nouveau, nvidiafb