Jak zrobić formułę numerującą faktury w Excelu?


(zgredzio) #1

Załóżmy, że robię sobie w Excelu jakiś arkusz dotyczący faktur. Numer pierwszej faktury to KP/1/2015. Czy da się stworzyć taką formułę, która by zmieniała tylko środkową liczbę? Próbowałem z formułą:

=TEKST(WIERSZ(A1);"000-000")

ale na razie nic z tego nie wyszło.


(madoch) #2

Da się

 

Zakładam, że numerację przechowujesz w kolumnie “A”.

 

więc numer faktury by wyglądał następująco (zawartość komórki B1).

 

=“KP/”&MAX(A:A)&"/2015"


(Pablo_Wawa) #3

Dla komórki B1 wpisz formułę

="KP/"&TEKST(WIERSZ(A1);"#")&"/2015"

i masz to co chciałeś.

 

Lub prościej:

="KP/"&WIERSZ(A1)&"/2015"

(zgredzio) #4

Dziękuję za pomoc, o coś takiego mi chodziło. :slight_smile: