Jaki kod do osadzenia pliku audio na www


(kuszelas) #1

Witam,
Chcę na swojej www osadzić plik audio. Chciałbym, aby:
1-plik był dostępny w przeglądarce IE i Chrome
2-plik nie uruchamiałby się w autostarcie.
3-można było regulować wymiary panelu nawigacyjnego.
Najbliższe tego celu wydaje się być zastosowanie poniższego kodu:

W Chrome jest OK. Natomiast w IE panel nawigacyjny jest prawie 4x większy i nie umiem go zmniejszyć. Nie wiem gdzie zapisać w kodzie wartości: width=“200” i height=“44”.

Próbowałem też z innym kodem:


W tym przypadku panel nawigacyjny w IE jest OK, natomiast w Chrome jest nieco zmieniony (dodany poniżej czarny pasek o wymiarach panelu). Niestety w Chrome dźwięk odtwarza się w autostarcie i nie potrafię tego zmienić.

Proszę pomoc w rozwiązaniu tego problemu.
Pozdrawiam
mk


(sebkor96) #2

Myślę że powinieneś spróbować z tagiem audio:

http://www.w3schools.com/tags/tag_audio.asp

Tam masz właśnie opcję autoplay, dopiero po jej dodaniu plik będzie odtwarzał się samoistnie bez zgody użytkownika.

Odtwarzanie pilków audio w Chrome jest zależne od ustawienia tej opcji:

media.autoplay.enabled


#3

http://www.kurshtml.edu.pl/html/osadzenie_pliku,multimedia.html


(kuszelas) #4

Podany przez Ciebie kod jest bliźniaczo podobny do tego, który wskazałem jako pierwszy w moim poście.
Stosując ten kod, zarówno w IE11 jak i w Chrome, plik nie odtwarza się w autostarcie. A więc jest OK.
Natomiast problemem jest wielkość panelu kontrolnego.
W Chrome jego wielkość jest prawidłowa. Natomiast w IE11 zajmuje on prawie połowę szerokości ekranu/strony.
Wygląda to tak:


Kombinowałem przeróżnie z dodawaniem znaczników: width i height, ale nie udało mi się znaleźć sposobu na zmniejszenie rozmiaru tego panelu.


(kuszelas) #5

Zastosowałem ten kod w takiej postaci:

Dało to efekt identyczny, jak zastosowanie kodu, który podałem jako drugi w w swoim poście.
W tym przypadku panele kontrolne w obu przeglądarkach wyglądały tak:

Panel w IE11 jest OK. Plik nie odtwarza się w autostarcie.
Natomiast w panelu w Chrome jest widoczna u dołu czarna pozioma belka. Nie jest to zbyt rażące, ale chętnie by się tego pozbył, gdybym wiedział jak?
Niestety, w Chrome plik odtwarza się w autostarcie, co jest niedopuszczalne, ale nie wiem jak to zmienić.


(sebkor96) #6

Użyj audio i spróbuj zrobić to tak:

<html>
    <head>
        <style>
            audio {
                width: 200px; /*Długość jaką sobie życzysz.*/
            }
        </style>
    </head>
    <body>
        <audio controls>
            <source src="ścieżka dostępu do pliku dźwiękowego" type="audio/mpeg">
        </audio>
    </body>
</html>

(kuszelas) #7

sebkor96
Dzięki!
Teraz jest SUPER!!!

Serdecznie pozdrawiam
mk