[Java] Eclipse - 'Building workspace' has encountered a problem


(Vandavv96) #1

Witam.

Przed godziną zainstalowałem do Eclipse`a Juno framework Spring i coś chyba poszło nie tak, gdyż po pomyślnej instalacji przez Eclipse Marketplace, przy tworzeniu jakiegokolwiek nowego obiektu (pliku, projektu itp) wyskakuje błąd taki, jak poniżej. 

Errors occurred during the build.
Errors running builder 'Maven Project Builder' on project 'First Project'.
Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5

Miałby ktoś jakiś pomysł jak to rozwiązać?


(Frankfurterium) #2

Prawdopodobnie Maven pochrzanił cache’a. Każ m na nowo “przeliczyć” i pościągać wszystkie zależności (gdzieś po drodze należało też zaznaczyć checkboxa przy opcji Force), w ostateczności ręcznie usuń z dysku całe lokalne repozytorium.


(kostek135) #3

Jeśli powyższe nie pomoże, może to wskazywać na problemy z dostępem do sieci.

Wtedy powodem może być to, że Maven nie może przebić się przez jakiegoś firewall’a (trzeba otworzyć port), albo połączyć z proxy (trzeba ustawić wpis z jakiego serwera proxy ma korzystać + credentials w .settings, bo Maven nie wykorzystuje ustawień systemowych).


(Vandavv96) #4

Spróbowałem odinstalować to wywaliło w połowie podobny błąd i stwierdziłem, że to nie ma sensu. Wywaliłem, zainstalowałem najnowszego Keplera i na nim śmiga znakomicie