Java -> nietypowy problem po reinstalacji


(X Ray77) #1

witam (po raz 1szy na forum),

po sprawdzeniu niezgodności w rejestrze (przy użyciu jv16) okazało się, że mam wpisy odnoszące się zarówno do bieżącej wersji Java 1.5.0, jak i wersji porzednich (bodajże 1.2.0); postanowiłem odinstalować Javę i usunąć wpisy w rejestrze, a następnie zainstalować na nowo;

po deinstalacji usunąłem również pozostawione foldery i pliki (np. folder 'Java' na C:\Program Files\Common Files, folder 'Sun' na C:\Windows\Dane aplikacji\, jak również foldery '.java' i '.jpi-cache') oraz wyczyściłem rejestr ze wskazanych uprzednio wpisów;

zainstalowałem Javę na nowo; niemniej, nie uruchamiają się applety dot. gier on-line (kurnik.pl lub w portalu gazeta.pl); testowałem poprawność zainstalowanej Javy na stronie 'java.com' + sprawdziłem dostępne tam informacje/ wskazówki -> ustawienia przeglądarki mam OK; w sumie instalowałem Javę 3 razy (2 razy on-line i raz off-line); za każdym razem jest to samo;

nie mam pojęcia czemu to nie działa; b. proszę o pomoc!

z takich moich obserwacji:

  1. po reinstalacji Javy te foldery '.java' i '.jpi-cache' nie zostały stworzone na nowo; może za bardzo się wypuściłem z ich wcześniejszym usunięciem, chociaż z informacji i opinii znalezionych na guglach wynikało, że foldery te mogą być usunięte;

  2. w folderze 'Downloaded Program Files' (C:\Windows) mam 3 pliki oznaczone jako formanty activeX o tej samej nazwie (Java Runtime Environment 1.5.0), tym samym rozmiarze (0 - słownie zero) i tej samej dacie utworzenia; różnią się tylko identyfikatorem - odpowiednio: {CAFEEFAC-0015-0000-0006-ABCDEFFEDCBA}, {8AD9C840-044E-11D1-B3E9-00805F499D93}, {CAFEEFAC-FFFF-FFFF-FFFF-ABCDEFFEDCBA}.

z góry serdecznie dziękuję za pomoc.

X-ray

P.S. nadmieniam, że przeszukałem to i inne fora, ale niestety nie znalazłem wskazówek do rozwikłania problemu.


(Danielderen) #2

możesz użyć przywracania systemu

zawsze to coś :mrgreen:


(X Ray77) #3

sprawdziłem jeszcze ustawienia firewall'a (czy czasem nie blokuje ciastek na stronie kurnik.pl) + wyłączyłem na chwilę ochronę rezydentną antywirusa, ale to nie to.

przywróciłem system do stanu sprzed deinstalacji, ale nawet to nic nie daje :cry:

cholera, co to może być ?!

b. proszę o pomoc!

Złączono Posta : 23.04.2006 (Nie) 10:47

sorry za tę litanię, ale próbuję sobie jakoś zebrać moje obserwacje/ spostrzeżenia do kupy...

otóż przypomniałem sobie, że wczoraj (jeszcze przed deinstalacją Javy) chciałem skorzystać ze skanera on-line Kaspersky; wyskoczył mi błąd, że w moim przypadku formanty activeX (konieczne do działanie ww. skanera) nie są obsługiwane, czy coś w tym stylu... zdziwiło mnie to, ponieważ poziom ochrony w strefie Internetu mam ustawiony na średni.

może qrcze moje problemy z Javą są jakoś powiązane z tymi dot. formantów activeX...

z niedzielnym pozdrowieniem

X-ray


(JNJN) #4

Prawodopodobnie przedobrzyłeś z czyszczeniem rejestru.

Przed czymś takim robi się jego kopie - gdyby coś nie tak poszło.

Odinstaluj Jave.

Z uruchom komenda chkdsk /f i sfc /scannow ,włóż płytę z XP z SP2 - jak taki system masz zainstalowany.Po chkdsk i sfc spacja.

Restart kompa.

Zainstaluj Jave i zobacz.


(X Ray77) #5

wydaje mi się, że to nie jest kwestia usuniętych przeze mnie wpisów w rejestrze; usuwałem tylko te wpisy, co do których miałem pewność, że dotyczą nieużywanych/ odinstalowanych programów lub błędnych skrótów; wpisy dot. Javy usunąłem po reinstalacji; wszystkie usunięte wpisy mogę odzyskać z kopii bezpieczeństwa (wykonywana default'owo w jv16 power tools);

wszystkie znaki na niebie i ziemi wskazują, że w tej materii coś się wykrzaczyło w sobotę, ponieważ ostatni raz skutecznie korzystałem z serwisu kurnik.pl w piątek; w sobotę natomiast robiłem wspomniane porządki z rejestrem + parę innych rzeczy dot. instalowania nowych i odinstalowania starych programów; zainstalowałem np. Operę, ale coś mi się wykrzaczyło (system się zawieszał, wyskoczyły jakieś błędy w jednej z bibliotek Opery - 'ouniansi.dll') i nie mogłem z niej korzystać -> odinstalowałem i usunąłem wpis w rejestrze; tak się zastanawiam, czy np. Opera nie zrobiła jakichś zmian we wpisach w rejestrze dot. Javy??

ponadto 'feralnego' dnia zainstalowałem spy sweeper'a i przeczyściłem nim system, ale to chyba - jak na mój laicki gust - nie jest przyczyną moich problemów z Javą;

dobrej nocy, pozdrawiam

X-ray


(Piotr P.) #6

http://groups.google.pl/group/pl.comp.o ... ac8989b12e


(JNJN) #7

Spróbuj tego co pisałem.

Albo zgraj dane i rozważ postawienie świeżego systemu,bo jak za bardzo namieszałeś w rejestrze to nic go nie naprawi - jak nie masz jego kopii.

http://forum.dobreprogramy.pl/viewtopic.php?t=25048


(X Ray77) #8

victoria! !!

zainstalowałem firefox'a i problem (tfu, tfu...) jak ręką odjął;

pozdrawiam serdecznie

X-ray

P.S. stosowałem Wasze zalecenia, ale niestety nie odniosły rezultatu; niemniej jednak, b. dziękuję za dobre chęci.