JDeveloper błąd podczas uruchamiania


(Jurczak Jakub) #1

Przy próbie uruchomienia JDeveloper konsola zwraca mi komunikat:

Oracle JDeveloper 11g Release 2 (11.1.2.1.0)

Copyright (c) 1997, 2011, Oracle and/or its affiliates. All rights reserved. 


2012-04-30 09:37:09 oracle.ide.osgi.boot.LauncherUtil throttleLocale

INFO: Locale pl_PL is not supported by this product. Forcing locale to en_US.

Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/kuba/Oracle/Middleware/jdk160_24/jre/lib/i386/libsplashscreen.so: libX11.so.6: cannot open shared object file: No such file or directory

	at java.lang.ClassLoader$NativeLibrary.load(Native Method)

	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1806)

	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1723)

	at java.lang.Runtime.loadLibrary0(Runtime.java:823)

	at java.lang.System.loadLibrary(System.java:1028)

	at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)

	at java.security.AccessController.doPrivileged(Native Method)

	at java.awt.SplashScreen.getSplashScreen(SplashScreen.java:91)

	at oracle.ide.osgi.boot.OracleIdeLauncher.getSimpleSplashImage(OracleIdeLauncher.java:539)

	at oracle.ide.osgi.boot.OracleIdeLauncher.main(OracleIdeLauncher.java:82)

	at oracle.ide.osgi.boot.JDeveloper.main(JDeveloper.java:14)

Rozumiem, że należy przełączyć lokalizację z polskiej na amerykańską, ale chciałbym również mieć spolszczony system, tak jak mam obecnie. Jak to zrobić?

Posiadam najnowszą wersję Java tj. 7u4 Oracle

System Ubuntu 12.04 64bit.


(nintyfan) #2

Wygląda na to, że JDeveloper uruchamia natywną bibliotekę z kodem pod 32-bity. Tamta biblioteka wymaga Xlib. W takim razie musisz zainstalować 32-bitowy XLib.

Chyba, że jest gdzieś dostępny 64-biitowy JDeveloper?


(Jurczak Jakub) #3

Wpisałem:

sudo apt-get install libx11*

Po instalacji i ponownej próbie uruchomienia zwraca:

Oracle JDeveloper 11g Release 2 (11.1.2.1.0)

Copyright (c) 1997, 2011, Oracle and/or its affiliates. All rights reserved. 


2012-05-04 14:11:04 oracle.ide.osgi.boot.LauncherUtil throttleLocale

INFO: Locale pl_PL is not supported by this product. Forcing locale to en_US.





2012-05-04 14:11:16 oracle.ide.osgi.Activator start

SEVERE: Failed to boot IDE cleanly

java.awt.HeadlessException: 

No X11 DISPLAY variable was set, but this program performed an operation which requires it.

	at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)

	at java.awt.Window.(Window.java:432)

	at java.awt.Frame.(Frame.java:403)

	at java.awt.Frame.(Frame.java:368)

	at javax.swing.JFrame.(JFrame.java:158)

	at oracle.javatools.controls.MainWindow.(MainWindow.java:46)

	at oracle.ide.IdeMainWindow.(IdeMainWindow.java:238)

	at oracle.ideimpl.MainWindowImpl.(MainWindowImpl.java:166)

	at oracle.ide.osgi.Activator.setupWindow(Activator.java:253)

	at oracle.ide.osgi.Activator.start(Activator.java:110)

	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)

	at java.security.AccessController.doPrivileged(Native Method)

	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)

	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)

	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)

	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)

	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)

	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)

	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)

	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

	at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.internalStart(EquinoxLauncher.java:281)

	at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.start(EquinoxLauncher.java:251)

	at org.eclipse.osgi.launch.Equinox.start(Equinox.java:256)

	at org.netbeans.core.netigso.Netigso.start(Netigso.java:153)

	at org.netbeans.NetigsoFramework.turnOn(NetigsoFramework.java:172)

	at org.netbeans.ModuleManager.enable(ModuleManager.java:985)

	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:318)

	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:254)

	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:286)

	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:172)

	at org.netbeans.core.startup.Main.start(Main.java:308)

	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)

	at java.lang.Thread.run(Thread.java:662)

Nie istnieje JDeveloper 64bit -- Dodane 04.05.2012 (Pt) 14:13 -- Użyłem

export DISPLAY=:0.0

, ale teraz jest nowy problem:

Oracle JDeveloper 11g Release 2 (11.1.2.1.0)

Copyright (c) 1997, 2011, Oracle and/or its affiliates. All rights reserved. 


2012-05-04 15:11:40 oracle.ide.osgi.boot.LauncherUtil throttleLocale

INFO: Locale pl_PL is not supported by this product. Forcing locale to en_US.

Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/kuba/Oracle/Middleware/jdk160_24/jre/lib/i386/libsplashscreen.so: libX11.so.6: cannot open shared object file: No such file or directory

	at java.lang.ClassLoader$NativeLibrary.load(Native Method)

	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1806)

	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1723)

	at java.lang.Runtime.loadLibrary0(Runtime.java:823)

	at java.lang.System.loadLibrary(System.java:1028)

	at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)

	at java.security.AccessController.doPrivileged(Native Method)

	at java.awt.SplashScreen.getSplashScreen(SplashScreen.java:91)

	at oracle.ide.osgi.boot.OracleIdeLauncher.getSimpleSplashImage(OracleIdeLauncher.java:539)

	at oracle.ide.osgi.boot.OracleIdeLauncher.main(OracleIdeLauncher.java:82)

	at oracle.ide.osgi.boot.JDeveloper.main(JDeveloper.java:14)

(nintyfan) #4
ls /lib32/libX*

ls /usr/lib32/libX*

(Jurczak Jakub) #5

Oba polecenia nie znalazły plików. Jakim poleceniem zainstalować 32bitowe biblioteki?


(nintyfan) #6

Ja tego nie wiedzę w repozytorium:

finch - text-based multi-protocol instant messaging client

libx11-6 - X11 client-side library

libx11-6-dbg - X11 client-side library (debug package)

libx11-data - X11 client-side library

libx11-dev - X11 client-side library (development headers)

libx11-doc - X11 client-side library (development documentation)

libx11-xcb-dev - Xlib/XCB interface library (development headers)

libx11-xcb1 - Xlib/XCB interface library

libx11-xcb1-dbg - Xlib/XCB interface library (debug package)

x11-utils - Narzędzia X11

dsniff - Various tools to sniff network traffic for cleartext insecurities

libx11-freedesktop-desktopentry-perl - perl interface to Freedesktop.org .desktop files

libx11-guitest-perl - collection of functions for X11 GUI testing/interaction

libx11-protocol-perl - Perl module for the X Window System Protocol, version 11

(Jurczak Jakub) #7

Znalazłem rozwiązanie! Problemem nie był tu brak bibliotek, ale to że miałem zainstalowaną 64bitową wersję JAVA (oraz 64 bitowy system), podczas gdy JDeveloper wspiera 32 bitowe systemy. Odpowiedź można znaleźć na tej stronie: https://help.ubuntu.com/community/32bit_and_64bit

Aby uruchomić 32 bitową aplikację na 64 bitowym systemie należy zainstalować "powłokę zgodności".

  1. Otwieramy Synaptic.

  2. Wyszukujemy pakiet

    ia32-libs

  3. instalujemy go wraz ze wszystkimi zależnościami.

(Podobny problem z uruchomieniem istniał przy aplikacji Visual Paradigm, ale powyższa porada go rozwiązuje)

Dziękuję nintyfan za zaainteresowanie problemem i pomoc.

Jeszcze małe pytanie... Jak ręcznie stworzyć na pulpicie lub pasku unity aktywator do programu?