Joomla 1.5 i Virtue Mart - błąd podczas rejestracji


(Blady214) #1

Witajcie,

zostałem poproszony o pewną stronę opartą na Joomli i VirtueMart. Głównym problemem jest błąd podczas rejestracji użytkowników, przy próbie rejestracji każdy user dostaje 500.

Starałem się sprawdzić zachowanie całego systemu i oto moje obserwacje:

  1. Wpis nowego użytkownika pojawia się jedynie w tabeli joomli, natomiast virtue mart nie otrzymuje żadnego wpisu w tabeli użytkowników.

  2. Po włączeniu maksymalnego poziomu błędów doszedłem do tego, że użytkownik otrzymuje błąd Invalid token.

  3. Rejestracja odbywa się pod adresem http://mojastrona... , natomiast zostaję przekierowany na http://www.mojastrona.... gdzie jest wyświetlany błąd, czyli request leci jakby nie tam, gdzie trzeba.

Jak rozwiązać ten problem? Jest to bardzo ważne, bo od prawie miesiąca żaden user poprawnie się nie zarejestrował.


(Dimatheus) #2

Blady214 , zapoznaj się, proszę, z tym tematem, a następnie - korzystając z przycisku zmien.gif

Pozdrawiam,

Dimatheus


(jacko1998) #3

Takie pytanie: Dlaczego robisz to w Joomli 1.5 ? Nie można było postawić tego na najnowszej wersji Joomli (3) ?


(Blady214) #4

Doskonale wiem o tym, że to powinno być dawno zrobione... ale ja zostałem poproszony jedynie o szybką naprawę, nie ja na codzień administruje tym sklepem. Z tego co widzę po plikach na FTP, to ktoś próbował robić update testowo ale tam jest też indywidualny szablon, który poleciał. Prędzej czy później ten update będzie konieczny, narazie jednak chodzi mi o usprawnienie, żeby to zaczęło w ogóle w jakimś stopniu działać. Więc nie dywagując już nad tematem update powróćmy do kwestii rejestracji...