[Joomla 1.5] Nie działa mod_rewrite


(VPN) #1

Mimo włączenia opcji mod_rewrite w Konfiguracji, dopisania var $mosConfig_sef = '1'; w configuration.php i dodania standardowego .htaccess nie działa mod_rewrite. Na serwerze jest uruchomione, tak zapewnia hosting.

W tej chwili mam taką zawartość .htaccess:

Options -Indexes

(Mariuszs) #2
$mosConfig_sef = '1';

To w configuration.php? Czy to jakaś hybryda Mambo z Joomla?

Co do mod_rewire, to aby uzyskać adresy, jakie chcesz, musisz mieć zaznaczone wszystkie 3 opcje w sekcji 'Optymalizacja dla wyszukiwarek' w konfiguracji globalnej. Oczywiście wyłącz cache po tej operacji.


(VPN) #3

Nie, to zwykła Joomla. Taką wskazówkę znalazłem.

Wpis z configuration.php usunąłem, 3 opcje zaznaczone, pamięć podręczna zawsze była wyłączona. I nie działa nadal :frowning:


(Mariuszs) #4

Użyj tego oryginalnego pliku .htaccess z Joomla 1.5:

##

(VPN) #5

Dzięki wielkie, teraz działa jak trzeba :slight_smile:

Przy okazji mam jeszcze pytanie. Czy mogę bezpiecznie usunąć z .htaccess te linie? Dodałem je, żeby instalacja przebiegła bez przeszkód, ale nie wiem czy są jeszcze potrzebne.

Options -Indexes


php_flag register_globals off

php_flag display_errors off

(Mariuszs) #6

Zmienne globalne, czy wyświetlanie błędów ustawiasz w configuration.php - czyli można usunąć. Oczywiście bezpieczniej, aby były one wyłączone.


(VPN) #7

Jeszcze raz dzięki. Szczęście, że trafiłem na eksperta Joomli.