[joomla] nietypowy problem z szablonem


(Ble34) #1

Witam

Mialem bardzo wiele szablonow joomli i stosowalem je do roznych portali - ze czuje sie zaledwie srednio-zaawansowany w phpe, ide na łatwizne i nabywam komercyjne szablony. Niestety ten który nabyłem tym razem, mimo iż od autora - to z takich a nie innych powodów supportu z jego strony otrzymac nie moge...

Do rzeczy: wgrałem do folderu 'Templates' interesujacy mnie szablon - gk_sportmaxum. Instalator joomli wykrył go i pozwolil sie zaakceptowac jako domyslny, jednakze po otworzeniu strony glownej (witryny, nie panel joomli) wyskakuje oto taki błąd:

Warning: require(/templates/gk_sportmaxum/gk_suckerfish.php) [function.require]: failed to open stream: No such file or directory in /home/vxr59197/public_html/Joomla_data/templates/gk_sportmaxum/index.php on line 23


Fatal error: require() [function.require]: Failed opening required '/templates/gk_sportmaxum/gk_suckerfish.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/vxr59197/public_html/Joomla_data/templates/gk_sportmaxum/index.php on line 23

Ktoś ma pojęcie w czym problem? Miał to być gotowy szablon zgodny z joomla 1.5 ,a wyrzuca jakies bledy plikowe.. ktos jest wstanie wytłumaczyć? Dzięki


(Tofik27) #2

w twoim szablonie jest błąd w 23 lini w pliku index.php


(Ble34) #3

dzięki za błyskotliwą odpowiedź. :wink: studiując na kampusie w Michigan udało mi się troszkę podszkolić angielskiego (amerykańskiego). :slight_smile: Bardziej miałem na myśli jak rozwiązać ten problem i/czy wywołany jest on po prostu błędem autora skryptu /nieodpowiednia wersja joomli (niekompatybilna) itd


(Mariuszs) #4

Wystarczy przywrócić z paczki szablonu oryginalny index.php szablonu. Sprawdź też, może jedna z funkcji jest niedomknięta lub brakuje np. przecinka.


(Ble34) #5

Nie, nie. banalne błędy w kodzie odnośnie znaczników odpadają, przeglądałem nie tylko linie w której jest błąd ale również inne 'pokrewne', niestety nic.

Paczka zainstalowana czysto po 'otrzymaniu'. Nic nie zdarzyłem modyfikować w indexie więc raczej również odpada.


(Mariuszs) #6

Jedyne wyjście to postawić nową Joomlę na czysto i szablon. Potem dograć bazę danych.