Karta sieciowa Ethernet nie ma poprawnej konfiguracji protokołu IP przy podłączeniu Mikrotik RB750


(dre4merOn) #1

Cześć, karta sieciowa Ethernet nie ma poprawnej konfiguracji protokołu IP przy podłączeniu Mikrotik RB750. Gdy podłączam właśnie Mikrotik do modemu i potem do laptopa to wyświetla się taki właśnie błąd jak w temacie w diagnozuj. Czy to źle skonfigurowany Mikrotik czy karta sieciowa ethernet? Gdy podłączam modem bezpośrednio do laptopa, internet przez kabel jest. Mój system to Windows 10 Pro.


(roobal) #2

Co to za modem? Jaki typ połączenia? Pokaż wyniki poleceń z Mikrotika (możesz zalogować sie po ssh lub skorzystać z wbudowanego terminala w Winbox. Jeśli mietek nie ma żadnego IPika, zaloguj się po jego MAC adresie).

 

Wynik wklej na pastebin i wklej tu link.


(dre4merOn) #3

@roobal Mam nadzieję, że o to Ci chodziło. I, że wszystkie komendy są poprawne w terminalu.

 

http://pastebin.com/SQPKAsiz

 

Modem Cisco od Toyi.


(roobal) #4

Nie masz skonfigurowanego serwera DHCP. Do tego musisz też utworzyć pule adresów dla DHCP. Możesz to wszystko wyklikać w Winbox, a jak nie ogarniesz, daj znać, napiszę Ci jak to zrobić. Najlepiej zresetuj też Mietka i przy logowaniu, jak dostaniesz pytanie czy załadować konfigurację startową, kliknij usuń. Wtedy będziesz musiał logować się po MAC adresie, bo wywali Cię z Winboksa.


(dre4merOn) #5

Nie wiem za bardzo jak to wszystko ogarnąć. Mógłbyś napisać jak skonfigurować serwer DHCP i jak utworzyć pulę adresów dla DHCP? Byłbym wdzięczny.
Resetowałem już router. Konfiguracje też usunąłem. Zaktualizowałem także Mikrotik’a do najnowszej wersji.


(roobal) #6

Na forum wygodniej mi to jest robić z terminalu, ale to wszystko możesz sobie wyklikać. Podam Ci polecenia, jak skonfigurować wszystko, potem będziesz mógł sobie podejrzeć jak to wygląda od strony graficznej.

 

Utwórz sobie interfejs WAN (zmienimy mu nazwę, żebyś wiedział, że to WAN). Niech to będzie interfejs pierwszy (ether1)

Utworz interfejs bridge, to będą dla Ciebie interfejsy LAN.

Dodaj do interfejsu bridge pozostałem interfejsy.

I tak pozostałem porty (oprócz ether1). Teraz czas na konfigurację interfejsu WAN.

Teraz określasz pulę adresów dla serwera DHCP.

Teraz konfiguracja serwera DHCP.

Mikrotik ma wbudowany serwer DNS, robie cache stron i umożliwia dodawanie własnych wpisów DNS (przydaje się). Możesz dodać też dodatkowe serwery DNS w opcjach DHCP.

Teraz czas na konfigurację interfejsu LAN

.

Teraz potrzebny Ci NAT, aby komputery w Twojej sieci LAN mogły kominukować się z Internetem.

Myślę, że teraz powinno Ci działać.


(dre4merOn) #7

Przepraszam za opóźnienie. W końcu mogę odpisać. Więc tak wykonałem wszystkie komendy. Niestety jest jak było czyli bez efektu. Myślę ,że wykonałem wszystko poprawnie. Cały czas się obawiam ,że to wina mojej karty sieciowej.  Ale może to być ten wina Mikrotika nie wykluczam po prostu głośno myślę. Czy miałbyś jeszcze jakieś sugestie dla mnie? 


(roobal) #8

Zaloguj się do Mietka w terminalu i wykonaj takie polecenie.

Wrzuć tu zawartość tego pliku. Plik możesz pobrać przez Winbox metodą przeciągnij i upuść lub logując się na wbudowany w Mikrotiku serwer FTP lub SFTP.


(dre4merOn) #9

jan/20/2017 23:29:24 by RouterOS 6.38.1

software id = GKXY-SZ0X

/interface bridge
add name=LAN protocol-mode=none
/interface ethernet
set [find default-name=ether2] name=ether1_WAN
/ip pool
add name=dhcp_pool_lan ranges=192.168.1.20-192.168.1.100
/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_lan always-broadcast=yes interface=LAN \
    name=dhcp_server_lan
/interface bridge port
add bridge=LAN interface=ether3
/ip address
add address=217.113.224.35/8 interface=ether1_WAN network=217.0.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
add dhcp-options=hostname,clientid interface=ether1_WAN
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1 \
    netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1_WAN
/ip route
add disabled=yes distance=1 gateway=ether1_WAN
/system clock
set time-zone-name=Europe/Warsaw
 

Proszę. Możliwe,że jednak nie zachowałem kolejności. Ponieważ jeszcze trochę raczkuję w Mikrotiku i odpaliłem kilka terminali później zamykałem całego Mikrotika i z powrotem. Dlatego proszę o wyrozumiałość. :wink: Nie znam się także na logach więc może błędne mam wrażenie.


(roobal) #10

Dwie rzeczy, a właściwie trzy: 1. Jesteś pewny, że ISP dał Ci 2147483648 adresów IP? Skoro masz statyczne IP, to nie konfigurujesz już DHCP Clienta; 2. Trasa, którą masz skonfigurowaną nie jest włączona, musisz ją włączyć. Żeby korzystać z Internetu musisz dodać trasę domyślną i tam wskazać adres bramy*; 3. W mostku LAN masz tylko port ether3 (pisałem, że musisz dodać tak samo pozostałe, czyli ether4, 5). Jeśli tylko ether3 masz w mostku LAN, to do tego portu się podepnij i sprawdź czy z serwera DHCP dostajesz adresy.

*/ip route add dst-address=0.0.0.0/0 gateway=ether1_WAN distance=1 disabled=no

Jako gateway podajesz adres IP bramy lub interface.


(dre4merOn) #11

Jeszcze jest niedziela więc odpisuję. :wink: Wiesz co zrobiłem? Przyznam się bez bicia, że średnio zrozumiałem to co do mnie napisałeś w ostatniej wiadomości. Pomyślałem sobie, że zrobię wszystko od początku. Zresetowałem router, podłączam… I działa. :wink: Moje pytanie brzmi czy jeszcze muszę go jakoś konfigurować? Wiem ,że mogę go pod siebie dopasować. Jednak pytam pod kontem bezpieczeństwa. Czy coś zalecasz? Czy jeśli działa to póki co zostawić jak jest? W przyszłości pewnie będę go sobie konfigurował jak lepiej poznam. Tak btw dzięki wielkie za pomoc. :slight_smile: Szacun dla Twoich umiejętności. :) 


(roobal) #12

Nie ma sprawy. Codziennie zarządzam Mikrotikami, więc znam je już na pamięć. Jeśli chodzi o bezpieczeństwo. Jak korzystasz z Winbox, to w IP>Services powyłączaj sobie zbędne usługi, jak np. dostęp do routera przez WWW (chyba że korzystasz z tego) i pozmieniaj porty dla ssh i telnet, np. na 888 i 999. Jeśli masz publiczne IP, to w logach spodziewaj się prób logowania na ssh i/lub telnet (automaty z Chin, Rosji, a nawet Francji). Jeśli masz publiczne IP, to koniecznie na firewallu zablokuj port 53 dla protokołu UDP (łańcuch input, action drop), bo to też lubią atakować i odczujesz drastyczny spadek wydajności routera. W IP Settings powłączaj sobie wszystkie te rzeczy, które tam są, domyślnie część jest wyłączona.

Możesz też zaktualizować firmware (System>Routerboad) i system (System>Packages). W Mikrotikach aktualizacje zawsze można cofnąć. Poza jednym przypadkiem, nigdy baboli nie miałem po aktualizacji (po ostatniej LACP w bridge powodował dodanie interfejsów LACP do bridge, co powodowało pętlę na interfejsach i skutkowało niedziałaniem LANu - dhpc nie odpowiadał). To na razie wszystko co przychodzi mi do głowy.