Karta wifi wg111v3 nie łączy się z netem


(system) #1

Witam.

Od jakiegoś miesiąca męczę się z pewnym problemem. Tzn chciałem sobie skonfigurować karte wifi NETGEAR wg111v3 pod linuxem - dokładnie pod debianem. Po przeczytaniu kilku postów na forum polskim i zagranicznym udało mi się załadować sterowniki tej karty - system debian wykrywa je bez problemu. Ale co najgorsze karta widzi sieć (mój router i livebox) ale nie umie się z nimi połączyć. Napewno problemem nie jest zabezpieczenie WPA/2 bo go specjalnie wyłączyłem żeby sprawdzić czysię wogóle połącze z siecią. No więc tak, poniżej przedstawiam wszystkie kroki jakie dokonałem do tychczas oraz moje aktualne konfiguracje:

  1. Na początku załadowałem sterowniki z windowsa od wg111v3:

    ndiswrapper -i wg111v3.inf

    depmod -a

    modprobe ndiswrapper

    ndiswrapper -m

  2. Oto wynik polecenia "lsusb" <-- system widzi sprzęt

    lsusb

    Bus 005 Device 004: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]

    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Bus 001 Device 005: ID 1267:0103 Logic3 / SpectraVideo plc G-720 Keyboard

    Bus 001 Device 004: ID 1267:0201 Logic3 / SpectraVideo plc A4Tech SWOP-3 Mouse

    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

  3. Oto wynik polecenia "ifconfig"

    ifconfig

    eth0 Link encap:Ethernet HWaddr 00:11:d8:c5:5d:99

          inet addr:192.168.2.15 Bcast:192.168.2.255 Mask:255.255.255.0
    
          inet6 addr: fe80::211:d8ff:fec5:5d99/64 Scope:Link
    
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    
          RX packets:9863 errors:0 dropped:0 overruns:0 frame:0
    
          TX packets:10254 errors:0 dropped:0 overruns:0 carrier:0
    
          collisions:0 txqueuelen:1000 
    
          RX bytes:8126780 (7.7 MiB) TX bytes:1918883 (1.8 MiB)
    
          Interrupt:17 Base address:0x9800

    lo Link encap:Local Loopback

          inet addr:127.0.0.1 Mask:255.0.0.0
    
          inet6 addr: ::1/128 Scope:Host
    
          UP LOOPBACK RUNNING MTU:16436 Metric:1
    
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
    
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
    
          collisions:0 txqueuelen:0 
    
          RX bytes:10612 (10.3 KiB) TX bytes:10612 (10.3 KiB)

    wlan0 Link encap:Ethernet HWaddr 00:1e:2a:45:85:7d

          UP BROADCAST MULTICAST MTU:1500 Metric:1
    
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    
          collisions:0 txqueuelen:1000 
    
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
  4. Oto wynik polecenia "iwconfig"

    iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:off/any Nickname:"wrt54gl"

          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated   
    
          Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=0/3  
    
          RTS thr:off Fragment thr:off
    
          Encryption key:off
    
          Power Management:off
    
          Link Quality:0 Signal level:0 Noise level:0
    
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
  5. Oto wyniki polecenia "iwlist wlan0 scanning":

    iwlist wlan0 scanning

    wlan0 Scan completed :

          Cell 01 - Address: 00:21:29:A2:16:AF
    
                    ESSID:"wrt54gl"
    
                    Protocol:IEEE 802.11g
    
                    Mode:Managed
    
                    Frequency:2.412 GHz (Channel 1)
    
                    Quality:50/100 Signal level:-64 dBm Noise level:-96 dBm
    
                    Encryption key:off
    
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    
                              12 Mb/s; 48 Mb/s
    
                    Extra:bcn_int=100
    
                    Extra:atim=0
  6. A to zawartość poliku "/etc/network/interfaces":

    more /etc/network/interfaces

    This file describes the network interfaces available on your system

    and how to activate them. For more information, see interfaces(5).

    The loopback network interface

    auto lo

    iface lo inet loopback

    auto wlan0

    iface wlan0 inet dhcp

    wireless-essid wrt54gl

    wireless-mode Managed

Wszystko wydaje mi się że jest dobrze skonfigurowane ale niepokoi mnie wyniki polecenia "dhclient up"

dhclient up

There is already a pid file /var/run/dhclient.pid with pid 13897

killed old client process, removed PID file

Internet Systems Consortium DHCP Client V3.1.1

Copyright 2004-2008 Internet Systems Consortium.

All rights reserved.

For info, please visit http://www.isc.org/sw/dhcp/


SIOCSIFADDR: No such device

up: ERROR while getting interface flags: No such device

up: ERROR while getting interface flags: No such device

Bind socket to interface: No such device

Może coś nie jest wgrane w moim komputerze z "dhcp" jakieś sterowniki albo program.

Jeśli ktoś ma jakiś ciekawy pomysł albo rozwiązanie i chce się nim podzielić to czekam. Dzięki pozdrawiam


(roobal) #2

Nie dhclient up tylko dhclient wlan0 jak już.

Pozdrawiam!


(system) #3

pokazuje ten sam wynik co "dhclient up"


(roobal) #4

Zrestartowałeś sieć?

/etc/init.d/networking restart

Pozdrawiam


(dragonn) #5

A czemu nie użyjesz wicd lub network-manager? Są wygodniejsze.


(system) #6

W tym problem że próbowałem z Network menager ustawiamłem tam wszytko:

  • sterowniki z ndiswrapper'a

  • nawet próbowałem przypisać statycznie adres IP i całą konfiguracje ale nic ztego.


(dragonn) #7

To spróbuj wicd, moim zdaniem jest lepszy.