Keepass 2.13 nie otwiera programów


(K Pop) #1

Przeczytałem wątek na forum pt. "Bezpieczne zarządzanie hasłami - KeePass dla początkujących"

Link: bezpieczne-zarzadzanie-haslami-keepass-dla-poczatkujacych-t287960.html#p1919684

Chciałem wykorzystać Keepassa do montowania woluminów programem Truecrypt.

Chciałem, ale nic z tego nie wyszło. Mało tego, żaden program nie uruchamia się po wpisaniu w polu "notatki" odpowiednich komend, a stosuję się ściśle do tego co napisane w w.w. poradniku. Czytałem na stronie Keepassa nt. używanych komend i było tam napisane, iż od wersji 2x nie ma komendy {WIN}. Jak w takim razie wersja którą mam ( 2.13) radzi sobie w otwieraniem

programów? Jeśli tak jest w rzeczywistości i to jest źródłem problemu, to czy w.w. poradnik nie powinien być zaktualizowany?

I pytanie dodatkowe: używając Keepassa, nie mogę się zalogować bezpośrednio na to forum, tylko ze strony głównej.

Mam komunikat, że hasło, lub użytkownik nieprawidłowe. Przy rejestracji było info, że logowanie z głównej musi być tylko za pierwszym razem. Jak to więc z tym jest?

Edit: Temat poprawiłem, reszta uważam, że w miarę precyzyjnie opisane. Mogę napisać nawet ze 3 razy więcej, tylko wtedy już będzie to lanie wody i mało kto doczyta do końca.


#2

maestro38 , proszę zapoznaj się z tą stroną oraz tym tematem, a następnie popraw tytuł tematu, używając przycisku ac7a4cd89050aa6e.gif


(Łukash) #3

Tylko na to pytanie zdaję mi się że umiem odpowiedzieć

KeePass zdaję się zachował hasło do http://www.dobreprogramy.pl/Logowanie.html ,a adres forum jest trochę inny

http://forum.dobreprogramy.pl/ ,KeePass nie wie że jeden login i hasło pasuję do zalogowania się na dobrychprogramach :wink: ,zachowaj hasło do forum.


(K Pop) #4

Niestety nie pomaga wpisanie adresu forum. Nie działa ani auto-type z menu kontekstowego, ani

to globalne. Wyczerpały już mi się pomysły, stąd mój post na forum. Próbowałem też bez wpisywania adresu, wyłączałem sekwencję dla danych okien (globalny auto-type) i chciałem się logować tylko z menu kontekstowego.

Też nie dało to pożądanego efektu.

Poza tym login i hasło jest wpisywane, ale strona to odrzuca, więc czy to na pewno wina Keepassa?


(Łukash) #5

W takim razie spróbuj usunąć logowanie na dobrychprogramach z KeePassa i ponownie spróbuj zapamiętać tylko na forum.

Nie mam zielonego pojęcia ,może faktycznie to nie jego wina.


(K Pop) #6

Tzn. usunąć cały wpis i utworzyć nowy?

Tylko tego jeszcze nie robiłem, ale czy to by miało sens?

URL jak już pisałem zmieniałem, próbowałem jeszcze w 3 miejscu się logować (na forum

są dwa miejsca do logowania), też to samo.

URL nie musi być zresztą nawet wpisany, czy poprawny, jak jest wykonywany auto-type z menu

kontekstowego.


(Krzysztof C.) #7

Po Twoim PW mogę tylko napisać, abyś nie używał KeePassa w wersji 2.x :smiley:

Sam wróciłem do wersji 1.x, gdyż od wersji 2.10 jest masa problemów z tym programem, głównie chodzi o Auto-Type przy Firefoxie i o otwieranie innych aplikacji właśnie. Interweniowałem w związku z tym u twórcy programu, ale... nic się nie zmienia. Ostatnia dobrze działająca wersja z serii 2.x to 2.09.

Nie aktualizuje mojego poradnika, ponieważ jest on przeznaczony głównie do wersji 1.x

Pozdrawiam


(K Pop) #8

Jestem w szoku. Żeby nowsza wersja była uboższa o tak istotną funkcję.

Byłem pewien, że załatwia się to w inny sposób po prostu (inne komendy)

To tylko mała sugestia, by nadmienić w poradniku o tym, że niektóre porady działają tylko do wersji 1.x

Ja już wiem i czytelnicy tego wątku, ale może nie każdy, że są istotne różnice w wersjach.

W takim razie teraz mam pytanie, czy są jakieś problemy z exportem baz do wersji 1.x ?

Będzie to już inne rozszerzenie pliku (KDB).

Jeśli dobrze działa 2.09, czemu wróciłeś do 1.x?

Aha, może przez to, że wersje 2.x potrzebują netframework ?

Wersja portable Keepassa nie ma wtedy racji bytu.

Są inne różnice na korzyść 1.x?

Edit: Więc jak, nikt nie zna odpowiedzi na moje pytania?


(Krzysztof C.) #9

Problem z Auto-Type w wersji 2.x rozwiązany!

Wystarczy dla grupy matki ustawić własną sekwencję autowpisywania (z reguły {UserName}{TAB}{Password}{ENTER}) i wszystko działa poprawnie. W poszczególnych wpisach można zmieniać sekwencję naturalnie na inną. Pamiętać należy też o tym, aby używać dokładnie! !!

Wracam więc do wersji 2.x :smiley:

Co do eksportu bazy z wersji 2 do 1 to nie ma problemów, ale nie wyeksportujemy na przykład dodatkowych pól. W ogóle nie wyeksportujemy tego co działa tylko w wersji 2. W związku jednak z rozwiązaniem problemu z Auto-Type nie ma co roztrząsać tego tematu :smiley: