Kliknięcie w adres mailowy na stronie nie uruchamia emClienta


(hałabała) #1

Da się to jakoś naprawić?


(iJuliusz) #2

Jaki masz Windows?


(hałabała) #3

Jak w dziale - Windows 7


(KAZDAN63) #4

Skojarzenie linków mailto (GOGLE CHROME & GMAIL - utwórz wiadomość) :
Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND]
@="\“C:\\PROGRAM FILES\\GOOGLE CHROME\\CHROME.exe\” https://mail.google.com/mail?extsrc=mailto&url=%1"
Jak to będzie w przypadku Twojego “wynalazku” to nie wiem choć wątpię , aby sama ścieżka dostępu do pliku .exe programu wystarczyła (odpowiedni wpis powinien powstać podczas instalacji programu) .
W przypadku GOOGLE CHROME , aby poczta otwierała się na nowej karcie przeglądarki :
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\SHELL\ASSOCIATIONS\URLASSOCIATIONS\MAILTO\UserChoice]
“Progid”=""


(hałabała) #5

A zaraz zaraz - jak to zrobić?


(krystian3w) #6

Ale ona chyba nie chce z Gmail w Chrome.


(iJuliusz) #7

Nie zauważyłem :wink:

obraz

Otwórz Opcje Internetowe. Kliknij w zaznaczonym miejscu.

Potem jedno z tych dwóch

obraz

Poszukaj Twojego programu klikając w to miejsce

obraz


(KAZDAN63) #8

Ty czytasz co napisałem ?


(KAZDAN63) #9

Wszystkie przeglądarki internetowe po kliknięciu linka mailto badają zawartość tego klucza Rejestru :
[HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND] i jego zawartość powinna być taka , aby adres e-mail został automatycznie wpisany do paska adresu tworzonej wiadomości , bo inaczej to nie ma to sensu .
Tylko OPERA do wersji 12.18 miała swoje ustawienia .


(hałabała) #10

iJuliusz: Probowałem tego i… w programach domyślnych nie mam emClienta a w protkole mailto: nie moge wybrać emClienta bo nie ma go tam do wyboru

KAZDAN63: nie wiem co Ty do mnie piszesz ale jakbys mógł mi to rozłozyc na czynniki pierwsze byłbym rad


(KAZDAN63) #11

Jaka jest ścieżka dostępu do pliku .exe tego programu (miejsce instalacji) ?


(hałabała) #12

C > Pliki programów (x86) > emClient > 1.exe


(KAZDAN63) #13

Wpisz do klucza COMMAND (jak go nie ma to go utwórz) :
“C:\PROGRAM FILES (x86)\EMCLIENT\1.exe” (uwaga na cudzysłowy tj. ścieżka dostępu do pliku 1.exe nie jest ciągła)
Problem w tym , że prawdopodobnie po 1.exe powinno być jeszcze coś dopisane tak , aby adres e-mail został automatycznie wpisany do paska adresu tworzonej wiadomości w tym programie .

Skopiować , wkleić do NOTATNIKA , zapisać jako 1.reg (Wszystkie pliki) i dodać do Rejestru :

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND]
@="\“C:\\PROGRAM FILES (x86)\\EMCLIENT\\1.exe\””

Ech to forum ! Chcesz \\ to trzeba napisać \\\\ !
Uwaga : Zapis widoczny w kluczu Rejestru i gotowy wpis różnią się ilością : " \ .


(hałabała) #14

Plik reg utworzyłem tylko nie rozumiem tego:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND]
@="“C:\PROGRAM FILES (x86)\EMCLIENT\1.exe””

Ech to forum ! Chcesz \ to trzeba napisać \\ !
Uwaga : Zapis widoczny w kluczu Rejestru i gotowy wpis różnią się ilością : " \ .


(krystian3w) #15

Powinny być dwa w pliku reg dla ścieżek plików.

Jak widać obie osoby lenie nie chcą nawet kliknąć w przycisk “</>” by otoczyć element jako kod i nic forum nie wycięło.

Działa nawet dobrze (np. z blokiem kodu w kilku liniach), nie wklejacie np. kodów gdzie potrzebne jest kolorowanie składni (dla ułatwienia zrozumienia kodu i wychwycenia błędów to w miarę działa), to powinna wam wystarczyć.


(hałabała) #16

Kurcze, Panowie. Spieracie sie między sobą a nikt nie potrafi mi tego klarownie wyjaśnić - Możecie najpierw mnie tak punkt po punkcie a potem ze sobą? - Nie będę się już wtedy wtrącał.

Mam najnowszą Operę 50. Na jakiejkolwiek ze stron mam adresy mailowe - klikając w nie nie uruchamia mi się klient pocztowy (Mam tez w miare nowego eMClienta)

Da sie to jakoś naprawić - Krótko, rzeczowo, powoli. Mogę???


(krystian3w) #17

Opera 50 nie jest najnowsza, jest już 51, spróbuje zainstalować u siebie program i zobaczyć jak skonstruuje ścieżkę i jak będzie działać z przeglądarkami (jak będzie trzeba to i Operę 51 zainstaluje na chwilę).


Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\Shell\Associations\UrlAssociations\mailto\UserChoice]
"Hash"="lMU1bWYJD4g="
"ProgId"="eM Client.Url.mailto"

Hash jest pewnie losowy.

Klucza / wpisu w:

HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND

nie utworzył i w Firefox działają linki mailto np.:

https://www.rapidtables.com/web/html/mailto.html


Program zrobił klucze w swoim wpisie:

[HKEY_CLASSES_ROOT\eM Client.Url.mailto]
[HKEY_CLASSES_ROOT\eM Client.Url.mailto]
@="eM Client URL"
[HKEY_CLASSES_ROOT\eM Client.Url.mailto\DefaultIcon]
@="C:\\Program Files\\eM Client\\MailClient.exe"
[HKEY_CLASSES_ROOT\eM Client.Url.mailto\shell]
[HKEY_CLASSES_ROOT\eM Client.Url.mailto\shell\open]
[HKEY_CLASSES_ROOT\eM Client.Url.mailto\shell\open\command]
@="\"C:\\Program Files\\eM Client\\MailClient.exe\" /mailurl \"%1\""

(hałabała) #18

Masz racje - mam juz 51-kę Opery


(KAZDAN63) #19

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\MAILTO\SHELL\OPEN\COMMAND]
@="\“C:\\PROGRAM FILES (x86)\\EMCLIENT\\1.exe\”"

krystian3w : Z epitetami to ostrożnie !


(krystian3w) #20

W Chrome 64 też daje radę, więc spróbuje w Operze.

Rozumiem że ta opcja nie naprawia problemów wcale: