KMyFirewall- jak skonfigurować? Jak upewnić sie, ze działa?


(Dawiddek55) #1

Wiec zainstalowałem sobie KMyFirewall.

  1. Jak odpalić ten program spod roota? (Ten program tego wymaga)

  2. Jak odpowiednio ustawić Firewalla aby chronił mój komp? Czy domyślne ustawienie wystarczą?

  3. Ten program nie pokazuje się w trayu dlatego nie mam pewności czy ten program działa w tle.

  4. Jeżeli program nie działa w tle, to potrzebuję polecenia, które doda do autostartu ten program

  5. Macie jakieś zastrzeżenia do tego programu? Polecacie jakiś inny firewall? Może lepiej wziąć AV? Jestem zainteresowany tym aby mój komputer był chroniony ad ataku hakera, bo o wirusy to sie nie boje, bo w końcu to jest linux :wink:

EDIT: Dodam, że zainstalowałem Avasta, jednak on nie uruchamia sie z systemem, dlatego jego będę włączal co jakiś czas żeby przeszkanowac kompa ale chce mieć aktywną zaporę która działa w tle cały czas chroni kompa przed atakiem-właśnie KMyFirewall (no chyba że mi polecicie inną)


(Winiarro) #2
  1. Poleceniem "sudo kmyfirewall" z konsoli. Poprosi o podanie hasła. A najlepiej to zainstaluj program gufw.

2.W gufw wystarczy zaznaczyć włącz firewalla.

3.To tylko nakładka na firewalla wbudowanego w system, czyli iptables. Podobnie gufw. One mają go tylko włączyć i nie są już potrzebne.

4.Patrz punkt 3

5.Tak najprostszy jest gufw

6.Avast ma za zadanie tak naprawdę skanować głównie partycje z windowsem. Nie musi działać w tle pod linuksem i nie działa.


(roobal) #3

KMyFirewall jest tylko nakładka graficzną na IPtables tak samo jak Firestarter czy wposmniany gufw, który jest nakładką graficzną dla ufw. KMyFireWall jest dla bardziej zaawansowanych użytkowników. Polecam instalację Firestarter lub Gufw ewentualnie Guarddog albo zainteresuj się samym IPTables.

Dla początkujących polecam poczytać http://forum.ubuntu.pl/showthread.php?t=43258 (nie wiem czemu ale albo wątek z forum został usunięty albo chwilowy problem na forum).

Moim zdaniem te regułki iptables są wystarczające aby chronić komputer, osobiście je wykorzystuję i dopasowuję do danej sytuacji ale na co dzień korzystam z takiego skrypciku:

#!/bin/sh


# Czyszczenie firewalla


iptables -F

iptables -X

iptables -t nat -F

iptables -t nat -X


# Polityka bezpieczeństwa


iptables -P INPUT DROP

iptables -P FORWARD DROP

iptables -P OUTPUT ACCEPT


# Reguły firewalla


iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT


# Zezwolenie na zapetlanie pakietów


iptables -A INPUT -i lo -j ACCEPT

iptables -A FORWARD -o lo -j ACCEPT

Dodajesz to do /etc/init.d/, nadajesz mu prawa do wykonywania:

chmod +x firewall

sudo mv ~/firewall /etc/init.d/

Dodajesz do poziomu uruchomieniowego, żeby się uruchamiał w czasie startu systemu, przed uruchominiem sieci:

sudo update-rc.d firewall defaults 90

Uruchamiasz zaporę:

sudo /etc/init.d/firewall start

W skrócie, zapora przyjmuje politykę odrzucania wszelkich pakietów, które przychodzą do Ciebie z neta a pozwala wysyłać pakiety aby mieć w ogóle dostęp do neta. Zapora pozwala odbierać tylko te pakiety z nawiązanych już połączeń i odbiera tylko pakiety tylko z portów, z których zostały wysłane pakity wychodzące. Zaporę możesz dostosować jeszcze po swojemu. Ja czasami zezwalam tylko na odbiór i wysyłkę tylko na portach 80 (http) i 443 (https, z którego korzysta m.in. Kadu i ogólnie GG), 53 (DNS) czasami 21-22 (ftp) a całą resztę blokuję:

#!/bin/sh


# Czyszczenie firewalla


iptables -F

iptables -X

iptables -t nat -F

iptables -t nat -X


# Polityka bezpieczeństwa


iptables -P INPUT DROP

iptables -P FORWARD DROP

iptables -P OUTPUT DROP


# Reguły firewalla


iptables -A INPUT -s 195.93.178.5 -j DROP # tą regułą blokuję popularną stronę - NK

iptables -A INPUT -s 195.93.178.6 -j DROP # tą regułą blokuję popularną stronę - NK

iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A OUTPUT -p tcp --dport 80 -j ACCEPT

iptables -A OUTPUT -p udp --dport 80 -j ACCEPT

iptables -A OUTPUT -p tcp --dport 443 -j ACCEPT

iptables -A OUTPUT -p udp --dport 443 -j ACCEPT

iptables -A OUTPUT -p tcp --dport 53 -j ACCEPT

iptables -A OUTPUT -p udp --dport 53 -j ACCEPT

iptables -A OUTPUT -p tcp 21:22 -j ACCEPT


# Zezwolenie na zapetlanie pakietów


iptables -A INPUT -i lo -j ACCEPT

iptables -A FORWARD -o lo -j ACCEPT


# Uniemożliwianie pingowanie mnie


iptables -A INPUT -p icmp -j DROP

Pozdrawiam!


(Dawiddek55) #4

ok, więc zainstaluje tego co jest podany i wykonam wszystkie polecenia wyżej podane wielkie dzięki :slight_smile:


(roobal) #5

Jeśli masz na myśli IPTables nie musisz go instalować w Ubunut i w wielu dystrybucjach jest standardowo instalowany, jednak jego polityka bezpieczeństwa standardowo pozwala na przyjmowania, odbieranie i przekierowanie pakietów. Jeśli zależy Ci tylko na ochronie komputera to wystarczy Ci pierwszy skrypt, drugi to tylko przykład. Natomiast jeśli chcesz zarządzać firewallem, np. blokować dane adresy www, ip itp. to na początek zainteresuj sie Firestarterem a tu masz ciekawy opis http://jakilinux.org/aplikacje/firestar ... a-kazdego/

Wspomniany wcześniej ufw powinien być też standardowo zainstalowany, jedynie GUI trzeba doinstalować, jednak polecam Firestarter :slight_smile:

Pozdrawiam!


(Dawiddek55) #6

Tego nie mogę zrobić, pisze, że ten init. d to nie jest katalog.

EDIT: Niestety żadne z poleceń kolegi roobal nie działają, jedno to zła skladnia polecenia a inne, że nie ma katalogu init.d

PS. Zainstalowałem gufwa, skonfigurowałem go, włączyłem zaporę i dodałem wyjątki na htp, https, takie jak napisał roobal. Zostało jeszcze dodanie programu do autostartu, niestety właśnie ta komenda wywala nieprawidłowa składnię, moglibyście podać jeszcze raz działającą komendę?

EDIT: JA w ogóle nie mam w /etc/init.d pliku o nazwie firewall :frowning:

Proszę o korektę tak aby wszystko działało/

EDIT 3: Wiecie co? W preferencjach gufw'a zaznaczyłęm sobie aby uruchamiał się zminimalizowany z sesją i był w obszarze powiadomienia, i jak widze, to wystarczy chyba ponieważ progam pracuje i strzeże :slight_smile: uruchomiłem go spod "sudo" jednak obawaim się o to że przy nastepnym starcie nie będzie działął ponieważ nie zostanie uruchomiony przez sudo :frowning: Proszę o napisanie polecenia tak, aby gufw zawsze był aktywny i uruchamiał się z sudo albo z roota, poniewaz wtedy będzie zawsze w 100% (chyba) aktywny. Z góry dziękuję.

PS. Macie jeszcze jakieś uwagi? Co mogę dodać?


(roobal) #7

Być może w Ubuntu jest inny układ katalogów, pisałem na podstawie Debiana, a to jedno polecenie to mój błąd, który już poprawiłem. W takim razie polecam instalację Firestartera.

Wpisz w konsoli i podaj wynik:

ls -l /etc

Pliku w /etc/init.d/firewall nie masz, ponieważ najpierw miałeś go stworzyć w twoim katalogu domowym a później przenieść do /etc/init.d :slight_smile:

W ten sposób uruchamiasz pogram do konfiguracji zapory, ona się uruchamia w tle, zresztą wpisz w konsoli:

sudo ufw -status

i powinno się wyświetlić

ufw enable albo disable - włączony/wyłączony

W czasie uruchamiania Ubuntu wyłącz bootsplash i zobaczysz czy ufw się uruchamia. (g)ufw, Firestarter i inne służa tak samo jak iptables tylko do konfiguracji zapory, tworzenie/usuwanie reguł, natomiast sama zapora działa w tle, ponieważ wszystkie pakiety są filtrowane przez jądro systemu cały czas aż do wykasowania/wyłączenia zapory, więc to że Gufw się nie wyświetla nie uruchamia wraz ze startem systemu nie znaczy, że zapora nei działa.

Pozdrawiam!