Kolejność instalacji bibliotek Net Framework


(Monia19923) #1

Z tej strony: http://www.microsoft.com/pl-pl/download/search.aspx?q=microsoft%20net%20framework można pobrać Microsoft Net Framework.

Chciałabym wiedzieć w jakiej dokładnie kolejności trzeba je zainstalować i czego brakuje.

  1. Pakiet redystrybucyjny systemu Microsoft® .NET Framework w wersji 1.1

  2. System Microsoft .NET Framework w wersji 1.1 — pakiet języka polskiego

  3. Dodatek Service Pack 1 dla architektury Microsoft .NET Framework 1.1

  4. Dodatek Service Pack 2 do programu Microsoft .NET Framework 2.0

  5. Pakiet językowy programu Microsoft .NET Framework 2.0 z dodatkiem Service Pack 1 (x86)

  6. Pakiet językowy programu Microsoft .NET Framework 2.0 z dodatkiem Service Pack 2 (x86)

  7. Dodatek Service Pack 1 do programu Microsoft .NET Framework 2.0 (x86)

  8. Dodatek Service Pack 1 do programu Microsoft .NET Framework 3.0

  9. Pakiet językowy programu Microsoft .NET Framework 3.0 z dodatkiem Service Pack 1

  10. Microsoft .NET Framework 3.5

  11. Dodatek Service Pack 1 do programu Microsoft .NET Framework 3.5

  12. Pakiet językowy programu Microsoft .NET Framework 3.5

  13. Microsoft .NET Framework 4 (instalator oparty na sieci Web)

  14. Microsoft .NET Framework 4.5

I co dalej??


(rgabrysiak) #2

Czy na pewno potrzebujesz pakiety językowe do .Net Framework? Moim zdaniem są one zbędne. To raz.

Dwa, czy na pewno potrzebujesz aż wszystkie wersje .Net Framework? Wydaje mi się że wystarczy wersja 3.5 i wyższa, chyba że masz jakieś programy które wymagają wcześniejszych wersji.


(system) #3

Najlepiej zdać się na propozycje witryny Windows Update w dziale aktualizacje opcjonalne! Jest to rozwiązanie na pewno optymalne.


(deFco247) #4

.NET Framework 3.5 SP1 zawiera w sobie wszystkie wcześniejsze wersje środowiska poza 1.1, która i tak jest b. rzadko potrzebna (aplikacje z niej korzystające mogą automatycznie używać 2.0).

.NET FrameWork 4.5 jest dostępny tylko dla systemów od Visty wzwyż.

Poza tym dla wersji 4 jest dostępny autonomiczny instalator (nie pobierający reszty plików z sieci): https://www.microsoft.com/pl-pl/downloa ... x?id=17718


(Bogdan_G) #5

Jak najbardziej przychylam się do zdania, że nie wszystkie frameworki są potrzebne. Framework 2 jest potrzebny jako środowisko do uruchomienia wielu programów, w tym office 2007. Framework 3.5 jest potrzebny do uruchamiania nowszych programów. Są takie tez programy, które potrzebują framework 4, ale trzeba się liczyć, ile zajmą przestrzeni dyskowej razem z frameworkiem 4. Co do framework niżej wersji 2, to już jest zbyt mało programów, które wymagają tego środowiska uruchamiania. Zaś framework 3, to najbardziej wadliwy zbiór bibliotek. Najwięcej jest do framework 3 aktualizacji i najwięcej jest bugów z uruchomieniem którejś z bibliotek .dll. Framework 3.5 ma to wszystko, co w wersji 3 i dużo więcej, co potrzeba.


(Monia19923) #6

Mam wersję 1.1;

2.0 service pack 2;

2.0 service pack 2 language pack - plk;

3.0 service pack 1 language pack - plk;

3.0 service pack 2;

3.5 sp1

Nie wiem czy zainstalowały się w sposób właściwy.