Komunikat o uszkodzeniu dysku po defragmentacji


(Lexer) #1

Po defragmentacji dysku jakimś zewntęrznym programem (niestety nazwy nie pamiętam, ale w każdym razie był on polecany na forach) windows zaczął wyświetlać taki oto komunikat:

capture07102010185709.jpg

Windows krzyczy, że po defragmentacji wszystkie partycje dysku są uszkodzone i niezbędne jest wykonanie kopii zapasowej. Aby upewnić się, że na dysku nie pojawiły się bad sectory przeskanowałem cały dysk najpierw scandiskiem z włączona opcją "Skanuj dysk i spróbuj odzyskać uszkodzone sektory" a także jakimś innym (niestety również nie pamiętam jakim) programem do sprawdzania, czy na dysku nie pojawiły się żadne bad sectory. Żaden z programów nie znalazł żadnych uszkodzeń. Próbowałem również defragmentować dysk defragmentatorem z windowsa, ale również to nie pomaga. Wniosek zatem taki, że dysk jest sprawny, tylko windows zgłupiał po defragmentacji...

Komunikat pojawia się losowo, w różnych okolicznościach. Pojawiają się kolejno dwa takie jak na załączonym obrazku okienka, a za trzecim razem okienko z dodatkową opcją " Nie przypominaj (niezalecene)" czy coś w tym stylu. Kliknięcie tej opcji likwiduje problem tylko do czasu kolejnego restartu komputera. Problem jest dosyć irytujący. Wszystko to trwa już przynajmniej ze 3 miesiące. Pomóżcie! Ja pozbyć się tego komunikatu? Obawiam się, że nawet jeśli sformatuję dysk to system dalej będzie wywalał błąd na pozostałych dwóch, nieformatowanych partycjach.

Problem występuje w Windows 7 Ultimate x64, na bieżąco aktualizowanym. W komputerze mam zainstalowany jeden dysk fizyczny z utworzonymi trzema partycjami.

Zobacz więcej: http://www.chip.pl/forum/viewtopic?tid= ... z11roRNruC


(Bela Daniel) #2

chkdsk c: /R

gdzie c: wolumin partycji który zamierzasz sprawdzić


(bubon) #3

A jak to nie pomoże, to formatowanie partycji C i ewentualnie kolejnych.


(Lexer) #4

Nie zrozumieliśmy się ... nie chodzi mi o sprawdzenie, czy na dysku istnieją ewentualne zepsute sektory, bo już to sprawdzałem i ich nie ma, chodzi mi jakieś pozbycie się tego komunikatu. Format też nie wchodzi w grę... tym bardziej, że nie dodałem jeszcze że przywracałem partycję systemową z utworzonej wcześniej kopii zapasowej, sprzed defragmentacji. Też nie pomogło.

Gdybym nie wiedział jak włączyć skandiska albo jak sformatować dysk, nie zawracałbym nikomu głowy na forum ...


(Łukash) #5

Wiesz ,używanie "nie wiadomo czego" może przynieść ,jak się przekonałeś ,nieoczekiwane skutki.Może w takim bądź razie faktycznie doszło do poważnego uszkodzenia mechaniki dysku ,skoro badów nie ma .Jak na gwarancji do lepiej oddaj do serwisu ,nie używaj już nie wiadomo czego do "naprawy" :wink:


(Lexer) #6

Gdyby dysk uległ "poważnemu uszkodzeniu" to nie sądzę, żeby działał bez żadnego zarzutu przez ponad trzy miesiące. Poza tym wątpię, żeby system miał możliwość sprawdzenia takiego "poważnego uszkodzenia mechaniki dysku" gdyby tak było pewnie byłyby jakieś fragmenty dysku do których nie ma dostępu albo wywalają błędy, a mimo tego, że intensywnie używam wszystkich partycji dysku nic takiego się nie dzieje. Nie znalazłem nawet najmniejszego pliczku, którego nie dałoby się odczytać.

Prosiłbym o jakieś rady, które naprawdę mogą mi pomóc a nie o pisanie żeby coś napisać...


(Łukash) #7

Ciężko cokolwiek w tej sprawie doradzić ,sorki że wyszło tak jakbym bił na post - tak nie było :wink:

Faktycznie masz racje.Sprawdź może w Podglądzie zdarzeń > bodajże System ,czy są jakieś ślady po tym błędzie ,jeżeli tak to przedstaw je.Nie wiem czy to dobry pomysł ,ale może backup ważnych danych z partycji Z lub D i format tej partycji > test czy dalej będzie wywalać Wolumin C\Z\D <-w ogóle tak miałeś przypisane litery partycji od początku ?


(Lexer) #8

Raport z podglądu zdarzeń:

98787736.jpg

W sumie nic ciekawego tu nie ma ...

Przeskanowałem jeszcze raz dla pewności dziś dys programem HDTune Pro. Zero bad sectorów ...

Tak, od początku litery dysków miałem przypisane jako c: d: z:

Jakieś pomysły?


(Łukash) #9

Raczej jest inaczej .Wykryty błąd S.M.A.R.T z tego co można wyczytać gdzie nie gdzie = dysk do serwisu .Wrzuć screen z HDTune Pro z zakładki Health.

Piotr92 dokładnie


(Piotrkijak) #10

Radzę Ci wymienić dysk i skopiować dane, bo zaraz mozesz je utracić.


(Lexer) #11

Nie rozumiem zupełnie czemu żeście się ta uparli no to, że dysk jest uszkodzony. Ja jestem na 90% przekonany, że wszystko jest ok. Moje pytanie nie brzmi co jest nie tak z dyskiem (bo wiem, że wszystko jest ok) tylko jak wyłączyć ten denerwujący komunikat. Tyloma różnymi programami ten dysk skanowałem i żaden nie stwierdził żadnych błędów, tylko windowsowi się coś pokopało gdy mu jakiś program do defragmentacji pozamieniał dane sektorami ...

Screeny z HDTune:

capture09102010220515.jpg

capture09102010220505.jpg


(Łukash) #12

Pierwszy raz widzę taką sytuacje i można zgłupieć :slight_smile: Wyłącz S.M.A.R.T. w Biosie jak się da http://pl.wikipedia.org/wiki/S.M.A.R.T._(informatyka Podobny problem http://windows7forum.pl/windows-wyrzuca ... -4078.html


(Lexer) #13

No, to już konkretna propozycja :smiley: S.M.A.R.T. w biosie był, ale był ... wyłączony. Z ciekawości go włączyłem, zobaczymy, czy to coś zmieni.


(Łukash) #14

Spróbować można ,napisz potem co i jak .


(Lexer) #15

O dziwo włączenie funkcji S.M.A.R.T. w biosie pomogło i od sześciu dni póki co (odpukać :slight_smile: ) komunikat nie pojawił się ani razu ... Jeśli coś się jeszcze jednak zmieni dam znać.