Konfiguracja FreeNAS do współpracy z winxp


(Czb1) #1

Proszę o pomoc w konfiguracji FreeNAS.

Zrobiłem wg instrukcji usługi smb, ftp, sshd, upnp.

Widzę zawartość po ftp w przeglądarce.

W smb nie widzę grupy roboczej WORKGROUP i oczywiście zasobów serwera FreeNAS.


#2

Cesik , proszę zapoznaj się z tą stroną oraz tym tematem, a następnie popraw tytuł tematu, używając przycisku ac7a4cd89050aa6e.gif


(Brtx) #3

A jak w Start > Uruchom... >

Wpiszesz:

\\adres_ip_freenas\udzial

To też nic?


(Czb1) #4

Problem rozwiązany.

Zainteresowanych proszę o kontakt mailowy.


(Kaka') #5

Cesik , nie tędy droga. Po to jest forum, aby właśnie tutaj podawać sobie rozwiązania problemów. Proszę abyś opisał solucję w tym temacie.


(Czb1) #6

Od początku swojego zainteresowania linuxem na forach piszecie tylko szukaj i czytaj. Nieliczni podają szczegóły.

A teraz czas na zaspokojenie głodu informacji (podziękowania dla forum unixy.pl).

Instrukcja krok po kroku. Pominąłem podstawową konfigurację FreeNAS. 


1. Ustawiamy ogólne prawo dostępu do FreeNAS: 


Services:CIFS/SMB:Settings 

Authentication:Anonymous 

NetBIOS name:FreeNAS 

Workgroup:Dom 



2. Tworzymy katalogi dla grup i użytkowników: 


Moje miejsce sieciowe:Wyświetl komputery grupy roboczej:Dom:FreeNAS:Zasoby 

Nowy folder:Parter 

Nowy folder:Pietro 

Nowy folder:Wszyscy 

Parter 

Nowy folder:Adam 

Nowy folder:Ewa 

Pietro 

Nowy folder:Piotr 

Nowy folder:Pawel 



3. Tworzymy grupy FreeNAS: 


Access:Groups 


parter 70 Parter 

pietro 71 Pietro 



4. Tworzymy użytkowników FreeNAS: 


Access:Users 


adam Adam haslo1 haslo1 1001 parter 

ewa Ewa haslo2 haslo2 1002 parter 

piotr Piotr haslo3 haslo3 1003 pietro 

pawel Pawel haslo4 haslo4 1004 pietro 



5. Nadajemy prawa dostępu do katalogów grup FreeNAS: 


Advanced:Execute command 


chown -R adam:parter /mnt/Zasoby/Parter 

chmod -R 770 /mnt/Zasoby/Parter 

chown -R piotr:pietro /mnt/Zasoby/Pietro 

chmod -R 770 /mnt/Zasoby/Pietro 



6. Nadajemy prawa dostępu do katalogów użytkowników FreeNAS: 


chown -R adam:parter /mnt/Zasoby/Parter/Adam 

chmod -R 700 /mnt/Zasoby/Parter/Adam 

chown -R ewa:parter /mnt/Zasoby/Parter/Ewa 

chmod -R 700 /mnt/Zasoby/Parter/Ewa 

chown -R piotr:pietro /mnt/Zasoby/Pietro/Piotr 

chmod -R 700 /mnt/Zasoby/Parter/Piotr 

chown -R pawel:pietro /mnt/Zasoby/Pietro/Pawel 

chmod -R 700 /mnt/Zasoby/Parter/Pawel

-- Dodane 23.06.2009 (Wt) 10:29 -- Moje niedopatrzenie. Zapomniałem dopisać na końcu ustawienie FreeNAS:

Services:CIFS/SMB:Settings 

Auhtentication:Local User