Konfiguracja routera pod zewnętrzne ip owncloud


(adrian218) #1

Witam mam taki problem postawiłem sobie serwer ownclouda. Posiadam router WR841N , do tego mam zewnętrzne ip pod którym chce żeby było widać ownclouda bo teraz zwyczajnie nie łączy się ,

Port na routerze odbolokowałem 80 i dodałem ip na komputer na jakim stoi serwer ownclouda nic.

 


(tomcio_pl) #2

Podaj więcej szczegółów. Jaki dostawca internetu, jaki system, ip stałe czy zmienne? Tak na marginesie to czy masz uruchomiony jakiś serwer na kompie?

 


(adrian218) #3

Tak mam uruchomiony serwer ownclouda na ubuntu. Mój dostawca internetu to radiówka, o którego mam wykupione zewnętrzne ip Po ip wewnętrznym jakie przydziela router działa lecz pod zewnętrznym już nie ,


(mechanic) #4

możliwe że na porcie 80 już coś działa, może interfejs routera, dlatego zmień porty, albo routera albo ownclouda


(adrian218) #5

TYlko jak mam to zrobić router na pewno nie działa na porcie 80.


(bart86) #6

pokaż co masz w katalogu /etc/apache2/sites-available

radiówka może blokować niektóre porty w tym 80 co jest dość częste


(adrian218) #7

000-default.conf

http://wklej.org/id/2370402/

 

default-ssl.conf

http://wklej.org/id/2370403/


(bart86) #8

Spróbuj wejść po https i pokaż co się pokazało.

W pliku 000-default.conf zmień port w pierwszej linijce z 80 na 88, zresetuj apache2 i spróbuj wejść http://adresip:88

Wysłane z mojego LG-D802 przy użyciu Tapatalka


(adrian218) #9

Z tym Ubuntu nowym to jest jakaś masakra zauważyłem że zmienia mi się ip po uruchomieniu  więc chciałem przypisać ip statyczne robię tak:

/etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo eth0
iface lo inet loopback
iface eth0 inet static
        address xxx.xxx.xxx.xxx(enter your ip here)
        netmask xxx.xxx.xxx.xxx
        gateway xxx.xxx.xxx.xxx(enter gateway ip here,usually the address of the router)

 

Oczywiście uzupełniam swoimi danymi i przy próbie restartu interfaces dostaje :

 

[…] Restarting networking (via systemctl): networking.serviceJob for networking.service failed because the control process exited


(roobal) #10

Większość routerów ma remote management wyłączony, więc i tak przekierowanie powinno działać. Ja podejrzewam, że problem leży gdzie indziej - łączysz się z własnej sieci, a Twój router prawdopodobnie odrzuca pakiet w pętli. Spróbuj spoza sieci, np. od kogoś lub z sieci mobilnej.


(adrian218) #11

No właśnie z poza innej sieci nie działa ale jak spinguje ten adres po moim zewnetrznym ip to mam :

 

PING 193.239.126.***(193.239.126.*** 56(84) bytes of data.


(bart86) #12

Czyli masz zmienne ip to nie wina systemu.

Wysłane z mojego LG-D802 przy użyciu Tapatalka


(roobal) #13

Zapomniałeś ukryć IP :wink: Łączysz się przez PPPoE? Ewentualnie pokaż maskę podsieci. Sprawdzałeś DMZ czy działa? Jeśli działa, to albo masz źle przekierowany port, albo owncloud działna na innym porcie (sprawdzisz netstatem na jakim nasłuchuje), albo w firmware jest błąd lub sprzęt ma wadę produkcyjną i przekierowanie nie działa.


(adrian218) #14

Nic nie pomaga dmz jest podany na adres ip komputera czyli 10.0.1.100 , port 80 na routerze odblokowany a nic nie działa po zewnętrznym ip jest to dla mnie dziwne bo kiedyś jak robiłem na tym samym routerze i innej wersji ubuntu wszystko działało. Choć tu nie system pewnie ma znaczenie.


(roobal) #15

Pokaż zakładkę status routera.