Konfiguracja wirtual hosta


(tomi001) #1

Mam problem z podpięciem domeny do virtualhosta (apache) otóż mod Vhost jest włączony do apacha, ale teraz jak wpisuje adres ip do pliku /etc/host.conf do dostaje komunikat

 

/etc/host.conf: line 2: bad command `www.domena.tld 127.0.0.1'



ping: unknown host www.domena.tld

Próbowałem  www.domena.tld 127.0.0.1 i też tak 127.0.0.1 www.domena.tld, chodzi o to, żeby lokalnie zarezerwować tą domenę i żeby ta domena działała pod apachem, a nie chcę jej nawet pingować.


(bachus) #2

No to pokaż kawałek ten konfiguracji, nie wiadomo co tam jest. Nie powinno być ServerName www.domena.tld ?


(_nikt79_) #3

Adres wpisujesz do pliku /etc/hosts nie do /etc/host.conf (jeżeli chcesz serwować domenę domena.ltd na adresie 127.0.0.1)

Dodatkowo potrzebujesz pliku konfiguracyjnego vhosta w /etc/apache2/sites-available i /etc/apache2/sites-enabled a po ich umieszczeniu restart lub reload apacha


(tomi001) #4

Dzięki teraz działa musiałem tylko edytować plik /etc/hosts a nie /etc/host.conf