Konflikt repozytoriów lub wersji bibliotek Ubuntu


(Dnalo Ps) #1

 

Mam zainstalowane Ubuntu 14.04 i zainstalowałem program SciDAViS korzystając z centrum oprogramowania jednak podczas użytkowania natrafiłem na problemy więc postanowiłem zainstalować najnowszą wersję z oficjalnej strony. Instalacja bezpośrednio z źródła się nie powiodła ze względu na brak odpowiedniej wersji bibliotek, po krótkim przeszukiwaniu sieci postanowiłem że dodam wpisy z nowszej wersji systemu (15.04 lub 15.10 nie pamiętam) do pliku sources.list. Dokonałem odpowiednich wpisów i przez menadżera Synaptic chciałem zainstalować nowsze wersje wymaganych bibliotek lub zainstalowałem nie pamiętam dokładnie, lecz zmierzam do tego że podczas mieszania w Synapticu doszedłem do miejsca w którym chciałem coś zainstalować i nie zauważyłem że przy okazji usunę znaczną część składową systemu. Kliknąłem ok i po chwili zobaczyłem czarny ekran, a po restarcie nie dało się uruchomić systemu więc go reinstalowałem. Po tym eksperymencie dałem sobie spokój na jakiś czas.

Ostatnio jednak zacząłem regularnie używać SciDAViS, zainstalowanego z centrum oprogramowania. Jego błędy znów zaczęły mnie denerwować więc postanowiłem zainstalować nowszą wersję, tym razem przy użyciu paczki .deb. Tu również musiałem zainstalować nowsze wersje bibliotek więc zrażony poprzednią metodą postanowiłem skorzystać z paczek .deb. Ten sposób umożliwił instalację pożądanego programu lecz spełnienie zależności wiązało się z deinstalacją innego programu(Librecad). Na krótką chwilę miałem spokój jednak ostatnio chciałem zainstalować wine i odkryłem że jest to niemożliwe jak również zainstalowanie innych programów(przy jakiejkolwiek próbie synaptic znowu chce usunąć i zaktualizować znaczną cześć programów, poprzez również terminal również nic nie mogę zrobić)

Rozumuję to tak że jest jakiś konflikt pomiędzy wersjami bibliotek z nowszej wersji systemu które są wymagane do działania pożądanego prze zemnie programu na starszej wersji systemu. Tak ?

Jak mogę to naprawić zachowując najnowszą wersję SciDAViS ? (Rozważałem podniesie wersji dystrybucji)

Jak zaradzić tego typu problemom w przyszłości ?

Trochę namieszałem ale myślę że zrozumiecie.


(bart86) #2

przeinstaluj system i nie używaj centrum oprogramowania, zainstaluj z terminala

 

apt update && apt install -y scidavis

(Dnalo Ps) #3

Jeśli zainstaluję z terminala to będę miał starszą wersję scidavis w której są błędy a ja chcę mieć nowszą.


(bart86) #4

To zainstaluj nowszą wersję Ubuntu

Wysłane z mojego LG-D802 przy użyciu Tapatalka