Laptop (ASUS F553M) nie tolerujący Linuxa


(Mailbfhearn) #1

Witam,

ostatnie kilka dni spędziłem na walce z latopem kolegi, który chciał mieć zainstalowany system Linux. Wynik tej walki jest mocno średni..

 

Jakie działania podjąłem..

 

1)


(dragonn) #2

Jakim błędami sypie Manjaro? Acpi=off nie jest rozwiązanie - wyłącza ono całe zarządzanie energią/zasilaniem dlatego też lapek się nie wyłącza. Napisz również dokładną konfigurację lapka.


(pocolog) #3

Czy przypadkiem “co któreś uruchomienie kończy się zwiechą” nie jest spowodowane błędami na dysku twardym? Fsck odpala się domyślnie co kilka uruchomień komputera.


(roobal) #4

Czyli na linii Asus - Linux jak widzę nic się nie zmieniło. Ostatnio właśnie zastanawiałem się czy kupować Asusa, ale ostatecznie postawiłem na Dell, który współpracuje z Canonical, sprzedaje laptopy z Ubuntu, więc z Linuksem nie może być problemów.

 

Jeśli na tym Asusie jest grafika Nvidii, spróbuj uruchomić z opcją noapic lub nolapic.


(Frankfurterium) #5

 

Bywa różnie.

Jakiś czas temu miałem okazję pracować na kobylastym Inspironie z preinstalowanym Ubuntu i obklejonym z każdej strony logiem Canonical. Compiz sypał się co kilka-kilkanaście minut. Dla przeciwwagi ostatnio potestowałem należącego do znajomego Asusa (którego można dostać sporo taniej niż pod linkiem). Kubuntu i Manjaro z KDE pracowały bez żadnej konfiguracji. Wifi, klawisze multimedialne, dotykowy ekran.


(Tomek) #6

Sam użytkuję della i zero problemów. Z początku nie działał prawie touchpad, ale zmieniło się z kolejnymi wersjami jajka. Aktualnie manjaro ale rozmyślam nad przesiadką na debiana.


(roobal) #7

@Frankfurterium, @Buber82 no wiadomo, wyjątki się zdarzają. Jak to się mówi - wyjątek potwierdza regułę :wink:


(Mailbfhearn) #8

Sorry, że zwlekałem z odp., ale nie miałem dostępu do komputera…

 

@dragonn - już teraz ci dokładnie nie powiem… bo byłem w lekkiej depresji jak to sprawdzałem … (to był któryś system z kolei i już byłem poważnie zrezygnowany…), ale coś mi się wydaje, że był problem po stronie dysku twardego… tzn. w kreatorze na tym kroku chyba się wykrzaczyło… (ale głowy nie dam…) Może @pocolog coś dobrze czuje… ale nie wiem jak to weryfikować dalej…

 

@pocolog - dwa razy udało mi się ubuntu uruchomić bez ustawienia flagi acpi to wtedy żadnych błędów chyba nie było… A odnośnie dysku nawiązałem wyżej…

 

Natomiast jak uruchamiam to ubuntu bez falgi to następuje zwiecha (i nie mam informacji z komunikatami…). Ale np. na szybko uruchomiłem teraz debiana bo miałem akurat pena przygotowanego… i on daje takie komunikaty:

 

i następuje zwieszka…

 

O dziwo… po dodaniu acpi=off błędy są praktycznie identyczne jak wyżej… tylko na końcu pojawia się tego typu komunikat:

 

_ intel_soc_dts_terminal request_threaded_irq ret -22  _ (może być gdzieś literówka…)

 

i jescze jakies napisy, które po sekundzie znikają i system jest załadowany…

 

@roobal - raczej nie ma karty nvidii (ogólnie ten lapek jakoś ciężko znaleźć nawet w sieci… a paradoksalnie najwięcej wyników (związanych również z problemami) znalazłem w języku portugaliskim lub włoskim -.- )

 

tutaj jakis link: http://www.pcdiga.com/2/15411/Portatil-Asus-15-6-F553MA-BING-SX361B

 

 

Ale może coś w tym jest, że ten Asus nie toleruje linucha :@ (a nie spodziewałem się, że coś takiego może być…)

 


(dragonn) #9

To ja raczej obstawiam na problem z Win i jego dziwnym układem partycji który czasami robi niż z sprzętem, może warto by spróbować zainstalować Arch-a?


(roobal) #10

@dragonn To jest laptop z Windows 8, więc na 99% nadysku jest tablica partycji GPT.

Może to coś pomoże :arrow: http://www.thomas-krenn.com/pl/wiki/Instalacja_systemu_operacyjnego_na_platformach_z_UEFI


(Mailbfhearn) #11

@dragonn - może będę musiał o tym pomyśleć…

@roobal - tylko dwie sprawy - ja w sumie wyłączyłem u siebie secure boota (zgodnie z jakimś tutkiem), a tutaj wydaje się być instrukcja pokazująca instalację z włączonym EFI ? Poza tym czy taka instalacja może spowodować, że ubuntu będzie się normalnie ładowało ? (bez kombinowania z tymi flagami ?)


(dragonn) #12

Można mieć włączone EFI z wyłączonym Secure Boot co jest wręcz zalecane bo EFI nie tylko odpowiada za uruchomienie systemu ale równie za część komunikacji z sprzętem , tak że uruchamianie systemu w trybie legacy bios na EFI może powodować niespodziewane problemy.


(Mailbfhearn) #13

@dragonn - znaczy się… może się rozpędziłem … bo dokładnie nie wiem bym jest to EFI (myślałem, że jest to praktycznie równoznaczne z UEFI…)

 

Ogólnie wyłączałem secure boota zgodnie z tym tutkiem: http://itsfoss.com/disable-uefi-secure-boot-in-windows-8/