Lepsza jakość dźwięku w systemie


(happypiotr) #1

Dzień dobry, czy mógłbym prosić o poradę.
Czy są jakieś pakiety, soft, co można by było wpłynąć na poprawę (korektę) dźwięku w systemie?

Bo mam laptopy Dell, w nich jakieś zwykłe karty dźwiękowe Realtek High Definition Audio.
Ale jest coś takiego co instaluje się samo w Win:

To jest chyba jakiś soft komercyjny co z Dellem jest za free.
Czy można coś znaleźć do Linuksa, coś podobnego? Co można by było zastosować?
Można coś zrobić, aby polepszyć dźwięk?
Dziękuję.


(happypiotr) #2

To jest ta strona tego softu


Dało by się coś znaleźć pod Linux coś podobnego?
Aby polepszyć dźwięk?

Dodam. Oczywiście głośniki w laptopie to inna sprawa i nie chodzi o to, bo zastosowanie takiego softu rzutuje również na wyjście audio (głośniki).
A po przejściu z Win na Linux, co jest ten sofy pod Windą, to dźwięk systemowy jest jak z radia tranzystorowego na łące :frowning:


(GForce) #3

GNOME ALSA Mixer (gnome-alsamixer) na mojej karcie Sound Blaster X-Fi na Manjaro działa świetnie.


(gunter) #4

To jest jakiś tam equalizer. Różnie można poprawiać dźwięk w Linuksie, a najprościej jak korzysta się z pulseaudio to zainstalować pulseaudio-equalizer.

sudo apt-get install pulseaudio-equalizer

W pliku konfiguracyjnym pulseaudio.

sudo gedit /etc/pulse/default.pa

Na końcu dodaj taki wpis.

### Dla pulseaudio equalizer
load-module module-equalizer-sink
load-module module-dbus-protocol

Teraz przeładuj pulseaudio.

pulseaudio -k

W miejscu zarządzania dźwiękiem (np. pavucontrol ) wybierz wyjście przez equalizer, coś w rodzaju “FFT based equalizer nazwa twojej karty coś tam”

Uruchom equalizer:

qpaeq

Ustaw i zapisz profile. ( można powiększyć będzie łatwiej ustawiać )


(GForce) #5

Pulseaudio equalizer odinstalowałem już dawno temu, u mnie w ogóle to nie działa, brak korektora, zniknęło wiele opcji, jakieś dziwne trzaski i szumy przy zwiększaniu głośności… kiedyś działo to elegancko, ale po którejś z aktualizacji coś się zepsuło, system Manjaro Xfce.


(gunter) #6

Pewnie myślisz o tym:

https://www.google.pl/search?q=pulseaudio+equalizer&client=firefox-b&dcr=0&source=lnms&tbm=isch&sa=X&ved=0ahUKEwj82vGJoc3WAhVlJJoKHWjHAfMQ_AUICigB&biw=1120&bih=534#imgrc=x5jlo9RofNGLgM:

A ja pisze o czymś takim:

https://www.google.pl/search?q=qpaeq&client=firefox-b&dcr=0&source=lnms&tbm=isch&sa=X&ved=0ahUKEwip-oCYoc3WAhUsJJoKHX9nDrQQ_AUICygC&biw=1120&bih=534#imgrc=qhx9nVn0iNwHqM:

Dla swojej kart Sound Blaster X-Fi, to powinieneś zmienić częstotliwość próbkowania, pewnie jest marne 44100. Pość jakoś muzę i pokaż:

cat /proc/asound/card0/pcm0p/sub0/hw_params


(GForce) #7

rate: 48000 :smile:


(gunter) #8

No ja dla swojego Sound Blaster X-Fi xtreme music mam troszkę więcej, możesz spróbować.
W pliku, jak go nie masz to zrób w domowym użytkownika.

~/.config/pulse/daemon.conf

Mam takie ustawienia.

resample-method = src-sinc-best-quality
default-sample-format = s32le
default-sample-rate = 192000
alternate-sample-rate = 96000
nice-level = -15

Restartuj pulseaudio

pulseaudio -k

i sprawdź, by wrócić do starych ustawień wystarczy skasować ten plik.