Linux i partycja systemowa Windows Veracrypt


(qbpm) #1

Witam.
Czy istnieje opcja zamontowania pod Linuxem partycji systemowej Windows zaszyfrowanej Veracrypt?
W przypadku truecrypt robiło się to (o ile pamiętam):
cryptsetup open --type tcrypt --tcrypt-system /dev/sda2 winda
w --help znalazłem, że należy dodać do tego --veracrypt

Próbowałem tak:

[root@mojkomp ja]# cryptsetup open --type tcrypt --tcrypt-system --veracrypt /dev/sda2 winda
Hasło: 
Nie wykryto nagłówka urządzenia z tym hasłem.
Hasło: Błąd podczas odczytu hasła z terminala.
[root@mojkomp ja]# cryptsetup open --type tcrypt --veracrypt /dev/sda2 winda
Hasło: 
Nie wykryto nagłówka urządzenia z tym hasłem.
Hasło: Błąd podczas odczytu hasła z terminala.
[root@mojkomp ja]# cryptsetup open --type tcrypt --tcrypt-system /dev/sda2 winda
Hasło: 
Nie wykryto nagłówka urządzenia z tym hasłem.

Mam aktualny arch linux i cryptsetup 1.7.5, Partycja Windows 7 utworzona w Veracrypt 1.21


#2

Szyfrowanie za pomocą VeraCrypt jest multi-platformowe.
Listę obsługiwanych poleceń otrzymasz wpisując veracrypt -h


(pocolog) #3

Jeśli utworzyłeś przez veracrypt to otwieraj przez veracrypt. Musisz go wcześniej zainstalować, ale nie powiem ci jak, ani czy jest w repo bo przecież nie podałeś dystrybucji :wink:


(roobal) #4

TrueCrypt nigdy nie był w repo jakiejkolwiek popularnej dystrybucji, podejrzewam że z VC jest podobnie.

Jak napisał @pocolog zainstaluj VC z GUI i tam zamontuj partycje z opcją pominięcia bootloadera.


(pocolog) #5

O dziwo Gentoo ma veracrypt w galezi testing :wink:


(qbpm) #6

Przed napisaniem posta próbowałem otworzyć przez veracrypt, (jest w mojej dystrybucji) jednak miałem jakieś zaćmienie, i podawałem nie tą partycję. :rofl: Spróbowałem jeszcze raz przez veracrypt i zadziałało. :wink: Do tej pory truecrypy otwierałem cryptsetup. Używam niestandardowego PIM. Co ciekawe, pod W7 ustawiłem, żeby nie pytał o PIM przy starcie systemu i nie pyta, a veracrypt pod Linuxem mimo to wymaga jego podania, bez tego nie działa. Podejrzewam, że gdybym miał standardowy PIM przy szyfrowaniu partycji systemowej W7 to cryptsetup by dał radę. W cryptsetup nie działa opcja PIM, choć dokumentacja mówi, że taka jest:
To open a VeraCrypt device with a custom Personal Iteration Multiplier (PIM) value, additionally to --veracrypt use either the --veracrypt-pim= option to directly specify the PIM on the command- line or use --veracrypt-query-pim to be prompted for the PIM.

cryptsetup tcryptOpen --tcrypt-system --veracrypt --veracrypt-query-pim  /dev/sda2 winda 
--veracrypt-query-pim: nieznana opcja

cryptsetup tcryptOpen --tcrypt-system --veracrypt --veracrypt-pim xx /dev/sda2 winda 
--veracrypt-pim: nieznana opcja

No chyba, że coś źle robię…
W każdym razie efekt osiągnąłem poleceniem:

# veracrypt -t -m system --pim=xx --protect-hidden=no  /dev/sda2 /mnt/test/
Enter password for /dev/sda2: 
Enter keyfile [none]: 

co prawda wkurza mnie pytanie o keyfile, bo trzeba dodatkowo enter wciskać, ale generalnie daje radę.
Dzięki.


(Domker) #7

A nie można dodać parametru:
- -keyfile ""
lub
- -keyfile " "
Nie powinno wówczas pytać o plik klucz.


(qbpm) #8

Działa: :slight_smile:
veracrypt -t -m system --pim=xx --protect-hidden=no --keyfiles= /dev/sda2 /mnt/test/
Przedtem próbowałem keyfiles=[none] i jeszcze jakieś, to nie działało. Na najprostsze nie wpadłem.


(roobal) #9

Może coś się zmieniło. TC był dostępny tylko na stronie :wink:


(roobal) #10

Możesz napisać jak wyłączyłeś pytanie o PIM?


(qbpm) #11

Veracrypt/system/settings/ i ptakiem zaznaczyłem:
Do not request PIM in the pre-boot authentication screen (PIM value is stored unencrypted on disk)


(roobal) #12

Ok, dzięki. Szukałem tej opcji, ale nie mogłem się jej doszukać.