Linux Mint 12 Skype nie chce się uruchomić


(Krzysztofbanas) #1

Mam Linux Mint 12 z KDE wersja 64 bitowa. Po zainstalowaniu z menadżera oprogramowania Skypa ten nie chce się uruchomić. Gdy wpisałem skype w terminalu efekt był następujący.

banan@Banan ~ $ skype

skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

Jak rozwiązać ten problem?


(Marcinch7) #2

Jeżeli x86:

sudo apt-get install libxss1

Jeżeli x64:

sudo apt-get install ia32-libs

(Krzysztofbanas) #3

Problem nadal występuje po skopiowaniu tej komendy wyskoczyło mi, że "libxss1 jest już w najnowszej wersji", a Skype nadal nie działa.


(Marcinch7) #4

System x64 czy x86?


(marcin82) #5

Banan

Podaj wynik polecenia:

arch

Sprawdź czy masz zainstalowane pakiety:

libdbus-1-3 libqt4-core libqt4-gui

Podobny wątek:

http://forum.linuxmint.pl/index.php/top ... l#msg31796 .


(Krzysztofbanas) #6
banan@Banan ~ $ arch

x86_64

banan@Banan ~ $ libdbus-1-3

libdbus-1-3: nie znaleziono polecenia

banan@Banan ~ $ libqt4-core

libqt4-core: nie znaleziono polecenia

banan@Banan ~ $ libqt4-gui

libqt4-gui: nie znaleziono polecenia

(marcin82) #7
sudo apt-get -y install libdbus-1-3 libqt4-core libqt4-gui

(Krzysztofbanas) #8

Sorki ale mnie trzeba prowadzić "za rączkę" =P

banan@Banan ~ $ sudo apt-get -y install libdbus-1-3 libqt4-core libqt4-gui

[sudo] password for banan: 

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

libdbus-1-3 jest już w najnowszej wersji.

The following package was automatically installed and is no longer required:

  openoffice.org-common

Aby je usunąć należy użyć "apt-get autoremove".

Zostaną zainstalowane następujące NOWE pakiety:

  libqt4-core libqt4-gui

0 aktualizowanych, 2 nowo instalowanych, 0 usuwanych i 8 nieaktualizowanych.

Konieczne pobranie 14,8 kB archiwów.

Po tej operacji zostanie dodatkowo użyte 262 kB miejsca na dysku.

Pob: 1 http://archive.ubuntu.com/ubuntu/ oneiric-updates/universe libqt4-core amd64 4:4.7.4-0ubuntu8.1 [6298 B]

Pob: 2 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main libqt4-gui amd64 4:4.7.4-0ubuntu8.1 [8462 B]

Pobrano 14,8 kB w 5s (2678 B/s)     

Zaznaczenie poprzednio niezaznaczonego pakietu libqt4-core.

(Odczytywanie bazy danych ... 160708 files and directories currently installed.)

Rozpakowanie libqt4-core (z .../libqt4-core_4%3a4.7.4-0ubuntu8.1_amd64.deb) ...

Zaznaczenie poprzednio niezaznaczonego pakietu libqt4-gui.

Rozpakowanie libqt4-gui (z .../libqt4-gui_4%3a4.7.4-0ubuntu8.1_amd64.deb) ...

Konfigurowanie libqt4-core (4:4.7.4-0ubuntu8.1) ...

Konfigurowanie libqt4-gui (4:4.7.4-0ubuntu8.1) ...

banan@Banan ~ $ skype

skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

(Marcinch7) #9
sudo apt-get install ia32-libs

Gdybyś wykonał moje instrukcje poprawnie, wszystko by działało po moim pierwszym poście.


(Krzysztofbanas) #10

Hmm...

banan@Banan ~ $ sudo apt-get install ia32-libs

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

ia32-libs jest już w najnowszej wersji.

The following package was automatically installed and is no longer required:

  openoffice.org-common

Aby je usunąć należy użyć "apt-get autoremove".

0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 8 nieaktualizowanych.

banan@Banan ~ $ skype

skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

Chyba jednak nie =|


(Marcinch7) #11

To walnij symlinka libXss.so -> libXss.so.1


(Krzysztofbanas) #12

Prosiłem żeby mnie prowadzić "za rękę". Czyli jak to^ zrobić?


(marcin82) #13

Podaj wynik polecenia:

sudo updatedb && locate libXss.so.1

(Krzysztofbanas) #14
banan@Banan ~ $ sudo updatedb && locate libXss.so.1

[sudo] password for banan: 

/home/banan/libXss.so.1.0.0

/usr/lib/x86_64-linux-gnu/libXss.so.1

/usr/lib/x86_64-linux-gnu/libXss.so.1.0.0

(Marcinch7) #15

sudo ln -s /usr/lib/x86_64-linux-gnu/libXss.so.1 /usr/lib/x86_64-linux-gnu/libXss.so


(Krzysztofbanas) #16

:expressionless:

banan@Banan ~ $ sudo ln -s /usr/lib/x86_64-linux-gnu/libXss.so.1 /usr/lib/x86_64-linux-gnu/libXss.so

[sudo] password for banan: 

banan@Banan ~ $ skype

skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

(Marcinch7) #17

Spróbuj to:

sudo apt-get install libxss1:i386

sudo apt-get install libqt4-core:i386

sudo apt-get install libqt4-gui:i386

sudo apt-get install libdbus-1-3:i386


(Krzysztofbanas) #18

No to tak pierwszy pakiet nie został odnaleziony. Drugi i trzeci zainstalowały się. Zaś ostatni jest już w najnowszej wersji. Po wpisaniu skype nadal to samo.


(marcin82) #19

Ostatecznie możesz spróbować zainstalować pakiet w ten sposób ... Pobierz pakiet dla i386 stąd:

http://ubuntu.mirror.cambrium.nl/ubuntu ... 2_i386.deb

Przenieś go na Pulpit, następnie otwórz terminal, przejdź na Pulpit:

cd Pulpit

i zainstaluj pakiet poleceniem:

sudo dpkg --force-architecture -i libxss1_1.2.1-2_i386.deb

Za efekty oczywiście nie można w żaden sposób ręczyć ...


(Krzysztofbanas) #20

Plik jest na pulpicie, a efekt

banan@Banan ~ $ sudo dpkg --force-architecture -i libxss1_1.2.1-2_i386.deb

[sudo] password for banan: 

dpkg: błąd przetwarzania libxss1_1.2.1-2_i386.deb (--install):

 brak dostępu do archiwum: Nie ma takiego pliku ani katalogu

Wystąpiły błędy podczas przetwarzania:

 libxss1_1.2.1-2_i386.deb

-- Dodane Pt, 30 marca 2012, 07:31 --

Wszedłem w Synaptic i odinstalowałem skype i zainstalowałem skype:i386. Skype działa jak należy :smiley: