Linux Mint 18.1 64bit problem ze sterownikami Nvidia Geforce (kart grafiki)


#1

Wgrałem dziś Linuxa zamiast Windows 10. Wszystko było pięknie do czasu zainstalowania Zalecanego sterownika do karty graficznej Geforce 920M poprzez Menadżer sterowników.
Mam laptopa z dwoma kartami - zintegrowaną i dodatkową - Intel HD 5500 / Geforce 920M
Po restarcie system przeszedł w Recovery Mode - przyczyną jest właśnie problem ze sterownikami Nvidia.
Pobrałem więc inny sterownik - wersja 374, kompatybilna z moją kartą. Ten sam problem.

System uruchamia się normalnie tylko, gdy używam sterownik Nouveau - ale wtedy karta Nvidia jest nieaktywna i działa Intel czy tego chcę czy nie. A ja chcę właśnie, by Geforce odawalał całą robotę.

Usunąłem sterownik Nvidia i nie wiem co w końcu zrobić, żeby karta działała bez problemów. Czytałem na różnych forach i nie ma skutecznej metody.

Proszę ewentualnie o wskazówki jak pozbyć się całkowicie wszystkiego związanego z Nvidią z systemu skoro nic i tak nie działa, a w Menadżerze Sterowników jest tego w cholerę.

System dzisiaj postawiony, więc nie instalowałem/zmieniałem niczego oprócz zabawy z tym sterownikiem Nvidia, który nie działa od początku.


(FadeMind) #2

#3

Co z tymi czterema sterownikami nvidia, które widnieją u mnie na liście? Można je jakoś usunąć? Manualnie instalowałem tylko jeden, a tutaj wywaliło aż tyle


(FadeMind) #4

Ubuntu dostarcza kilka wersji sterownika binarnego NVIDIA. Jeżeli masz nowszą dGPU NVIDIA to instalujesz najnowszą wersję (w tym przypadku 381.22). Mint bazuje na Ubuntu :stuck_out_tongue: Niestety Canonical uwaliło bumblebee (w przeciwieństwie do Archa/Manjaro).

W Manjaro bumblebee działa Out Of Box - user tylko wybiera tryb uruchomienia systemu live NON FREE :wink:

W Ubuntu/Mint trzeba ręcznie wszystko ogarniać :smiley:

Dodatkowo NVIDIA Prime na sztywno aktywuje NVIDIA dGPU albo Intel iGPU po ponownym uruchomieniu systemu (wybór w NVIDIA Settings).


#5

Zainstalowałem ten najnowszy sterownik 381 + Nvidia X Server Settings i nadal uruchamia się w trybie awaryjnym przy tym sterowniku :frowning:


(FadeMind) #6

Zainstaluj Manjaro i nie męcz się z Ubuntu/Mint. Kernel 4.4 LTS nie jest zgodny z najnowszym sprzętem i mogą pojawiać się takie problemy.


#7

Zrobiłem reinstall Mint’a. Pobrałem Nvidia prime i settings oraz ustawiłem sterownik Nvidia 375 - zalecany.

Teraz nie ma już problemu z trybem awaryjnym - system startuje normalnie, ale… widnieje komunikat “Nvidia prime is not supported by your hardware” na skrócie od Nvidia prime.

Skoro sterownik Intela jest wyłączony, a Nvidii włączony, to system powinien używać tylko kartę Nvidia? Czy jednak jest na tyle upośledzony, że nadal nie widzi tej drugiej?

Chcę używać tylko kartę Nvidia - zintegrowana jest zbędna.

Graphics: Card-1: Intel Broadwell-U Integrated Graphics
Card-2: NVIDIA GK208M [GeForce 920M]
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
Resolution: 1366x768@60.05hz
GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) GLX Version: 3.0 Mesa 11.2.0


(FadeMind) #8

Ewidentnie kernel jest za stary na twój sprzęt :wink: 4.10.x albo 4.11 to minimum (obecnie).


#9

Temat do zamknięcia :smiley:

Odpaliłem teraz system…a tutaj wszystko już pięknie działa - mogę w końcu skonfigurować ustawienia Nvidia. Prime działa.

Widać, trzeba było zrestartować dwa razy i dać mu czas na zastanowienie się :slight_smile:

Dzięki za pomoc


(FadeMind) #10

Życzę wytrwałości i zawziętości w pogłębianiu wiedzy nt. Linuxa :wink: 98% problemów jest już znanych/rozwiązanych/opisanych na anglojęzycznych forach :grin:


#11

Mam z nim kontakt pierwszy raz w życiu, stąd takie problemy nowicjusza. Kłaniają się nawyki z Windowsa. Z Dziesiątką nie mogłem już wytrzymać, więc postanowiłem się jej pozbyć :slight_smile: