Linux Mint, nie uruchamiają się przeglądarki


(Le_mar) #1

Czołem
Linux Mint 17.3 32bit, jądro 3.19.0-32-generic i686
przestały uruchamiać się przeglądarki Slimjet i Chromium.
Slimjet od trzech wersji wstecz, “wszystkie zależności spełnione”.
Nie chce się uruchomić też Chromium po ostatniej aktualizacji do wersji 59, tak to wygląda w terminalu

leszek@leszek ~ $ chromium-browser %U Using PPAPI flash. --disable-new-tab-first-run --enable-user-scripts --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version= Received signal 11 SEGV_MAPERR 000002f5df78 #0 0x0000b46a14b3 base::debug::StackTrace::StackTrace() #1 0x0000b46a0d77 base::debug::StackTrace::StackTrace() #2 0x0000b46a18ce <unknown> #3 0x0000b47e8c98 ([vdso]+0xc97) #4 0x0000b585499c <unknown> #5 0x0000b5855758 <unknown> #6 0x0000b55914b8 <unknown> #7 0x0000b5589c43 <unknown> #8 0x0000b558ce02 <unknown> #9 0x0000afd5201c BrowserContextKeyedServiceFactory::BuildServiceInstanceFor() #10 0x0000b041d436 KeyedServiceFactory::GetServiceForContext() #11 0x0000b558cee6 <unknown> #12 0x0000b557fdd7 <unknown> #13 0x0000b54cc375 <unknown> #14 0x0000b54cddf8 <unknown> #15 0x0000b54cfb0e <unknown> #16 0x0000b54cfc0f <unknown> #17 0x0000b54cfecc <unknown> #18 0x0000b60b9f30 <unknown> #19 0x0000b56e8298 <unknown> #20 0x0000b56e91dc <unknown> #21 0x0000b1ed8e69 content::BrowserMainLoop::PreMainMessageLoopRun() #22 0x0000b2204607 content::StartupTaskRunner::RunAllTasksNow() #23 0x0000b1eda4fe content::BrowserMainLoop::CreateStartupTasks() #24 0x0000b1edf533 <unknown> #25 0x0000b1ed8032 content::BrowserMain() #26 0x0000b25bb6ee <unknown> #27 0x0000ad555b4b service_manager::Main() #28 0x0000b25ba240 content::ContentMain() #29 0x0000b507a047 ChromeMain #30 0x0000b507861b <unknown> #31 0x0000ad6a1af3 __libc_start_main #32 0x0000b5079e8e <unknown> gs: 00000033 fs: 00000000 es: 0000007b ds: 0000007b edi: b9091a9c esi: b9091900 ebp: bffde808 esp: bffde6d0 ebx: b9091748 edx: 00000006 ecx: 00000026 eax: bffde820 trp: 0000000e err: 00000004 ip: b585499c cs: 00000073 efl: 00210282 usp: bffde6d0 ss: 0000007b [end of stack trace] Calling _exit(1). Core file will not be generated. leszek@leszek ~ $
Mam również zainstalowany Xubuntu 32bit, tam nie ma takich problemów.
Jakieś rady?


(adamserce) #2

Czy to samo występuje na koncie gościa?
A próbowałeś odinstalować i na nowo zainstalować?


(Le_mar) #3

Tak
Tak
Bez efektu.
Kursor na chwilę zamienia się w kółeczko, procesor troszkę popracuje…i nic.


#4

Skąd instalacja obu paczek? Istnieje szansa, że Chromium 59 jest już zbyt “nowe” jak na Mint 17 - tak na pierwszy rzut oka. Spróbuj je jednak uruchomić bez żadnych dodatków (nie mam go i nie pamiętam opcji, ale w konsoli pod help wychodzi).


(Le_mar) #5

Chromium aktualizuje się wraz z systemem, Slimjet ze strony domowej programu.
Niestety polecenia nie znalazłem.


#6

Najprościej będzie spróbować odpalić te przeglądarki w konsoli i zobaczyć co wypluje.


(Le_mar) #7

Wkleiłem w pierwszym poście.


#8

Sorki, kawa jeszcze nie weszła.


(Bogdan_G) #9

Próbowałeś palemoona 27?
Wypakować, uruchomić. Z poziomu palemona pobrać spolszczenie, potem ustawić w about:config general.useragent.locale na pl-PL.
https://linux.palemoon.org/download/installer/
http://addons.palemoon.org/language-packs/

Dodam, że w dzisiejszych czasach przydaje się filtrowanie XSS.


#10

Spróbuj zatem tak:
mv ~/.config/chromium ~/.config/chromium.bak
I teraz uruchom program.
Powinien utworzyć domyślny profil i generalnie uruchomić się bez żadnych dodatków. Oczywiście powyższą zmianę będziesz mógł odwrócić. Zdaje się, że podobny efekt uzyskasz uruchamiając chromium w trybie incognito.
Dla slimjet podobnie.


(Le_mar) #11

Wynik:

[quote]leszek@leszek ~ $ mv ~/.config/chromium ~/.config/chromium.bak
mv: nie można przenieść „/home/leszek/.config/chromium” do „/home/leszek/.config/chromium.bak/chromium”: Katalog nie jest pusty
[/quote]
I Chromiun nie uruchamia się.


(Le_mar) #12

Slimjet to Chromium 58, tak jak Opera Stable, która u mnie działa bez problemu.

No problem ;).


#13

Widać już kiedyś stworzyłeś taki katalog (*.bak) - musisz zrobić inny.
To, że “slimjet to chromium 58 tak jak opera stable”, to mocne uproszczenie. We wszystkich tych przeglądarkach jest być może ten sam silnik (Blink), jednakże każda z nich ma własny interfejs, a nadto co najmniej dwie z nich zostały zbudowane z jakimiś ustawieniami, na jakimś kompilatorze, z jakimiś bibliotekami itd. itp. Ze względu na to, że zarówno slimjet, jak i opera są zamkniętymi przeglądarkami - nie możemy nic wiedzieć (no w pewnym uproszczeniu) o nich oprócz jednej rzeczy - wszędzie Blink. Z pierwszego postu raczej nie wynika, by w ogóle ów Blink miał prawo zadziałać.
Swoją drogą, jeśli wyeliminujemy problem z profilami, to jeśli chromium nadal się nie otworzy, a Ty masz “czysty” system (czyli Mint 17/Ubuntu 14.04) bez jakichś istotnych paczek z PPA, to problem do zgłoszenia twórcom Minta (a i tak odeślą do Ubuntu).


(Le_mar) #14

Chyba masz rację, jak pisałem w pierwszym poście, mam Xubuntu i tam wszystko działa, ale to jest ostatnia wersja 16.04. A mój Mint to wersja niższa.
No nic, dzięki.


(Le_mar) #15

Aktualizacja
Właśnie Chromium zaktualizowało się i śmiga bez problemu: