Linux Mint problem z partycją /home


(Michal Fied) #1

Witam wszystkich,


(Amaterasu) #2

Dobry wieczór!

Jeżeli system chodzi - dobrze. Teraz sprawdźmy, czy dobrze wykrywa partycje i czy /home istnieje. W tym celu, uruchom Terminal za pomocą wyszukiwania go w liście programów bądź Control + Alt + Delete i skopiuj komendę:

sudo fdisk - l

Podaj tutaj to, co ta komenda wyświetli.


(Drobok) #3

mrmakaveli Na forum piszemy w języku polskim - popraw swój post korzystając z polskich znaków diakrytycznych.


(Michal Fied) #4

Przepraszam, zapomniałem dodać, że tablica partycji to GPT więc polecenie fdisk tutaj nie działa.


(marcin82) #5

No to podaj wynik:

 

sudo parted -l

A przy okazji:

cat /etc/fstab

cat /etc/mtab

df -BM

dmesg | grep sda

Wszystko - każda komenda w osobnym tagu Code.


(Michal Fied) #6
sudo parted -l
Model: ATA ST9750420AS (scsi)
Dysk /dev/sda: 750GB
Rozmiar sektora (logiczny/fizyczny): 512B/4096B
Tablica partycji: gpt
 
Numer  Początek  Koniec  Rozmiar  System plików   Nazwa   Flaga
 1     1049kB    52,4GB  52,4GB   ext4            System
 2     52,4GB    210GB   157GB    ext4            Dane
 3     210GB     225GB   15,7GB   linux-swap(v1)
 4     225GB     226GB   200MB    fat32                   ładowalna
 5     226GB     236GB   10,0GB   ext4

 

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=f0d9d53b-c303-4bee-86b3-43da6e86f157 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda4 during installation
UUID=31DB-9296  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda5 during installation
UUID=35d6541c-feaa-4bef-8162-362050826a09 /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=ae6edf73-09ef-4cec-833f-8b6011114ef4 none            swap    sw              0       0

 

cat /etc/mtab
/dev/sda1 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/cgroup tmpfs rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /sys/firmware/efi/efivars efivarfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
none /run/user tmpfs rw,noexec,nosuid,nodev,size=104857600,mode=0755 0 0
none /sys/fs/pstore pstore rw 0 0
/dev/sda5 /home ext4 rw 0 0
/dev/sda4 /boot/efi vfat rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
systemd /sys/fs/cgroup/systemd cgroup rw,noexec,nosuid,nodev,none,name=systemd 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user=michal 0 0
/dev/sda2 /media/michal/f1ec0adf-ccbb-46d5-8643-58356e6476e7 ext4 rw,nosuid,nodev,uhelper=udisks2 0 0

 

df -BM
System plików  1M-blocks  użyte dostępne %uż. zamont. na
/dev/sda1         49087M  5960M   40612M  13% /
none                  1M     0M       1M   0% /sys/fs/cgroup
udev               3930M     1M    3930M   1% /dev
tmpfs               789M     2M     788M   1% /run
none                  5M     0M       5M   0% /run/lock
none               3945M   392M    3554M  10% /run/shm
none                100M     1M     100M   1% /run/user
/dev/sda5          9259M   235M    8532M   3% /home
/dev/sda4           189M     4M     185M   2% /boot/efi
/dev/sda2        147519M 25159M  114844M  18% /media/michal/f1ec0adf-ccbb-46d5-8643-58356e6476e7

 

dmesg | grep sda
[   2.010153] sd 0:0:0:0: [sda] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
[   2.010154] sd 0:0:0:0: [sda] 4096-byte physical blocks
[   2.010236] sd 0:0:0:0: [sda] Write Protect is off
[   2.010238] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[   2.010279] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   2.068990]  sda: sda1 sda2 sda3 sda4 sda5
[   2.069856] sd 0:0:0:0: [sda] Attached SCSI disk
[   2.998336] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   5.342082] Adding 15359996k swap on /dev/sda3.  Priority:-1 extents:1 across:15359996k FS
[   9.572512] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   9.945863] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
[1672.106957] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)

(nintyfan) #7

Jeżeli partycja /home jest zamontowana, to nie jest widoczna w oknie mój komputer. To standard i chyba tylko Windows tego się nie trzyma.


(KoczurekK) #8

@nintyfan ma rację, partycja zamontowana w /home nie jest pokazywana w nemo (miętowy eksplorator plików) jako osobny dysk ani w zakładce “Mój komputer”, ani “Urządzenia” po lewej.  :) Jeżeli bardzo ci zależy możesz spróbować to obejść. :stuck_out_tongue_winking_eye:

 

Droga moderacjo, rozwiązanie tym razem testowane (Nie zmieniło się nic poza tą linijką o ostrzeżeniu - działało, jeżeli ktoś użył moich porad nie ma się czym martwić). :slight_smile:

 

Naciśnij Alt + Ctrl + F1 i zaloguj się na konto roota a następnie odmontuj partycję podpiętą pod /home

umount /home

I usuń katalog /home (najpierw upewnij się, że jest pusty!)

rmdir /home

W katalogu /media utwórz katalog home

mkdir /media/home

W pliku /etc/fstab zmień tą linię:

UUID=35d6541c-feaa-4bef-8162-362050826a09 /home           ext4    defaults        0       2

na:

UUID=35d6541c-feaa-4bef-8162-362050826a09 /media/home           ext4    defaults        0       2

I podlinkuj nowy katalog na miejsce starego /home

ln -s /media/home /home

Teraz wszystko powinno działać, jeżeli napotkasz jakieś problemy, z konta roota usuń link symboliczny /home i utwórz katalog home:

rm -f /home
mkdir /home

A następnie przywróć zmienioną linię w /etc/fstab.

 

Przepraszam za odgrzewanie kotleta i pozdrawiam!