Linux prawie się zawiesza podczas oglądania filmów


(tomi001) #1

Mam taki problem raz jak oglądałem film w mplayerze, a drugi raz jak oglądałem film w ipla to obraz stanął ale dźwięk szedł dalej i nic nie dało się zrobić nawet przełączanie do trybu tekstowego nie dawało rezultatów, z tego można wnioskować że się zawiesił, ale dziwne że dźwięk idzie dalej.


(FadeMind) #2

Podaj wynik polecenia inxi:

inxi -Fxz

(tomi001) #3

Nie znaleziono polecenia.
Edit

Zainstalowałem ten pakiet i mam następujący wynik

System: Host: dhcppc3 Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: KDE 4.14.2 (Qt 4.8.6)
Distro: Debian GNU/Linux 8
Machine: System: SAMSUNG product: 300E4A/300E5A/300E7A/3430EA/3530EA v: 0.1
Mobo: SAMSUNG model: 300E4A/300E5A/300E7A/3430EA/3530EA v: FAB1 Bios: Phoenix v: 06QA date: 04/03/2012
CPU: Dual core Intel Core i3-2350M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9179
Clock Speeds: 1: 915 MHz 2: 1901 MHz 3: 990 MHz 4: 814 MHz
Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
Card-2: NVIDIA GF119M [GeForce GT 520MX] bus-ID: 01:00.0
Display Server: X.Org 1.16.4 drivers: nouveau,intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.06hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
IF: eth0 state: down mac:
Card-2: Intel Centrino Wireless-N 130 driver: iwlwifi v: in-tree: bus-ID: 02:00.0
IF: wlan0 state: up mac:
Drives: HDD Total Size: 2000.4GB (56.6% used) ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
ID-2: USB /dev/sdb model: Touro_Mobile_3.0 size: 1000.2GB
Partition: ID-1: / size: 239G used: 62G (28%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 422G used: 77G (20%) fs: ext4 dev: /dev/sda7
Sensors: System Temperatures: cpu: 68.0C mobo: 29.8C gpu: 67.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 243 Uptime: 37 min Memory: 1918.8/7916.6MB Init: systemd runlevel: 5 Gcc sys: 4.9.2
Client: Shell (bash 4.3.301) inxi: 2.1.28


(gosciuW7) #4

Spróbuj zmienić powłokę Linuxa, zamiast KDE zainstaluj Xfce i sterowniki video.

Jaki to Linux?


(tomi001) #5

Debian gnu linux 8, ja mam sterowniki domyślnie zainstalowane wraz z systemem, jak zainstaluje jakieś inne sterowniki to mogą mi niektóre gry nie działać.


(FadeMind) #6

BBswitch zainstalowany?
https://wiki.debian.org/Bumblebee


(tomi001) #7

Właśnie teraz zainstalowałem, a co on daje ?


(FadeMind) #8

Jesteś nowym użytkownikiem Linuxa/Debiana?


(tomi001) #9

Debiana tak, ale nie linukssa.


(FadeMind) #10

Masz laptopa z NVIDIA Optimus.
Domyślnie Debian używa NOUVEAU. Do poprawnego działania laptop z Optimusem wymaga bbswitch + bumblebee + nvidia (sterownik własnościowy).

Bez BBswitch GPU NVIDIA działa cały czas (nie jest wyłączona) i to powoduje zwiększenie ciepła w obudowie.

Oczywiście po instalacji bumblebee (i jego konfiguracji) trzeba zrestartować laptopa aby wprowadzić zmiany).


(Azi) #11

Jeżeli dobrze rozumiem, to w Mplayer filmy odtwarzają się poprawnie a w ipla są problemy?
Może spróbuj w innej przeglądarce iplę uruchomić. W repo trochę tego znajdziesz…
Co do kwestii sterowników, to już koledzy doradzili Ci wszystko, być może tu jest problem.


(tomi001) #12

Pod mplayerem tez się potrafi zawiesić, ale to rzadko.


(tomi001) #13

ZAinstalowałem bumblebee i nadal się potrafi zawiesić, ale tym razem nie na filmie czyli to nie było przez oglądanie filmu ?


(takijeden.ninja) #14

Jest jeszcze jedna możliwość, bardzo niefajna, ale prawdopodobna.
Być może nawala Ci sprzęt, bo gdyby sypał się jakiś program lub przeglądarka to nie uziemiałoby to całego systemu.
Spróbuj to sprawdzić z jakąś inną dystrybucją linuksa (całkiem odmienną), odpal ją np. w trybie live z pendrajwa i spróbuj odtworzyć jakiś materiał video z dysku oraz Internetu.


#15

Ten film jest odtwarzany lokalnie, czy z internetu? Czy na innym playerze również występuje błąd? Czy ten sam film oglądany ponownie również ma błąd w tym samym miejscu?
Przyczyn szukamy w konfiguracji i w sprzęcie, ale istnieje możliwość, że problem leży zupełnie gdzie indziej. Np. w odtwarzanym pliku, który jest wadliwy.
Niemniej jednak, dobrze owego Optimusa byłoby skonfigurować. O sterownikach nouveau najczęściej osoby, które mają kartę NVidii twierdzą, że służy wyłącznie do instalacji sterowników zamkniętych :slight_smile:


(tomi001) #16

Od tamtego czasu się nie zawiesił, a to nie jest tylko podczas oglądania filmu.


#17

Skoro nie tylko podczas oglądania filmu, a w pierwszym wątku było, że właśnie podczas oglądania filmu, to w takim razie wyartykuuj z jakim błędem maz do czynienia. Inna sprawa, że skoro obecnie nie masz, to istnieje prawdopodobieństwo, że być może jakaś aktualizacja coś zmieniła.
Jeśli błąd będzie występował, to być może sensownie będzie pokazać ostatnie wpisy pliku dziennika, sprzed wystąpienia błędu.