Linux - program do kamerki


(rpm) #1

Witam poszukuję jakiejś alternatywy na Linux do programu manycam. Zależy mi na tym aby ten program posiadał możliwośc przekierowywania obrazu z pulpitu i dodawania zdjęć. Czyli posiadał podobne opcje co manycam. Czy któryś z tych programów te opcje posiada? http://linuxiarze.pl/kamera/

Jak są jakieś inne programy których nie znam, to miło by było jak podacie ich nazwy. Z góry dziękuje, pozdrawiam!


(saturno) #2

VokoScreen

WebcamStudio


(rpm) #3

Dzięki niestety nie mogę zainstalowac tych programów na Ubuntu 15.04. Pobrałem ze stron głównych tych programów i przy instalacji pakietu deb występują konflikty zależności.

Wybieranie wcześniej niewybranego pakietu vokoscreen.
(Odczytywanie bazy danych ... 289617 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu vokoscreen_2.0.0-2_i386.deb ...
Rozpakowywanie pakietu vokoscreen (2.0.0-2) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu vokoscreen:
 vokoscreen zależy od libopencv-highgui2.4; jednakże:
  Pakiet libopencv-highgui2.4:i386 nie jest zainstalowany.
 vokoscreen zależy od libav-tools; jednakże:
  Pakiet libav-tools nie jest zainstalowany.
 vokoscreen zależy od mkvtoolnix; jednakże:
  Pakiet mkvtoolnix nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu vokoscreen (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu bamfdaemon (0.5.1+15.04.20150202-0ubuntu1)...
Rebuilding /usr/share/applications/bamf-2.index...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.10.1-0ubuntu5)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.22-1ubuntu3)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.58ubuntu1)...
Przetwarzanie wyzwalaczy pakietu man-db (2.7.0.2-5)...
Przetwarzanie wyzwalaczy pakietu menu (2.1.47ubuntu1)...
Wystąpiły błędy podczas przetwarzania:
 vokoscreen

 

sudo dpkg -i webcamstudio_0.61-1~getdeb2~trusty_all.deb
Wybieranie wcześniej niewybranego pakietu webcamstudio.
(Odczytywanie bazy danych ... 289595 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu webcamstudio_0.61-1~getdeb2~trusty_all.deb ...
Rozpakowywanie pakietu webcamstudio (0.61-1~getdeb2~trusty) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu webcamstudio:
 webcamstudio zależy od java-wrappers; jednakże:
  Pakiet java-wrappers nie jest zainstalowany.
 webcamstudio zależy od libappframework-java; jednakże:
  Pakiet libappframework-java nie jest zainstalowany.
 webcamstudio zależy od libcommons-cli-java; jednakże:
  Pakiet libcommons-cli-java nie jest zainstalowany.
 webcamstudio zależy od libcommons-codec-java; jednakże:
  Pakiet libcommons-codec-java nie jest zainstalowany.
 webcamstudio zależy od libcommons-httpclient-java; jednakże:
  Pakiet libcommons-httpclient-java nie jest zainstalowany.
 webcamstudio zależy od libcommons-lang3-java; jednakże:
  Pakiet libcommons-lang3-java nie jest zainstalowany.
 webcamstudio zależy od libjna-java; jednakże:
  Pakiet libjna-java nie jest zainstalowany.
 webcamstudio zależy od libjsr305-java; jednakże:
  Pakiet libjsr305-java nie jest zainstalowany.
 webcamstudio zależy od liblog4j1.2-java; jednakże:
  Pakiet liblog4j1.2-
dpkg: błąd przetwarzania pakietu webcamstudio (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu bamfdaemon (0.5.1+15.04.20150202-0ubuntu1)...
Rebuilding /usr/share/applications/bamf-2.index...
Przetwarzanie wyzwalaczy pakietu gnome-menus (3.10.1-0ubuntu5)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.22-1ubuntu3)...
Przetwarzanie wyzwalaczy pakietu mime-support (3.58ubuntu1)...
Przetwarzanie wyzwalaczy pakietu systemd (219-7ubuntu5)...
Przetwarzanie wyzwalaczy pakietu ureadahead (0.100.0-19)...
ureadahead will be reprofiled on next reboot
Wystąpiły błędy podczas przetwarzania:
 webcamstudio

(saturno) #4

VokoScreen powinieneś mieć w repozytoriach.

 

WebcamStudio spróbuj zainstalować przez gdebi


(nintyfan) #5

Co do problemów z zależnościami, to pewnie instalowałeś przez dpkg. Spróbuj najpierw zainstalować brakujące paczki przez apt-get install.


(sir_lucjan) #6

Wydaj polecenie:

 

apt-get -f install

(rpm) #7

Ale ja tak robiłem wpisujac

sudo apt-get -f install

i ciaglę brakowało jakichś zależnosci. Jednak pod odblokowaniu repozytorium starsza wesja VokoScreen jest w systemie.