Linux - /usr/src/linux* - które katalogi można usunąć?


(ra-v) #1

Mam zainstalowane kernel-source, bo coś było potrzebne do sterowników z nvidia.com i VirtualBox, ale jednak zajmują trochę GB. Ale czy jakieś pliki źródeł ze starszych wersji jądra mogą być potrzebne.

Linux - katalogi po prawej - które można usunąć żeby nie zrobić sobie kuku?

# uname -r

2.6.37.6-24-desktop

(etam) #2

http://tech.sixcolumns.com/2012/10/how- … ntu-tweak/


(ra-v) #3

To openSUSE;-)


(etam) #4

To wiele wyjaśnia :slight_smile: Ale która wersja? Factory?

Podaj wyniki poleceń (nie trzeba roota)

rpm -q -f /usr/src/linux*

rpm -q -f /lib/modules/*

grep multiversion /etc/zypp/zypp.conf | grep -v "##"

ls /etc/zypp/multiversion.d/

(ra-v) #5

A skąd mam wiedzieć;-)

linux-70u8:/home/rafalh # rpm -q -f /usr/src/linux*

kernel-devel-2.6.37.6-24.1.noarch

kernel-source-2.6.37.6-24.1.noarch

plik /usr/src/linux-2.6.37.6-0.5 nie należy do żadnego pakietu

plik /usr/src/linux-2.6.37.6-0.9 nie należy do żadnego pakietu

kernel-devel-2.6.37.6-24.1.noarch

kernel-source-2.6.37.6-24.1.noarch

kernel-desktop-devel-2.6.37.6-24.1.x86_64

kernel-desktop-devel-2.6.37.6-24.1.x86_64

linux-70u8:/home/rafalh # rpm -q -f /lib/modules/*

ndiswrapper-kmp-desktop-1.56_k2.6.37.1_1.2-11.3.x86_64

nvidia-gfxG02-kmp-desktop-304.64_k2.6.37.1_1.2-21.1.x86_64

vmware-guest-kmp-desktop-2012.8.8.1_k2.6.37.6_0.11-32.1.x86_64

VirtualBox-4.2-4.2.4_81684_openSUSE114-1.x86_64

VirtualBox-4.2-4.2.4_81684_openSUSE114-1.x86_64

virtualbox-host-kmp-desktop-4.0.12_k2.6.37.6_0.20-0.48.1.x86_64

virtualbox-guest-kmp-desktop-4.0.12_k2.6.37.6_0.20-0.48.1.x86_64

VirtualBox-4.2-4.2.4_81684_openSUSE114-1.x86_64

plik /lib/modules/2.6.37.6-0.9-desktop nie należy do żadnego pakietu

kernel-desktop-2.6.37.6-24.1.x86_64

preload-kmp-desktop-1.2_k2.6.37.6_24-6.19.1.x86_64

linux-70u8:/home/rafalh # grep multiversion /etc/zypp/zypp.conf | grep -v "##"

# multiversion = provides:multiversion(kernel)

linux-70u8:/home/rafalh # ls /etc/zypp/multiversion.d/

ls: nie ma dostępu do /etc/zypp/multiversion.d/: Nie ma takiego pliku ani katalogu

(etam) #6

Sorry, pomyliły mi się numerki. Ty masz 2.6, a w Factory jest 3.6 (w openSUSE 12.2 jest 2.4)

Wygląda na to, że na pewno możesz usunąć

sudo rm -fr /usr/src/linux-2.6.37.6-0.5 /usr/src/linux-2.6.37.6-0.9 /lib/modules/2.6.37.6-0.9-desktop

Cała reszta jest pod opieką menadżera pakietów.

Zrób sobie porządek z pakietami VirtualBoxa, bo masz mieszankę wersji 4.2.4 i 4.0.12 (najprawdopodobniej wystarczy usunąć pakiety virtualbox-host-kmp-desktop i virtualbox-guest-kmp-desktop)


(Frankfurterium) #7

A 12.2 nie ma czasem od razu 3.4?


(etam) #8

Cholerne cyferki. Przecież napisałem, że w 56.2 jest 3.14 :smiley:


(ra-v) #9

13.5 GB - nieźle.

Śmieci po VirtualBox 4.0 - 9 MB

Na razie dzięki za rady, jak się coś rozleci to wpadnę;-)