Linux zainstalował się obok Windowsa XP, ale bios go nie wykrywa


(sewer6) #1

Zainstalowałem sobie Linux Mint 64bit, obok Windowsa XP 32bit, ale komputer po uruchomieniu nie pyta się mnie, który system chcę uruchomić i ładuje XP. Nie wiem czemu tak jest. Linux zainstalował się normalnie z płyty, ale gdy po instalacji kliknąłem, żeby ponownie uruchomić komputer, niby Linux się wyłączył, oddał płytę, ale pozostał szary ekran z jakimiś napisami. Był tam dłuższy czas, więc zresetowałem komputer i wtedy automatycznie wstał XP-ek. Da się to jakoś naprawić, czy muszę jeszcze raz instalować system? Będę musiał wtedy usuwać z dysku wszystkie pojedyncze pliki?

 


(MrBeckham666) #2

musisz albo wgrać grub albo po prostu linuxa od nowa wtedy też się Grub wgra :) 


(sewer6) #3

Tak właśnie postąpiłem. Jak wgrać Gruba?

 


(Amaterasu) #4

Wypal pendraka z Super Grub2 Disk. Ustaw na pierwszym miejscu i uruchom ponownie komputer. Wyświetli Ci się coś podobnego do GRUB-a, przez co będziesz mógł wejść na Linuksa.

Zainstaluj z jego poziomu GRUB-a, uruchamiając Terminal:

sudo apt-get install grub
grub-install --no-floppy /dev/sdX
grub-mkconfig -o /boot/grub/grub.cfg

Gdzie “X” to dysk, na którym jest on zainstalowany.


(sewer6) #5

Zrobiłem to tak jak jest tutaj, ale tutaj to robiłem już drugi raz. Za pierwszym razem wykonywał jeszcze jakieś operacje.

http://www.fotosik.pl/zdjecie/f7e71419be90ffa7

Nie wiedziałem czy w linuxie oznacza się mój dysk tą samą literą co w Windowsie. Wcześniej napisałem po prostu C, ale spróbowałem jeszcze raz w ten sposób.

http://www.fotosik.pl/zdjecie/d26d52068ab2d480

Ogólnie jak robiłem to wszystko pierwszy raz to ostatnie komenda w ogóle nie weszła.


(Piesek64) #6

Wykonuj WSZYSTKIE operacje jako root. Przez sudo…


(sewer6) #7

Czyli przed każdą komendą pisać sudo?

 


(saturno) #8

Pokaż wynik polecenia:

df

 


(sewer6) #9

Oto wynik df:

Filesystem     1K-blocks     Used Available Use% Mounted on


(Amaterasu) #10

W Linuksie jest inaczej niżeli w Windowsie; nie ma dysków C, D itd. Poza tym, jest różnica pomiędzy dyskiem a partycją, ale system MS będzie i tak wmawiał, że wszystko jest takie same. Bo nie jest!

Partycja - utworzona na dysku lokacja, dzięki której można zapisać na nim dane. W Linuksie jest ona oznaczana cyframi na końcu oznaczenia dysku, np. sda4, sdb3.

Dysk - urządzenie służące do tworzenia partycji i zapisywania na nich danych. W Linuksie dyski oznacza się literami według alfabetu po sd, np. sda, sdb, sdc, sdd itd.

Poza tym, w komendach, które Ci podałam, nie daje się numeru partycji, tylko po prostu dysk, np. /dev/sda

Podłączonych urządzeń masz do komputera aż trzy (sda, sdb oraz sdc). Z moich obserwacji wynika, że wszystko masz zainstalowane na sda. Zatem wpisz moją ostatnią komendę, zamień sdX na sda.

Uwaga, post pisany na szybkiego. Proszę zbytnio nie czepiać się definicji na temat różnic pomiędzy partycją a dyskiem, miało to tylko na zadanie wyjaśnić sda itd. Jeżeli szukacie pewniejszego źródła, wejdźcie do Google.


(sewer6) #11

Wszystko weszło, ale po restarcie wywaliło mi gruba w trybie tekstowym. Co teraz?


(sewer6) #12

Okazało się, że grub wywalił błąd, ale udało mi się go naprawić. Teraz zmagam się z innym problemem. Co mi po tym, że mogę wybrać system, skoro nie działa klawiatura. Domyślam się, że dlatego, że jest na USB, ale jak mam to naprawić?


(flecht) #13

Nie wiem, czy to pomoże, ale możesz sprawdzić w BIOSie, czy masz włączone wsparcie dla klawiatury USB.


(sewer6) #14

Gdzie znajduje się taka opcja? Było wsparcie dla klawiatury na PS/2. Przestawiłem z Disabled na coś innego.


(flecht) #15

Szukajcie, a znajdziecie. Pozycja może nazywać się Legacy USB keyboard support.


(sewer6) #16

Znalazłem Legacy USB Support, zmieniłem na enabled i działa! Ogólnie Enabled to znaczy włączone tak?, a Disabled wyłączone? (angielski u mnie leży i kwiczy)

 


(Amaterasu) #17

Yup. Jak nie masz pewności to spytaj się Wujka Google’a :].