Logowanie by pion- nie dziala :(


(Reksio151) #1

Sciagnalem sobie system logowania i rejestracji by pion wrzucilem go na serwer a on nie dziala:/ po wpisaniu sanych i nacisnieciu wyslij wszystkie dane znikaja :confused: a powinno wyswietlic mi sie okno ze rejestracja sie powiodla ...

http://www.e-kler.iglu.cz/logowanie_by_pion- tu jest dzialajacy skrypt

http://www.reksiosite.ovh.org/log/index.php-tu%20nie%20dziala

http://www.reksiosite.ovh.org/logowanie_by_pion.rar-to jest ten skrypt


(Skr3czu) #2

Mi tam działa,weź powiedz dokładnie co Ci nie działa?


(Reksio151) #3

Ale sprawdzales na moejj stronce czy dziala http://www.reksiosite.ovh.org/log/index.php

bo jak ja u mnie sprawdzalem to nie dzialalo,a dokladnie to jak chcialem stworzyc nowe konto, wpisalem dane i nacisnalem wyslij to wszystkie dane mi znieknely i nie zrobilo mi konta:/

I mam jeszcze jeden problem z skryptem newsor jak napisze jakis komentarz to po odswiezeniu strony robi sie nowy komentarz taki sam jak poprzedni:/

oto kod:

<?php

function load($file){

$plik = @file( $file ) ;

if ( empty( $plik )) return “” ;

$count = count( $plik ) ;

for( $a = 0 ; $a < $count ; $a++ )

$e[$a] = chop( $plik[$a] ) ;

return $e ;

}

function add($file, $line ){

if(file_exists( $file )){$plik = @fopen( $file, “a” );}

flock( $plik, 2 ) ;

fwrite( $plik, $line ) ;

flock( $plik, 3 ) ;

fclose( $plik ) ;

}

if ($_POST[‘opisy’]){

$nick=$_POST[‘nick’]; $opis=$_POST[‘opis’]; $autor=$_POST[‘autor’];

add(“dane.dat”, “Temat:”.$nick."
Tresc:".$opis."
Autor:".$autor."

\n");

}

?>

cellspacing="0">
Temat:
Nick:
Tresc: style="width:155px;"> value="Dodaj">
Newsy dodane: \<?php $tmp=load("dane.dat"); ?\>[/code]

(Skr3czu) #4

Może nie nadałeś dla logowania odpowiednich chmodów


(Reksio151) #5

Ja dalem chmody dla tych plikow i folderow gdzie sie zapisuja pliki a dla tych z rozszerzeniem .php nie dalem. Ale sprobuje zrobic i nadam chmody tym plikom tez