Logowanie do zasobów sieciowych w systemach Windows


(Motylbb5) #1

Witam

Nie do końca potrafię zrozumieć zasadę logowania w systemach Windows do zasobów sieciowych.

Dlaczego chcąc dostać się do zasobu sieciowego muszę być zalogowany na moim komputerze na koncie o takiej samej nazwie jak konto w miejscu gdzie chcę się dostać?

Nie wiem czy czegoś nie robię źle ale opiszę jak to wygląda:

  1. Przy włączaniu komputera loguję się lokalnie (czyli “na pulpit” a nie do domeny) na konto o nazwie “motyl”.

  2. Po zalogowaniu działa mi wszystko: sieć lokalna i internet.

  3. Chcę się teraz podłączyć do zasobu sieciowego, który jest na urządzeniu NAS. Jest tam kilka katalogów i każdy z nich jest chroniony hasłem.

Jeden z nich jest przeznaczony dla mnie ale mogę się na niego zalogować tylko jako użytkownik “admin”.

Denerwujące jest to, że jeżeli siadam do nie mojego komputera gdzie nie ma lokalnie konta “admin” to nie mogę się zalogować do NAS (do tego katalogu) chociaż podaję poprawnie login i hasło.

Wystarczy, że stworzę na tym komputerze lokalnego użytkownika “admin” i już działa.

Czy nie da się tego zrobić tak, że z dowolnego lokalnego użytkownika zostanę tam wpuszczony gdy wpiszę dane poprawnie czyli login “admin” i hasło do niego?


(Pablo_Wawa) #2

Tak działa skrócone uwierzytelnianie. Rozwiązaniem jest użycie prostego skryptu (lub wpisanie tego ręcznie w linii poleceń):

net use Z: \\adres.serwera.NAS\ZASÓB /user:admin

co podmapuje Ci ten zasób jako dysk Z:, być może będziesz musiał podać jeszcze hasło do konta admin.


(Motylbb5) #3

Dzięki, działa :slight_smile:

A możesz mi powiedzieć dlaczego w GUI (Explorator Windows) nie pozwala mi się zalogować jeżeli nie jestem zalogowany lokalnie jako “admin” pomimo istnienia na tym komputerze takiego użytkownika? Dziwi mnie to, że konsola mnie wpuszcza a Explorator wyświetla komunikat:

Problem w tym, że nie jestem tam zalogowany.

Sprawdzam to tak:

net use

O co tu chodzi?


(Pablo_Wawa) #4

Powodem takiego zachowania (odrzucania próby zalogowania się do zasobu sieciowego) jest prawdopodobnie uproszczone logowanie (uwierzytelnianie), polegające na sprawdzeniu nazwy użytkownika (loginu) i ewentualnie hasła i jeśli bieżący użytkownik nie ma żadnego prawa do żadnego zasobu, to żądanie jest automatycznie odrzucane - nie ma tego drugiego elementu, czyli okienka logowania.

Nie wiem, po czyjej stronie jest “problem” - czy po stronie Windows, czy serwera plików. Nie wnikałem głębiej, bo wiem jak “obejść” problem. :slight_smile:

Być może jak poszukasz o tym w internecie, to będzie to wyjaśnione.


(Motylbb5) #5

OK… poszukam może gdzieś znajdę opis. Na tę chwilę dzięki za podpowiedzi.