Lubuntu 12.04 - nie startuje


(Wieloiksiasty) #1

Zainstalowałem na starszym laptopie Lubuntu 12.04 za pomocą alternatywnego instalatora (ze względu na małą ilość ramu w komputerze). Instalacja przebiegła bezproblemowo. Po restarcie systemu pojawił się pierwszy problem, linux nie uruchomił się ponownie. Na ekranie migał jedynie kursor. Po próbie bootowania za pomocą PLOP'a dostaję kominikat:

WARNING:

NO VALID BOOTSECTOR SIGNATURE

CONTINUE BOOT? [Y/N]

Po wybraniu 'Y', nic się nie dzieje na ekranie pojawia się z powrotem PLOP. Próbowałem też przywrócić gruba za pomocą instalatora w trybie ratunkowym. Rezultat to kominikat:

Unable to install GRUB in /dev/sda

Executing 'grub-install /dev/sda' failed.


This is a fatal error.

Jakieś propozycje?


(roobal) #2

Pobierz SuperGrubDisk 2, sparwdź czy wykryje system zainstalowany na dysku i jeśli wykryje, spróbuj za jego pomocą uruchomić Lubuntu.

Dziwna sprawa, sprawdź czy system w trybie ratunkowym nie montuje partycji w trybie tylko do odczytu, ale myślę, że system powinien o tym powiadomić, mimo wszystko sprawdź to jeszcze.

Pozdrawiam!


(Wieloiksiasty) #3

SuperGrubDisk nic nie wykrył, ale udało mi się zbootować ubuntu w ten sposób: http://jakilinux.org/linux/wszystko-o-grub/. Czyli z linii poleceń. System zaczął startować, niestety zatrzymał się zaraz za:

(initramfs) [3.320220] firewire_core: created device fw0: GUID a00d080028b32cd1, S400

Potem pojawiło się coś w rodzaju promptu:

(initramfs)

i linux pozwolił wpisywać komendy, jednak Lubuntu nadal nie odpala się tak jak powinno. :-x

W trybie ratunkowym po ponownej instalacji systemu reinstall gruba przebiega bez errorów, jednak nie daje też żadnych rezultatów. Partycja jest montowana i do odczytu i do zapisu.


(roobal) #4

To co się uruchamia to BusyBox. Jeśli partycje są montowane poprawnie, sprawdź ich zawartość.

Pozdrawiam!


(Wieloiksiasty) #5

W trybie ratunkowym poprawnie uruchamiana jest tylko partycja /dev/sda1, czyli ta która powinna zawierać system i rzeczywiście ta partycja zawiera system. Pozostałe partycje, które miały służyć za /home oraz /usr nie chcą się w żaden sposób zamontować.


(roobal) #6

Możliwe, że system plików jest uszkodzony, miałem kiedyś podobny problem. Spróbuj jeszcze raz zainstalować system.

Pozdrawiam!


(Sebix99) #7

xxx-xxx001 - Próbowałeś sam zamontować partycję w konsoli dla testu?


(mati75) #8

SeBiX99 w busybox nie da się zamontować NICZEGO! Po raz kolejny piszesz o czymś, o czym nie masz zielonego pojęcia. xxx-xxx001 spróbuj z mini.iso zainstalować.


(Sebix99) #9

Bardziej mi chodziło o zamontowanie na trybie awaryjnym. Jeszcze jedno to że w BusyBox nie można to nie znaczy że nie można wsadzić płytki z liveCD -,-


(Wieloiksiasty) #10

Dzięki za pomoc. Problem rozwiązałem istalując Linux Mint 12 LXDE, który bardzo mi się spodobał.