Macchanger nie startuje w czasie bootowania


(Raf20076) #1

Witam wszystkich.

Zainstalowałem macchanger’a w Debianie Jessie i następnie stworzyłem sobie skrypt, który powinien startować wraz ze startem komputera w czasie bootowania.

#!/bin/bash

### BEGIN INIT INFO
# Provides: macchanger
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time
# Description: Enable service provided by daemon.
### END INIT INFO

# Wyłączenie karty bezprzewodowej

ifconfig wlan0 down

# Wygenerowanie losowo nowego numeru MAC

macchanger -r wlan0

# Włączenie karty bezprzewodowej

ifconfig wlan0 up

Zapisałem plik a następnie skopiowałem go do

cp macchanger /etc/init.d/

Nadałem prawa uruchomiania

chmod +x /etc/init.d/macchanger

I utworzyłem dowiązanie do uruchomienia serwisu

update-rc.d macchanger defaults 90

Mimo to macchanger nie startuje wraz z systemem. Muszę dodać że podobnie mam zainstalowany skrypt iptables też

update-rc.d firewall defaults 90

i on startuje normalnie.

Czy ktoś ma jakiś pomysł?

Rozwiązałem

#!/bin/bash

### BEGIN INIT INFO
# Provides: macchanger
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time
# Description: Enable service provided by daemon.
### END INIT INFO

Powinno być

#!/bin/bash

### BEGIN INIT INFO
# Provides: macchanger
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time
# Description: Enable service provided by daemon.
### END INIT INFO

było

#!/bin/bash

Powinno być bez spacji od brzegu

#!/bin/bash