Mandriva le 2005 i gf 6600 - jak?


(Bartlomiej Kwiatkowski) #1

jestem zielony w linuksie. Troche o tym czytałem i próbowałem, ale w sumie nadal nie wiem jak zainstalować sterowniki do GF 6600 w Mandrivie Limited Edition 2005 (to jest chyba mandrake 10.2 z tego co się orientuję).

Przy instalacji mandrivy wybrałem kartę graficzną Vesa, bo z grupy Nvidia żadna nie chciała działać. Teraz mam niebotyczne 60 Hz na monitorze crt...

Chcę zainstalować stery nvidii, bo mam zamiar odpalić parę gier w przyszłości (na przykład Kohan: Immortal Sovereigns 8)

Pomożcie proszę bo sam tego nie zrobię :-k


#2
  1. Zainstalować źródła jądra (jeżeli jeszcze nie masz)

  2. Wyłączyć iksy (ctrl+alt+F1, zalogować się jako root, wpisać telinit 3)

  3. Przejśc do katalogu ze sterownikami

  4. wpisać sh NVIDIA-nrwersji-itp.run

  5. Wyedytować /etc/X11/xorg.conf i zmienić “vesa” na “nvidia”

  6. Odpalić iksy (telinit 5)

Piszę to bo się nudzę, te informacje można w ciągu max. minuty znaleźć na google, albo chociażby zajrzeć do przyklejonych tutaj wątków.


(Bartlomiej Kwiatkowski) #3

areh,

który sterownik powinienem ściągnąć z http://www.nvidia.com? mam do wyboru:

Linux IA32, Linux AMD64/EM64T i Linux IA64.

Nie wiem jak wykonać twój 1. punkt :stuck_out_tongue:


#4

Sterowniki wybierz do Twojej architektury. Jeżeli masz zwykłego Pentiuma, Celerona, Athlona czy Durona, to IA32, jeżeli masz procka 64-o bitowego, to albo AMD64, albo IA64 (w zależności od tego czy masz Pentiuma czy AMD).

Źródła jądra masz na płycie (chyba, od dawna nie widziałem Mandrake/Mandriva na oczy). Jeżeli ich tam nie ma, będziesz musiał poszukać w necie, albo najlepiej skonfiguruj sobie urpmi (jeżeli nie wiesz jak, wpisz w google “easyurpmi”). Instaluje się je tak samo jak inne pakiety. Pamiętaj tylko, żeby zainstalować źródła do tego jądra którego używasz.


(Bartlomiej Kwiatkowski) #5

jak odpalam polecenie:

sh NVIDIA-Linux-x86-1.0-7676-pkg1.run

to pokazuje się umowa licencyjna a potem parę komunikatów o błędach. Jeden mówi, że brakuje jakiegos pliku “… .ko”

i że prawdopodobnie jądro zostało skompilowane przy pomocy złych plików źródłowych…

Nawet nie wiem jak wkleić na forum te komunikaty, bo wszystkie polecenia wykonuję po wyłączeniu X-ów :confused:

Żaden ze standardwych opisów tej instalacji nie działa.


#6

A źródła jądra zainstalowałeś do dokładnie takiej wersji jaką posiadasz?


(Bartlomiej Kwiatkowski) #7

uruchomiłem “Instalacja oprogramowania” z menu, potem wyszukałem kernel-source i to zainstalowałem. Nawet nie patrzyłem co instaluję… (typowo po lamersku)


(>Ziom<) #8

To następnym razem patrz. Zorientuj się jaki masz kernel i wybierz źródła w dokładnie takiej samej wersji.


(Bartlomiej Kwiatkowski) #9

znalazłem w końcu komendę: cat /proc/version

wynik:

Linux version 2.6.11-6.mdk (gb@n2.mandrakesoft.com) (gcc version 3.4.3 (Mandrakelinux 10.2 3.4.3-3mdk)) #1 True i data

tylko co dalej ?


#10

Zainstalować źródła kernela do tej wersji jądra, czyli kernel-source-2.6.11-6.mdk. Wcześniej odinstalować te które zainstalowałeś, chyba że masz właśnei te, to problem leży gdzie indziej.

Możesz spróbować zainstalować sterowniki w trybie graficznym, wtedy będziesz mógł podczas nieudanej próby instalacji skopiować tutaj błędy. Zresztą, teraz też możesz, bo są zapisane w logach. Podczas instalacji na pewno było napisane co im nie pasuje i gdzie są logi z instalacji.

Co do instalacji sterowników bez wyłączania iksów, to wystarczy w /tmp skasować plik .X0-lock.


(Bartlomiej Kwiatkowski) #11

błagam jak piszecie, żebym coś zrobil, to napiszcie jeszcze jak, bo to nie windows…

instaluj… odinstaluj… dla mnie to czarna magia…


find .X0-lock: no such file or directory


ha! menu->System->Komfiguracja->Pakiety->Usuwanie oprogramowania :slight_smile:

kernel-source-2.6-2.6.11-6mdk

mam to odinstalować?


(>Ziom<) #12

Nie. Są dobre. (tak mi się wydaje)


(Bartlomiej Kwiatkowski) #13

Więc tak moi drodzy:

a) zamykam iksy, wchodzę na superużytkownika, zmieniam poziom pracy na 3

i uruchamiam instalatora komendą:

sh NVIDIA-Linux-x86-1.0-7676-pkg1.run

b) pojawia się treść umowy licencyjnej NVIDII - wybieram Accept c) pojawia się komunikat:

No precompiled kernel iterface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from NVIDIA ftp site (ftp://download.nvidia.com)?
  • wybieram OK d) pojawia się chyba jakiś komunikat o błędzie, ale przez mniej niż sekundę, więc nie zdążę go przeczytać e) kolejny komunikat:

    Building kernel module

  • jest pokazany pasek postępu, dochodzi do 100 % f) komunikat:

    ERROR: Unable to load the kernel module ‘nvidia.ko’. This is most likely because the kernel module was built using the wrong kernel source files. Please make sure you have installed the kernel source files for your kernel; on Red Hat Linux systems, for example, be sure you have the ‘kernel-source’ rpm installed. If you know the the correct kernel source files are installed, you may specify the kernel source path with the ‘kernel-source-path’ commandline option.

  • do wyboru mam tylko OK g) ostatni komunikat instalatora:

    ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

  • znów do wyboru jest OK

W tym momencie instalator kończy pracę :olaboga:


#14
No precompiled kernel iterface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from NVIDIA ftp site (ftp://download.nvidia.com)?

W tym momencie spróbuj wybrać “No”. Wtedy przebuduje to co znajdzie na dysku - właśnie min. po to były potrzebne źródła jądra (sprawdż czy w /usr/src masz symlinka “linux” który wskazuje na Twoje źródła, ale raczej powinno to być).


(Bartlomiej Kwiatkowski) #15

ten symlink jest dokładnie tak jak to opisałeś, ale jeśli wybiorę opcję’nie pobieraj z ftp nvidii, to dalej jest samo co wcześniej od punktu f). Wychodzi na to, że bez tego modułu ‘nvidia.ko’ nic nie zdziałam chyba :confused:

Jeśli to pomoże, to w /etc/X11/xorg.conf mam wpis:

Section "Device"

    Identifier "device1"

    BoardName "VESA driver (generic)"

    Driver "vesa"

    Option "DPMS"

EndSection

----- na dodatek wczoraj sie bawiłem (w ramach nauki) i podczas działania komendy urpmi kernel-source wcisnąłem CTRL + Z. Teraz jak odpalam to polecenie, dostaję komunikat:

error: /var/cache/urpmi/rpms/kernel-source-2.6-2.6.11-12mdk.i586.rpm: headerRead failed

Następujące pakiety zawierają niepoprawne podpisy:

var/cache/urpmi/rpms/kernel-source-2.6-2.6.11-12mdk.i586.rpm: Brakujący podpis (Unable to read rpm file)

Czy chcesz kontynuować instalację? (y/N)

jak to naprawić?

P.S. już nie będę się bawił bez instrukcji :aniol:


#16

Co do sterowników, to jako rozwiązanie zastępcze proponuję zmienić “vesa” na “nv”, oraz ustawić odpowiednie odświeżanie w tym samym pliku.


(Bartlomiej Kwiatkowski) #17

mówisz może o pliku /etc/X11/Xorg.conf ? i o sekcji Device ?

jeśli tak, to jutro z rańca się za to biorę, bo zaraz do wyrka spadam :ziew: